Recommended update for mdadm

SUSE Recommended Update: Recommended update for mdadm
Announcement ID: SUSE-RU-2019:14081-1
Rating: moderate
References: #1081286 #1082766 #1095141 #1095729 #1096363 #1105175
Affected Products:
  • SUSE Linux Enterprise Server 11-SP4-LTSS
  • SUSE Linux Enterprise Debuginfo 11-SP4

An update that has 6 recommended fixes can now be installed.

Description:

This update for mdadm provides the following fixes:

  • Assemble: Prevent a segmentation fault with faulty "best" devices. (bsc#1082766, bsc#1095729)

  • Do not use the bad_blocks and unacknowledged_bad_blocks sysfs entries which are not available in SLE11-SP4 kernel. (bsc#1105175)


  • Accept option '--brief' with '--export' (bsc#1095141) Call mdadm --detail --export with --brief in 64-md-raid.rules. This should prevent overflow on large deployment.
  • md_monitor: use pselect (bsc#1095141)
  • md_monitor: fix crash in display_io_status (bsc#1096363)
  • md_monitor: fixup crash in display_md_status (bsc#1081286), (bsc#1096363)

  • Delete code that require sysfs entries bad_blocks and unacknowledged_bad_blocks which are not in SLE11-SP4 kernel. (bsc#1105175)

Patch Instructions:

To install this SUSE Recommended Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
Alternatively you can run the command listed for your product:

  • SUSE Linux Enterprise Server 11-SP4-LTSS:
    zypper in -t patch slessp4-mdadm-14081=1
  • SUSE Linux Enterprise Debuginfo 11-SP4:
    zypper in -t patch dbgsp4-mdadm-14081=1

Package List:

  • SUSE Linux Enterprise Server 11-SP4-LTSS (i586 ppc64 s390x x86_64):
    • mdadm-3.3.1-10.27.4
  • SUSE Linux Enterprise Debuginfo 11-SP4 (i586 ppc64 s390x x86_64):
    • mdadm-debuginfo-3.3.1-10.27.4
    • mdadm-debugsource-3.3.1-10.27.4

References: