Recommended update for SUSEConnect

SUSE Recommended Update: Recommended update for SUSEConnect
Announcement ID: SUSE-RU-2019:1260-1
Rating: moderate
References: #1128969 #959561
Affected Products:
  • SUSE Linux Enterprise Module for Basesystem 15

An update that has two recommended fixes can now be installed.

Description:

This update for SUSEConnect fixes the following issues:

  • Does no longer try to remove a service during migration, if a zypper service plugin already exists (bsc#1128969)
  • Shows non-enabled extensions with a remark about availability
  • Adds output information about registration and unregistration progress
  • Output proper message when SUSEConnect is called without parameters (bsc#959561)
  • Default to https URI when no protocol prefix is provided for --url
  • Support transactional-update systems (fate#326482)

Patch Instructions:

To install this SUSE Recommended Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
Alternatively you can run the command listed for your product:

  • SUSE Linux Enterprise Module for Basesystem 15:
    zypper in -t patch SUSE-SLE-Module-Basesystem-15-2019-1260=1

Package List:

  • SUSE Linux Enterprise Module for Basesystem 15 (aarch64 ppc64le s390x x86_64):
    • SUSEConnect-0.3.17-3.16.1

References: