Recommended update for open-iscsi

SUSE Recommended Update: Recommended update for open-iscsi
Announcement ID: SUSE-RU-2019:1114-1
Rating: moderate
References: #1127913 #1128972
Affected Products:
  • SUSE Linux Enterprise Module for Basesystem 15

An update that has two recommended fixes can now be installed.

Description:

This update for open-iscsi fixes the following issues:

  • Fix a regression in behavior of iscsiadm caused by the switch to libopeniscsiusr (bsc#1128972)

  • Prevent iscsiuio segmentation fault in case get_tx_pkt fails while sending ARP (bsc#1127913)

Patch Instructions:

To install this SUSE Recommended Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
Alternatively you can run the command listed for your product:

  • SUSE Linux Enterprise Module for Basesystem 15:
    zypper in -t patch SUSE-SLE-Module-Basesystem-15-2019-1114=1

Package List:

  • SUSE Linux Enterprise Module for Basesystem 15 (aarch64 ppc64le s390x x86_64):
    • iscsiuio-0.7.8.2-13.26.1
    • iscsiuio-debuginfo-0.7.8.2-13.26.1
    • libopeniscsiusr0_2_0-2.0.876-13.26.1
    • libopeniscsiusr0_2_0-debuginfo-2.0.876-13.26.1
    • open-iscsi-2.0.876-13.26.1
    • open-iscsi-debuginfo-2.0.876-13.26.1
    • open-iscsi-debugsource-2.0.876-13.26.1
    • open-iscsi-devel-2.0.876-13.26.1

References: