Recommended update for mariadb-connector-c

SUSE Recommended Update: Recommended update for mariadb-connector-c
Announcement ID: SUSE-RU-2019:0963-1
Rating: moderate
References: #1116686
Affected Products:
  • SUSE Linux Enterprise Server 12-SP4
  • SUSE Linux Enterprise Desktop 12-SP4

An update that has one recommended fix can now be installed.

Description:

This update for mariadb-connector-c to version fixes the following issues:

  • New upstream version 3.0.7 (bsc#1116686)
  • CONC-370: Fixed memory leak in configuration file parsing.
  • CONC-371: Incorrect fractional part conversion when converting datetime string to MYSQL_TIME
  • CONC-283: Fixed pkg-config configuration
  • CONC-364: Not all sockets created in pvio_socket_connect function are closed
  • Multiple fixes in named pipe implementation
  • CONC-349: Added new parameter STMT_ATTR_STATE to retrieve statement status via api function mysql_stmt_attr_get

Patch Instructions:

To install this SUSE Recommended Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
Alternatively you can run the command listed for your product:

  • SUSE Linux Enterprise Server 12-SP4:
    zypper in -t patch SUSE-SLE-SERVER-12-SP4-2019-963=1
  • SUSE Linux Enterprise Desktop 12-SP4:
    zypper in -t patch SUSE-SLE-DESKTOP-12-SP4-2019-963=1

Package List:

  • SUSE Linux Enterprise Server 12-SP4 (aarch64 ppc64le s390x x86_64):
    • libmariadb3-3.0.7-2.3.8
    • libmariadb3-debuginfo-3.0.7-2.3.8
    • libmariadb_plugins-3.0.7-2.3.8
    • libmariadb_plugins-debuginfo-3.0.7-2.3.8
    • mariadb-connector-c-debugsource-3.0.7-2.3.8
  • SUSE Linux Enterprise Desktop 12-SP4 (x86_64):
    • libmariadb3-3.0.7-2.3.8
    • libmariadb3-debuginfo-3.0.7-2.3.8
    • libmariadb_plugins-3.0.7-2.3.8
    • libmariadb_plugins-debuginfo-3.0.7-2.3.8
    • mariadb-connector-c-debugsource-3.0.7-2.3.8

References: