Recommended update for grub2

SUSE Recommended Update: Recommended update for grub2
Announcement ID: SUSE-RU-2019:0945-1
Rating: moderate
References: #1113702 #1122569
Affected Products:
  • SUSE Linux Enterprise Server 12-SP3
  • SUSE Linux Enterprise Desktop 12-SP3
  • SUSE CaaS Platform ALL
  • SUSE CaaS Platform 3.0

An update that has two recommended fixes can now be installed.

Description:

This update for grub2 fixes the following issues:

  • Fixed a regression of crashing lvm on multipath SAN (bsc#1113702)
  • Add exception handling to FCP lun enumeration (bsc#1113702)
  • Fix LOADER_TYPE parsing in grub2-once (bsc#1122569)

Patch Instructions:

To install this SUSE Recommended Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
Alternatively you can run the command listed for your product:

  • SUSE Linux Enterprise Server 12-SP3:
    zypper in -t patch SUSE-SLE-SERVER-12-SP3-2019-945=1
  • SUSE Linux Enterprise Desktop 12-SP3:
    zypper in -t patch SUSE-SLE-DESKTOP-12-SP3-2019-945=1
  • SUSE CaaS Platform ALL:
    To install this update, use the SUSE CaaS Platform Velum dashboard. It will inform you if it detects new updates and let you then trigger updating of the complete cluster in a controlled way.
  • SUSE CaaS Platform 3.0:
    To install this update, use the SUSE CaaS Platform Velum dashboard. It will inform you if it detects new updates and let you then trigger updating of the complete cluster in a controlled way.

Package List:

  • SUSE Linux Enterprise Server 12-SP3 (aarch64 ppc64le s390x x86_64):
    • grub2-2.02-4.40.1
    • grub2-debuginfo-2.02-4.40.1
  • SUSE Linux Enterprise Server 12-SP3 (aarch64 s390x x86_64):
    • grub2-debugsource-2.02-4.40.1
  • SUSE Linux Enterprise Server 12-SP3 (ppc64le):
    • grub2-powerpc-ieee1275-2.02-4.40.1
  • SUSE Linux Enterprise Server 12-SP3 (aarch64):
    • grub2-arm64-efi-2.02-4.40.1
  • SUSE Linux Enterprise Server 12-SP3 (x86_64):
    • grub2-i386-pc-2.02-4.40.1
    • grub2-x86_64-efi-2.02-4.40.1
    • grub2-x86_64-xen-2.02-4.40.1
  • SUSE Linux Enterprise Server 12-SP3 (noarch):
    • grub2-snapper-plugin-2.02-4.40.1
    • grub2-systemd-sleep-plugin-2.02-4.40.1
  • SUSE Linux Enterprise Server 12-SP3 (s390x):
    • grub2-s390x-emu-2.02-4.40.1
  • SUSE Linux Enterprise Desktop 12-SP3 (x86_64):
    • grub2-2.02-4.40.1
    • grub2-debuginfo-2.02-4.40.1
    • grub2-debugsource-2.02-4.40.1
    • grub2-i386-pc-2.02-4.40.1
    • grub2-x86_64-efi-2.02-4.40.1
    • grub2-x86_64-xen-2.02-4.40.1
  • SUSE Linux Enterprise Desktop 12-SP3 (noarch):
    • grub2-snapper-plugin-2.02-4.40.1
    • grub2-systemd-sleep-plugin-2.02-4.40.1
  • SUSE CaaS Platform ALL (noarch):
    • grub2-snapper-plugin-2.02-4.40.1
  • SUSE CaaS Platform ALL (x86_64):
    • grub2-2.02-4.40.1
    • grub2-debuginfo-2.02-4.40.1
    • grub2-debugsource-2.02-4.40.1
    • grub2-i386-pc-2.02-4.40.1
    • grub2-x86_64-efi-2.02-4.40.1
    • grub2-x86_64-xen-2.02-4.40.1
  • SUSE CaaS Platform 3.0 (x86_64):
    • grub2-2.02-4.40.1
    • grub2-debuginfo-2.02-4.40.1
    • grub2-debugsource-2.02-4.40.1
    • grub2-i386-pc-2.02-4.40.1
    • grub2-x86_64-efi-2.02-4.40.1
    • grub2-x86_64-xen-2.02-4.40.1
  • SUSE CaaS Platform 3.0 (noarch):
    • grub2-snapper-plugin-2.02-4.40.1

References: