Recommended update for rpm

SUSE Recommended Update: Recommended update for rpm
Announcement ID: SUSE-RU-2019:0894-1
Rating: moderate
References: #1119414 #1126327 #1129753
Affected Products:
  • SUSE Linux Enterprise Module for Development Tools 15
  • SUSE Linux Enterprise Module for Basesystem 15

An update that has three recommended fixes can now be installed.

Description:

This update for rpm fixes the following issues:

  • This update shortens RPM changelog to after a certain cut off date (bsc#1129753)
  • Translate dashes to underscores in kmod provides (FATE#326579, jsc#SLE-4117, jsc#SLE-3853, bsc#1119414).
  • Re-add symset-table from SLE 12 (bsc#1126327).

Patch Instructions:

To install this SUSE Recommended Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
Alternatively you can run the command listed for your product:

  • SUSE Linux Enterprise Module for Development Tools 15:
    zypper in -t patch SUSE-SLE-Module-Development-Tools-15-2019-894=1
  • SUSE Linux Enterprise Module for Basesystem 15:
    zypper in -t patch SUSE-SLE-Module-Basesystem-15-2019-894=1

Package List:

  • SUSE Linux Enterprise Module for Development Tools 15 (aarch64 ppc64le s390x x86_64):
    • rpm-build-4.14.1-10.16.1
    • rpm-build-debuginfo-4.14.1-10.16.1
    • rpm-debuginfo-4.14.1-10.16.1
    • rpm-debugsource-4.14.1-10.16.1
  • SUSE Linux Enterprise Module for Basesystem 15 (aarch64 ppc64le s390x x86_64):
    • python-rpm-debugsource-4.14.1-10.16.1
    • python2-rpm-4.14.1-10.16.1
    • python2-rpm-debuginfo-4.14.1-10.16.1
    • python3-rpm-4.14.1-10.16.1
    • python3-rpm-debuginfo-4.14.1-10.16.1
    • rpm-4.14.1-10.16.1
    • rpm-debuginfo-4.14.1-10.16.1
    • rpm-debugsource-4.14.1-10.16.1
    • rpm-devel-4.14.1-10.16.1
  • SUSE Linux Enterprise Module for Basesystem 15 (x86_64):
    • rpm-32bit-4.14.1-10.16.1
    • rpm-32bit-debuginfo-4.14.1-10.16.1

References: