Recommended update for fence-agents

SUSE Recommended Update: Recommended update for fence-agents
Announcement ID: SUSE-RU-2019:0626-1
Rating: moderate
References: #1088358
Affected Products:
  • SUSE Linux Enterprise High Availability 12-SP3

An update that has one recommended fix can now be installed.

Description:

This update for fence-agents fixes the following issues:
A new Google Compute Engine image client was added (fence_ge):

  • fence_gce: new agent (pull#159) (fate#325539) (bsc#1088358)
  • fence_gce: zone & project parameters are mandatory (pull#177) (fate#325539) (bsc#1088358)
  • fence_gce: Clean up and log errors (pull#194) (fate#325539) (bsc#1088358)
  • fence_gce: google-auth instead of oauth2client (pull#197)
  • fence_gce: logging and non required parameters (pull##211)
  • fence_gce: filter call to aggregatedList (pull#218)

Patch Instructions:

To install this SUSE Recommended Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
Alternatively you can run the command listed for your product:

  • SUSE Linux Enterprise High Availability 12-SP3:
    zypper in -t patch SUSE-SLE-HA-12-SP3-2019-626=1

Package List:

  • SUSE Linux Enterprise High Availability 12-SP3 (ppc64le s390x x86_64):
    • fence-agents-4.0.25+git.1485179354.eb43835-4.11.1
    • fence-agents-debuginfo-4.0.25+git.1485179354.eb43835-4.11.1
    • fence-agents-debugsource-4.0.25+git.1485179354.eb43835-4.11.1

References: