Recommended update for cups

SUSE Recommended Update: Recommended update for cups
Announcement ID: SUSE-RU-2019:0608-1
Rating: moderate
References: #1118118
Affected Products:
  • SUSE Linux Enterprise Module for Development Tools 15
  • SUSE Linux Enterprise Module for Desktop Applications 15
  • SUSE Linux Enterprise Module for Basesystem 15

An update that has one recommended fix can now be installed.

Description:

This update for cups fixes the following issues:

  • Fixed validation of UTF-8 filenames to avoid crashes (bsc#1118118)

Patch Instructions:

To install this SUSE Recommended Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
Alternatively you can run the command listed for your product:

  • SUSE Linux Enterprise Module for Development Tools 15:
    zypper in -t patch SUSE-SLE-Module-Development-Tools-15-2019-608=1
  • SUSE Linux Enterprise Module for Desktop Applications 15:
    zypper in -t patch SUSE-SLE-Module-Desktop-Applications-15-2019-608=1
  • SUSE Linux Enterprise Module for Basesystem 15:
    zypper in -t patch SUSE-SLE-Module-Basesystem-15-2019-608=1

Package List:

  • SUSE Linux Enterprise Module for Development Tools 15 (aarch64 ppc64le s390x x86_64):
    • cups-ddk-2.2.7-3.9.1
    • cups-ddk-debuginfo-2.2.7-3.9.1
    • cups-debuginfo-2.2.7-3.9.1
    • cups-debugsource-2.2.7-3.9.1
  • SUSE Linux Enterprise Module for Desktop Applications 15 (x86_64):
    • cups-debugsource-2.2.7-3.9.1
    • libcups2-32bit-2.2.7-3.9.1
    • libcups2-32bit-debuginfo-2.2.7-3.9.1
  • SUSE Linux Enterprise Module for Basesystem 15 (aarch64 ppc64le s390x x86_64):
    • cups-2.2.7-3.9.1
    • cups-client-2.2.7-3.9.1
    • cups-client-debuginfo-2.2.7-3.9.1
    • cups-config-2.2.7-3.9.1
    • cups-debuginfo-2.2.7-3.9.1
    • cups-debugsource-2.2.7-3.9.1
    • cups-devel-2.2.7-3.9.1
    • libcups2-2.2.7-3.9.1
    • libcups2-debuginfo-2.2.7-3.9.1
    • libcupscgi1-2.2.7-3.9.1
    • libcupscgi1-debuginfo-2.2.7-3.9.1
    • libcupsimage2-2.2.7-3.9.1
    • libcupsimage2-debuginfo-2.2.7-3.9.1
    • libcupsmime1-2.2.7-3.9.1
    • libcupsmime1-debuginfo-2.2.7-3.9.1
    • libcupsppdc1-2.2.7-3.9.1
    • libcupsppdc1-debuginfo-2.2.7-3.9.1

References: