Recommended update for arpwatch

SUSE Recommended Update: Recommended update for arpwatch
Announcement ID: SUSE-RU-2019:0567-1
Rating: moderate
References: #1119851
Affected Products:
  • SUSE Linux Enterprise Module for Open Buildservice Development Tools 15
  • SUSE Linux Enterprise Module for Basesystem 15

An update that has one recommended fix can now be installed.

Description:

This update for arpwatch provides the following fix:

  • Prevent a memory leak in gethname. (bsc#1119851)

Patch Instructions:

To install this SUSE Recommended Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
Alternatively you can run the command listed for your product:

  • SUSE Linux Enterprise Module for Open Buildservice Development Tools 15:
    zypper in -t patch SUSE-SLE-Module-Development-Tools-OBS-15-2019-567=1
  • SUSE Linux Enterprise Module for Basesystem 15:
    zypper in -t patch SUSE-SLE-Module-Basesystem-15-2019-567=1

Package List:

  • SUSE Linux Enterprise Module for Open Buildservice Development Tools 15 (aarch64 ppc64le s390x x86_64):
    • arpwatch-debuginfo-2.1a15-5.3.1
    • arpwatch-debugsource-2.1a15-5.3.1
    • arpwatch-ethercodes-build-2.1a15-5.3.1
  • SUSE Linux Enterprise Module for Basesystem 15 (aarch64 ppc64le s390x x86_64):
    • arpwatch-2.1a15-5.3.1
    • arpwatch-debuginfo-2.1a15-5.3.1
    • arpwatch-debugsource-2.1a15-5.3.1

References: