Recommended update for python-ovs packages

SUSE Recommended Update: Recommended update for python-ovs packages
Announcement ID: SUSE-RU-2019:0404-1
Rating: moderate
References: #1109991
Affected Products:
  • SUSE OpenStack Cloud Crowbar 8
  • SUSE OpenStack Cloud 8
  • HPE Helion Openstack 8

An update that has one recommended fix can now be installed.

Description:

This update for python-ovs, python-ovsdbapp fixes the following issues:
python-ovsdbapp:

  • Improve DbListCommand operation from O(n^2) to O(n)

python-ovs:
  • build against openvswitch-devel to enable the c extensions

Patch Instructions:

To install this SUSE Recommended Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
Alternatively you can run the command listed for your product:

  • SUSE OpenStack Cloud Crowbar 8:
    zypper in -t patch SUSE-OpenStack-Cloud-Crowbar-8-2019-404=1
  • SUSE OpenStack Cloud 8:
    zypper in -t patch SUSE-OpenStack-Cloud-8-2019-404=1
  • HPE Helion Openstack 8:
    zypper in -t patch HPE-Helion-OpenStack-8-2019-404=1

Package List:

  • SUSE OpenStack Cloud Crowbar 8 (noarch):
    • python-ovsdbapp-0.4.3-3.3.1
  • SUSE OpenStack Cloud Crowbar 8 (x86_64):
    • python-ovs-2.7.0-3.3.1
  • SUSE OpenStack Cloud 8 (x86_64):
    • python-ovs-2.7.0-3.3.1
  • SUSE OpenStack Cloud 8 (noarch):
    • python-ovsdbapp-0.4.3-3.3.1
  • HPE Helion Openstack 8 (noarch):
    • python-ovsdbapp-0.4.3-3.3.1
  • HPE Helion Openstack 8 (x86_64):
    • python-ovs-2.7.0-3.3.1

References: