Recommended update for python-django_openstack_auth

SUSE Recommended Update: Recommended update for python-django_openstack_auth
Announcement ID: SUSE-RU-2019:0266-1
Rating: moderate
References: #1109991
Affected Products:
  • SUSE OpenStack Cloud Crowbar 8
  • SUSE OpenStack Cloud 8
  • HPE Helion Openstack 8

An update that has one recommended fix can now be installed.

Description:

This update for python-django_openstack_auth fixes the following issues:

  • Add a new optional WEBSSO_KEYSTONE_URL property in order to support WEBSSO for deployments where network segmentation is used per security requirement (bsc#1109991)
  • Add .zuul.yaml for pike
  • Update UPPER_CONSTRAINTS_FILE for stable/pike
  • Zuul: Remove project name
  • Don't add required attribute to html form fields
  • Imported Translations from Zanata
  • Remove tox_install.sh usage
  • Updated from global requirements
  • Allow an action if no policy exists for it and there is no default policy.

Patch Instructions:

To install this SUSE Recommended Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
Alternatively you can run the command listed for your product:

  • SUSE OpenStack Cloud Crowbar 8:
    zypper in -t patch SUSE-OpenStack-Cloud-Crowbar-8-2019-266=1
  • SUSE OpenStack Cloud 8:
    zypper in -t patch SUSE-OpenStack-Cloud-8-2019-266=1
  • HPE Helion Openstack 8:
    zypper in -t patch HPE-Helion-OpenStack-8-2019-266=1

Package List:

  • SUSE OpenStack Cloud Crowbar 8 (noarch):
    • python-django_openstack_auth-3.6.1-4.5.1
  • SUSE OpenStack Cloud 8 (noarch):
    • python-django_openstack_auth-3.6.1-4.5.1
  • HPE Helion Openstack 8 (noarch):
    • python-django_openstack_auth-3.6.1-4.5.1

References: