Recommended update for openssh

SUSE Recommended Update: Recommended update for openssh
Announcement ID: SUSE-RU-2019:0213-1
Rating: important
References: #1123028
Affected Products:
  • SUSE Linux Enterprise Server 12-SP1-LTSS
  • SUSE Linux Enterprise Server 12-LTSS

An update that has one recommended fix can now be installed.

Description:

This update for openssh fixes the following issues:

  • A previously applied security patch unintendedly changed the behavior of OpenSSH's "scp" utility such that server-side brace expansion would no longer be supported. Attempts to copy a set files from a remote machine to the local one by running "scp 'remote:{file-a,file-b}' /tmp" would fail. This change in behavior broke Corosync and, potentially, many user scripts that relied on brace expansion. [bsc#1123028]

Patch Instructions:

To install this SUSE Recommended Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
Alternatively you can run the command listed for your product:

  • SUSE Linux Enterprise Server 12-SP1-LTSS:
    zypper in -t patch SUSE-SLE-SERVER-12-SP1-2019-213=1
  • SUSE Linux Enterprise Server 12-LTSS:
    zypper in -t patch SUSE-SLE-SERVER-12-2019-213=1

Package List:

  • SUSE Linux Enterprise Server 12-SP1-LTSS (ppc64le s390x x86_64):
    • openssh-6.6p1-54.29.1
    • openssh-askpass-gnome-6.6p1-54.29.1
    • openssh-askpass-gnome-debuginfo-6.6p1-54.29.1
    • openssh-debuginfo-6.6p1-54.29.1
    • openssh-debugsource-6.6p1-54.29.1
    • openssh-fips-6.6p1-54.29.1
    • openssh-helpers-6.6p1-54.29.1
    • openssh-helpers-debuginfo-6.6p1-54.29.1
  • SUSE Linux Enterprise Server 12-LTSS (ppc64le s390x x86_64):
    • openssh-6.6p1-54.29.1
    • openssh-askpass-gnome-6.6p1-54.29.1
    • openssh-askpass-gnome-debuginfo-6.6p1-54.29.1
    • openssh-debuginfo-6.6p1-54.29.1
    • openssh-debugsource-6.6p1-54.29.1
    • openssh-fips-6.6p1-54.29.1
    • openssh-helpers-6.6p1-54.29.1
    • openssh-helpers-debuginfo-6.6p1-54.29.1

References: