Recommended update for llvm6, jsoncpp

SUSE Recommended Update: Recommended update for llvm6, jsoncpp
Announcement ID: SUSE-RU-2019:0198-1
Rating: moderate
References: #1112730
Affected Products:
  • SUSE Linux Enterprise Software Development Kit 12-SP4
  • SUSE Linux Enterprise Server 12-SP4
  • SUSE Linux Enterprise Desktop 12-SP4

An update that has one recommended fix can now be installed.

Description:

This update for llvm6, jsoncpp provides the following fixes:
Changes in llvm6:

  • Make sure opt-viewer installed in /usr/bin can find resources from /usr/share/opt-viewer. (bsc#1112730)
  • Make sure llvm6-polly will not conflict with future llvm7-polly.
  • Add direct conflict between llvm6-polly-devel and future llvm7-polly-devel to prevent false reports of file conflicts.

Changes in jsoncpp:
  • No change rebuild to get libjsoncpp1 released to SDK 12-SP4.

Patch Instructions:

To install this SUSE Recommended Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
Alternatively you can run the command listed for your product:

  • SUSE Linux Enterprise Software Development Kit 12-SP4:
    zypper in -t patch SUSE-SLE-SDK-12-SP4-2019-198=1
  • SUSE Linux Enterprise Server 12-SP4:
    zypper in -t patch SUSE-SLE-SERVER-12-SP4-2019-198=1
  • SUSE Linux Enterprise Desktop 12-SP4:
    zypper in -t patch SUSE-SLE-DESKTOP-12-SP4-2019-198=1

Package List:

  • SUSE Linux Enterprise Software Development Kit 12-SP4 (aarch64 ppc64le s390x x86_64):
    • libLTO6-6.0.0-2.3.2
    • libLTO6-debuginfo-6.0.0-2.3.2
    • libjsoncpp1-1.6.5-3.2.1
    • libjsoncpp1-debuginfo-1.6.5-3.2.1
    • llvm6-6.0.0-2.3.2
    • llvm6-LTO-devel-6.0.0-2.3.2
    • llvm6-debuginfo-6.0.0-2.3.2
    • llvm6-debugsource-6.0.0-2.3.2
    • llvm6-devel-6.0.0-2.3.2
    • llvm6-devel-debuginfo-6.0.0-2.3.2
    • llvm6-gold-6.0.0-2.3.2
    • llvm6-gold-debuginfo-6.0.0-2.3.2
    • llvm6-polly-6.0.0-2.3.2
    • llvm6-polly-debuginfo-6.0.0-2.3.2
    • llvm6-polly-devel-6.0.0-2.3.2
  • SUSE Linux Enterprise Server 12-SP4 (aarch64 ppc64le s390x x86_64):
    • libLLVM6-6.0.0-2.3.2
    • libLLVM6-debuginfo-6.0.0-2.3.2
    • llvm6-debuginfo-6.0.0-2.3.2
    • llvm6-debugsource-6.0.0-2.3.2
  • SUSE Linux Enterprise Server 12-SP4 (x86_64):
    • libLLVM6-32bit-6.0.0-2.3.2
    • libLLVM6-debuginfo-32bit-6.0.0-2.3.2
  • SUSE Linux Enterprise Desktop 12-SP4 (x86_64):
    • libLLVM6-32bit-6.0.0-2.3.2
    • libLLVM6-6.0.0-2.3.2
    • libLLVM6-debuginfo-32bit-6.0.0-2.3.2
    • libLLVM6-debuginfo-6.0.0-2.3.2
    • llvm6-debuginfo-6.0.0-2.3.2
    • llvm6-debugsource-6.0.0-2.3.2

References: