Security update for compat-openssl097g

SUSE Security Update: Security update for compat-openssl097g
Announcement ID: SUSE-SU-2018:3994-1
Rating: moderate
References: #1110018 #1113742
Cross-References: CVE-2016-8610
Affected Products:
  • SUSE Linux Enterprise Server for SAP 11-SP4
  • SUSE Linux Enterprise Debuginfo 11-SP4

An update that solves one vulnerability and has one errata is now available.

Description:

This update for compat-openssl097g fixes the following issues:
Security issue fixed:

  • CVE-2016-8610: Adjusted current fix and add missing error string (bsc#1110018).

Non-security issue fixed:
  • Fixed timing vulnerability in DSA signature generation (bsc#1113742).

Patch Instructions:

To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
Alternatively you can run the command listed for your product:

  • SUSE Linux Enterprise Server for SAP 11-SP4:
    zypper in -t patch slesappsp4-compat-openssl097g-13896=1
  • SUSE Linux Enterprise Debuginfo 11-SP4:
    zypper in -t patch dbgsp4-compat-openssl097g-13896=1

Package List:

  • SUSE Linux Enterprise Server for SAP 11-SP4 (ppc64 x86_64):
    • compat-openssl097g-0.9.7g-146.22.51.8.1
    • compat-openssl097g-32bit-0.9.7g-146.22.51.8.1
  • SUSE Linux Enterprise Debuginfo 11-SP4 (i586 x86_64):
    • compat-openssl097g-debuginfo-0.9.7g-146.22.51.8.1
    • compat-openssl097g-debugsource-0.9.7g-146.22.51.8.1
  • SUSE Linux Enterprise Debuginfo 11-SP4 (x86_64):
    • compat-openssl097g-debuginfo-32bit-0.9.7g-146.22.51.8.1

References: