Security update for curl

SUSE Security Update: Security update for curl
Announcement ID: SUSE-SU-2018:2714-1
Rating: moderate
References: #1086367 #1106019
Cross-References: CVE-2018-14618
Affected Products:
  • SUSE Linux Enterprise Module for Basesystem 15

An update that solves one vulnerability and has one errata is now available.

Description:

This update for curl fixes the following issues:
This security issue was fixed:

  • CVE-2018-14618: Prevent integer overflow in the NTLM authentication code (bsc#1106019)

This non-security issue was fixed:
  • Use OPENSSL_config instead of CONF_modules_load_file() to avoid crashes due to openssl engines conflicts (bsc#1086367)

Patch Instructions:

To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
Alternatively you can run the command listed for your product:

  • SUSE Linux Enterprise Module for Basesystem 15:
    zypper in -t patch SUSE-SLE-Module-Basesystem-15-2018-1904=1

Package List:

  • SUSE Linux Enterprise Module for Basesystem 15 (aarch64 ppc64le s390x x86_64):
    • curl-7.60.0-3.9.1
    • curl-debuginfo-7.60.0-3.9.1
    • curl-debugsource-7.60.0-3.9.1
    • libcurl-devel-7.60.0-3.9.1
    • libcurl4-7.60.0-3.9.1
    • libcurl4-debuginfo-7.60.0-3.9.1
  • SUSE Linux Enterprise Module for Basesystem 15 (x86_64):
    • libcurl4-32bit-7.60.0-3.9.1
    • libcurl4-32bit-debuginfo-7.60.0-3.9.1

References: