Security update for ImageMagick

SUSE Security Update: Security update for ImageMagick
Announcement ID: SUSE-SU-2018:2562-1
Rating: important
References: #1105592
Affected Products:
  • SUSE Linux Enterprise Module for Development Tools 15
  • SUSE Linux Enterprise Module for Desktop Applications 15

An update that contains security fixes can now be installed.

Description:

This update for ImageMagick fixes the following issues:
Security issue fixed:

  • Disable PS, PS2, PS3, XPS and PDF coders in default policy.xml (bsc#1105592)

Patch Instructions:

To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
Alternatively you can run the command listed for your product:

  • SUSE Linux Enterprise Module for Development Tools 15:
    zypper in -t patch SUSE-SLE-Module-Development-Tools-15-2018-1797=1
  • SUSE Linux Enterprise Module for Desktop Applications 15:
    zypper in -t patch SUSE-SLE-Module-Desktop-Applications-15-2018-1797=1

Package List:

  • SUSE Linux Enterprise Module for Development Tools 15 (aarch64 ppc64le s390x x86_64):
    • ImageMagick-debuginfo-7.0.7.34-3.17.1
    • ImageMagick-debugsource-7.0.7.34-3.17.1
    • perl-PerlMagick-7.0.7.34-3.17.1
    • perl-PerlMagick-debuginfo-7.0.7.34-3.17.1
  • SUSE Linux Enterprise Module for Desktop Applications 15 (aarch64 ppc64le s390x x86_64):
    • ImageMagick-7.0.7.34-3.17.1
    • ImageMagick-debuginfo-7.0.7.34-3.17.1
    • ImageMagick-debugsource-7.0.7.34-3.17.1
    • ImageMagick-devel-7.0.7.34-3.17.1
    • libMagick++-7_Q16HDRI4-7.0.7.34-3.17.1
    • libMagick++-7_Q16HDRI4-debuginfo-7.0.7.34-3.17.1
    • libMagick++-devel-7.0.7.34-3.17.1
    • libMagickCore-7_Q16HDRI6-7.0.7.34-3.17.1
    • libMagickCore-7_Q16HDRI6-debuginfo-7.0.7.34-3.17.1
    • libMagickWand-7_Q16HDRI6-7.0.7.34-3.17.1
    • libMagickWand-7_Q16HDRI6-debuginfo-7.0.7.34-3.17.1

References: