Security update for samba

SUSE Security Update: Security update for samba
Announcement ID: SUSE-SU-2018:2339-2
Rating: moderate
References: #1081741 #1103411
Cross-References: CVE-2018-1050 CVE-2018-10858
Affected Products:
  • SUSE Linux Enterprise Server 12-SP2-BCL

An update that fixes two vulnerabilities is now available.

Description:

This update for samba fixes the following issues:
The following security issues were fixed:

  • CVE-2018-1050: Fixed denial of service vulnerability when SPOOLSS is run externally (bsc#1081741).
  • CVE-2018-10858: smbc_urlencode helper function is a subject to buffer overflow (bsc#1103411)

Patch Instructions:

To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
Alternatively you can run the command listed for your product:

  • SUSE Linux Enterprise Server 12-SP2-BCL:
    zypper in -t patch SUSE-SLE-SERVER-12-SP2-BCL-2018-1574=1

Package List:

  • SUSE Linux Enterprise Server 12-SP2-BCL (x86_64):
    • libdcerpc-atsvc0-4.2.4-28.29.1
    • libdcerpc-atsvc0-debuginfo-4.2.4-28.29.1

References: