Security update for php53

SUSE Security Update: Security update for php53
Announcement ID: SUSE-SU-2018:2044-1
Rating: moderate
References: #1096984 #1099098
Affected Products:
  • SUSE Linux Enterprise Software Development Kit 11-SP4
  • SUSE Linux Enterprise Server 11-SP4
  • SUSE Linux Enterprise Debuginfo 11-SP4

  • An update that fixes two vulnerabilities is now available.

    Description:

    This update for php53 fixes the following issues:

    The following security issue was fixed:

    - An out-of-bounds read in the do_core_note function in readelf.c in
    libmagic.a allowed remote attackers to cause a denial of service via a
    crafted ELF file (CVE-2018-10360, bsc#1096984)
    - CVE-2018-12882: exif_read_from_impl allowed attackers to trigger a
    use-after-free (in exif_read_from_file) because it closed a stream that
    it is not responsible for closing (bsc#1099098)

    Patch Instructions:

    To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
    Alternatively you can run the command listed for your product:

    • SUSE Linux Enterprise Software Development Kit 11-SP4:
      zypper in -t patch sdksp4-php53-13700=1
    • SUSE Linux Enterprise Server 11-SP4:
      zypper in -t patch slessp4-php53-13700=1
    • SUSE Linux Enterprise Debuginfo 11-SP4:
      zypper in -t patch dbgsp4-php53-13700=1

    Package List:

    • SUSE Linux Enterprise Software Development Kit 11-SP4 (i586 ia64 ppc64 s390x x86_64):
      • php53-devel-5.3.17-112.28.1
      • php53-imap-5.3.17-112.28.1
      • php53-posix-5.3.17-112.28.1
      • php53-readline-5.3.17-112.28.1
      • php53-sockets-5.3.17-112.28.1
      • php53-sqlite-5.3.17-112.28.1
      • php53-tidy-5.3.17-112.28.1
    • SUSE Linux Enterprise Server 11-SP4 (i586 ia64 ppc64 s390x x86_64):
      • apache2-mod_php53-5.3.17-112.28.1
      • php53-5.3.17-112.28.1
      • php53-bcmath-5.3.17-112.28.1
      • php53-bz2-5.3.17-112.28.1
      • php53-calendar-5.3.17-112.28.1
      • php53-ctype-5.3.17-112.28.1
      • php53-curl-5.3.17-112.28.1
      • php53-dba-5.3.17-112.28.1
      • php53-dom-5.3.17-112.28.1
      • php53-exif-5.3.17-112.28.1
      • php53-fastcgi-5.3.17-112.28.1
      • php53-fileinfo-5.3.17-112.28.1
      • php53-ftp-5.3.17-112.28.1
      • php53-gd-5.3.17-112.28.1
      • php53-gettext-5.3.17-112.28.1
      • php53-gmp-5.3.17-112.28.1
      • php53-iconv-5.3.17-112.28.1
      • php53-intl-5.3.17-112.28.1
      • php53-json-5.3.17-112.28.1
      • php53-ldap-5.3.17-112.28.1
      • php53-mbstring-5.3.17-112.28.1
      • php53-mcrypt-5.3.17-112.28.1
      • php53-mysql-5.3.17-112.28.1
      • php53-odbc-5.3.17-112.28.1
      • php53-openssl-5.3.17-112.28.1
      • php53-pcntl-5.3.17-112.28.1
      • php53-pdo-5.3.17-112.28.1
      • php53-pear-5.3.17-112.28.1
      • php53-pgsql-5.3.17-112.28.1
      • php53-pspell-5.3.17-112.28.1
      • php53-shmop-5.3.17-112.28.1
      • php53-snmp-5.3.17-112.28.1
      • php53-soap-5.3.17-112.28.1
      • php53-suhosin-5.3.17-112.28.1
      • php53-sysvmsg-5.3.17-112.28.1
      • php53-sysvsem-5.3.17-112.28.1
      • php53-sysvshm-5.3.17-112.28.1
      • php53-tokenizer-5.3.17-112.28.1
      • php53-wddx-5.3.17-112.28.1
      • php53-xmlreader-5.3.17-112.28.1
      • php53-xmlrpc-5.3.17-112.28.1
      • php53-xmlwriter-5.3.17-112.28.1
      • php53-xsl-5.3.17-112.28.1
      • php53-zip-5.3.17-112.28.1
      • php53-zlib-5.3.17-112.28.1
    • SUSE Linux Enterprise Debuginfo 11-SP4 (i586 ia64 ppc64 s390x x86_64):
      • php53-debuginfo-5.3.17-112.28.1
      • php53-debugsource-5.3.17-112.28.1

    References: