Security update for poppler

SUSE Security Update: Security update for poppler
Announcement ID: SUSE-SU-2018:1662-1
Rating: moderate
References: #1045939 #1059066 #1059101 #1059155 #1060220 #1061092 #1061263 #1061264 #1061265 #1064593 #1074453
Affected Products:
  • SUSE Linux Enterprise Software Development Kit 12-SP3
  • SUSE Linux Enterprise Server 12-SP3
  • SUSE Linux Enterprise Desktop 12-SP3

  • An update that fixes 11 vulnerabilities is now available.

    Description:

    This update for poppler fixes the following issues:

    These security issues were fixed:

    - CVE-2017-14517: Prevent NULL Pointer dereference in the
    XRef::parseEntry() function via a crafted PDF document (bsc#1059066).
    - CVE-2017-9865: Fixed a stack-based buffer overflow vulnerability in
    GfxState.cc that would have allowed attackers to facilitate a
    denial-of-service attack via specially crafted PDF documents.
    (bsc#1045939)
    - CVE-2017-14518: Remedy a floating point exception in
    isImageInterpolationRequired() that could have been exploited using a
    specially crafted PDF document. (bsc#1059101)
    - CVE-2017-14520: Remedy a floating point exception in
    Splash::scaleImageYuXd() that could have been exploited using a
    specially crafted PDF document. (bsc#1059155)
    - CVE-2017-14617: Fixed a floating point exception in Stream.cc, which may
    lead to a potential attack when handling malicious PDF files.
    (bsc#1060220)
    - CVE-2017-14928: Fixed a NULL Pointer dereference in
    AnnotRichMedia::Configuration::Configuration() in Annot.cc, which may
    lead to a potential attack when handling malicious PDF files.
    (bsc#1061092)
    - CVE-2017-14975: Fixed a NULL pointer dereference vulnerability, that
    existed because a data structure in FoFiType1C.cc was not initialized,
    which allowed an attacker to launch a denial of service attack.
    (bsc#1061263)
    - CVE-2017-14976: Fixed a heap-based buffer over-read vulnerability in
    FoFiType1C.cc that occurred when an out-of-bounds font dictionary index
    was encountered, which allowed an attacker to launch a denial of service
    attack. (bsc#1061264)
    - CVE-2017-14977: Fixed a NULL pointer dereference vulnerability in the
    FoFiTrueType::getCFFBlock() function in FoFiTrueType.cc that occurred
    due to lack of validation of a table pointer, which allows an attacker
    to launch a denial of service attack. (bsc#1061265)
    - CVE-2017-15565: Prevent NULL Pointer dereference in the
    GfxImageColorMap::getGrayLine() function via a crafted PDF document
    (bsc#1064593).
    - CVE-2017-1000456: Validate boundaries in TextPool::addWord to prevent
    overflows in subsequent calculations (bsc#1074453).

    Patch Instructions:

    To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
    Alternatively you can run the command listed for your product:

    • SUSE Linux Enterprise Software Development Kit 12-SP3:
      zypper in -t patch SUSE-SLE-SDK-12-SP3-2018-1125=1
    • SUSE Linux Enterprise Server 12-SP3:
      zypper in -t patch SUSE-SLE-SERVER-12-SP3-2018-1125=1
    • SUSE Linux Enterprise Desktop 12-SP3:
      zypper in -t patch SUSE-SLE-DESKTOP-12-SP3-2018-1125=1

    Package List:

    • SUSE Linux Enterprise Software Development Kit 12-SP3 (aarch64 ppc64le s390x x86_64):
      • libpoppler-cpp0-0.43.0-16.15.1
      • libpoppler-cpp0-debuginfo-0.43.0-16.15.1
      • libpoppler-devel-0.43.0-16.15.1
      • libpoppler-glib-devel-0.43.0-16.15.1
      • libpoppler-qt4-devel-0.43.0-16.15.1
      • poppler-debugsource-0.43.0-16.15.1
      • poppler-qt-debugsource-0.43.0-16.15.1
      • typelib-1_0-Poppler-0_18-0.43.0-16.15.1
    • SUSE Linux Enterprise Server 12-SP3 (aarch64 ppc64le s390x x86_64):
      • libpoppler-glib8-0.43.0-16.15.1
      • libpoppler-glib8-debuginfo-0.43.0-16.15.1
      • libpoppler-qt4-4-0.43.0-16.15.1
      • libpoppler-qt4-4-debuginfo-0.43.0-16.15.1
      • libpoppler60-0.43.0-16.15.1
      • libpoppler60-debuginfo-0.43.0-16.15.1
      • poppler-debugsource-0.43.0-16.15.1
      • poppler-qt-debugsource-0.43.0-16.15.1
      • poppler-tools-0.43.0-16.15.1
      • poppler-tools-debuginfo-0.43.0-16.15.1
    • SUSE Linux Enterprise Desktop 12-SP3 (x86_64):
      • libpoppler-glib8-0.43.0-16.15.1
      • libpoppler-glib8-debuginfo-0.43.0-16.15.1
      • libpoppler-qt4-4-0.43.0-16.15.1
      • libpoppler-qt4-4-debuginfo-0.43.0-16.15.1
      • libpoppler60-0.43.0-16.15.1
      • libpoppler60-debuginfo-0.43.0-16.15.1
      • poppler-debugsource-0.43.0-16.15.1
      • poppler-qt-debugsource-0.43.0-16.15.1
      • poppler-tools-0.43.0-16.15.1
      • poppler-tools-debuginfo-0.43.0-16.15.1

    References: