Security update for ntp

SUSE Security Update: Security update for ntp
Announcement ID: SUSE-SU-2018:1464-1
Rating: moderate
References: #1034892 #1077445 #1082063 #1082210 #1083417 #1083420 #1083422 #1083424 #1083426
Affected Products:
  • SUSE Linux Enterprise Server 12-LTSS

  • An update that solves 6 vulnerabilities and has three fixes is now available.

    Description:

    This update for ntp fixes the following issues:

    - Update to 4.2.8p11 (bsc#1082210):
    * CVE-2016-1549: Sybil vulnerability: ephemeral association attack.
    While fixed in ntp-4.2.8p7, there are significant additional
    protections for this issue in 4.2.8p11.
    * CVE-2018-7182: ctl_getitem(): buffer read overrun leads to undefined
    behavior and information leak. (bsc#1083426)
    * CVE-2018-7170: Multiple authenticated ephemeral associations.
    (bsc#1083424)
    * CVE-2018-7184: Interleaved symmetric mode cannot recover from bad
    state. (bsc#1083422)
    * CVE-2018-7185: Unauthenticated packet can reset authenticated
    interleaved association. (bsc#1083420)
    * CVE-2018-7183: ntpq:decodearr() can write beyond its buffer
    limit.(bsc#1083417)
    - Don't use libevent's cached time stamps in sntp. (bsc#1077445)
    - Fix systemd migration in %pre (bsc#1034892).

    Patch Instructions:

    To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
    Alternatively you can run the command listed for your product:

    • SUSE Linux Enterprise Server 12-LTSS:
      zypper in -t patch SUSE-SLE-SERVER-12-2018-1000=1

    Package List:

    • SUSE Linux Enterprise Server 12-LTSS (ppc64le s390x x86_64):
      • ntp-4.2.8p11-46.26.2
      • ntp-debuginfo-4.2.8p11-46.26.2
      • ntp-debugsource-4.2.8p11-46.26.2
      • ntp-doc-4.2.8p11-46.26.2

    References: