Security update for xen

SUSE Security Update: Security update for xen
Announcement ID: SUSE-SU-2018:1456-1
Rating: important
References: #1027519 #1074562 #1090296 #1090822 #1090823 #1092631
Affected Products:
  • SUSE Linux Enterprise Software Development Kit 12-SP3
  • SUSE Linux Enterprise Server 12-SP3
  • SUSE Linux Enterprise Desktop 12-SP3
  • SUSE CaaS Platform ALL

  • An update that solves three vulnerabilities and has three fixes is now available.

    Description:


    This update for xen fixes the following issues:

    Security issues fixed:

    - CVE-2018-3639: Spectre V4 – Speculative Store Bypass aka "Memory
    Disambiguation" (bsc#1092631)

    This feature can be controlled by the "ssbd=on/off" commandline flag for
    the XEN hypervisor.
    - CVE-2018-10982: x86 vHPET interrupt injection errors (XSA-261
    bsc#1090822)
    - CVE-2018-10981: qemu may drive Xen into unbounded loop (XSA-262
    bsc#1090823)

    Other bugfixes:

    - Upstream patches from Jan (bsc#1027519)
    - additional fixes related to Page Table Isolation (XPTI). (bsc#1074562
    XSA-254)
    - qemu-system-i386 cannot handle more than 4 HW NICs (bsc#1090296)

    Patch Instructions:

    To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
    Alternatively you can run the command listed for your product:

    • SUSE Linux Enterprise Software Development Kit 12-SP3:
      zypper in -t patch SUSE-SLE-SDK-12-SP3-2018-996=1
    • SUSE Linux Enterprise Server 12-SP3:
      zypper in -t patch SUSE-SLE-SERVER-12-SP3-2018-996=1
    • SUSE Linux Enterprise Desktop 12-SP3:
      zypper in -t patch SUSE-SLE-DESKTOP-12-SP3-2018-996=1
    • SUSE CaaS Platform ALL:
      To install this update, use the SUSE CaaS Platform Velum dashboard. It will inform you if it detects new updates and let you then trigger updating of the complete cluster in a controlled way.

    Package List:

    • SUSE Linux Enterprise Software Development Kit 12-SP3 (aarch64 x86_64):
      • xen-debugsource-4.9.2_06-3.32.1
      • xen-devel-4.9.2_06-3.32.1
    • SUSE Linux Enterprise Server 12-SP3 (x86_64):
      • xen-4.9.2_06-3.32.1
      • xen-debugsource-4.9.2_06-3.32.1
      • xen-doc-html-4.9.2_06-3.32.1
      • xen-libs-32bit-4.9.2_06-3.32.1
      • xen-libs-4.9.2_06-3.32.1
      • xen-libs-debuginfo-32bit-4.9.2_06-3.32.1
      • xen-libs-debuginfo-4.9.2_06-3.32.1
      • xen-tools-4.9.2_06-3.32.1
      • xen-tools-debuginfo-4.9.2_06-3.32.1
      • xen-tools-domU-4.9.2_06-3.32.1
      • xen-tools-domU-debuginfo-4.9.2_06-3.32.1
    • SUSE Linux Enterprise Desktop 12-SP3 (x86_64):
      • xen-4.9.2_06-3.32.1
      • xen-debugsource-4.9.2_06-3.32.1
      • xen-libs-32bit-4.9.2_06-3.32.1
      • xen-libs-4.9.2_06-3.32.1
      • xen-libs-debuginfo-32bit-4.9.2_06-3.32.1
      • xen-libs-debuginfo-4.9.2_06-3.32.1
    • SUSE CaaS Platform ALL (x86_64):
      • xen-debugsource-4.9.2_06-3.32.1
      • xen-libs-4.9.2_06-3.32.1
      • xen-libs-debuginfo-4.9.2_06-3.32.1
      • xen-tools-domU-4.9.2_06-3.32.1
      • xen-tools-domU-debuginfo-4.9.2_06-3.32.1

    References: