Recommended update for suse-module-tools

SUSE Recommended Update: Recommended update for suse-module-tools
Announcement ID: SUSE-RU-2018:4178-1
Rating: important
References: #1116665 #1119371
Affected Products:
  • SUSE Linux Enterprise Module for Basesystem 15

An update that has two recommended fixes can now be installed.

Description:


This update for suse-module-tools fixes the following issues:

  • Move "weak-modules" script to -legacy subpackage to avoid dependency on binutils (bsc#1116665, bsc#1119371)
  • Require mkinitrd (provided also by dracut) directly instead of file requires. This is fixing image build failures

Patch Instructions:

To install this SUSE Recommended Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
Alternatively you can run the command listed for your product:

  • SUSE Linux Enterprise Module for Basesystem 15:
    zypper in -t patch SUSE-SLE-Module-Basesystem-15-2018-2978=1

Package List:

  • SUSE Linux Enterprise Module for Basesystem 15 (aarch64 ppc64le s390x x86_64):
    • suse-module-tools-15.0.2-3.6.1

References: