Recommended update for guile

SUSE Recommended Update: Recommended update for guile
Announcement ID: SUSE-RU-2018:3756-1
Rating: moderate
References: #1110085
Affected Products:
  • SUSE Linux Enterprise Module for Development Tools 15

An update that has one recommended fix can now be installed.

Description:


  • The patch fixes a coredump when using guile with japanese locales based on Shift-JIS (LC_CTYPE=ja_JP.sjis) (bsc#1110085)

Patch Instructions:

To install this SUSE Recommended Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
Alternatively you can run the command listed for your product:

  • SUSE Linux Enterprise Module for Development Tools 15:
    zypper in -t patch SUSE-SLE-Module-Development-Tools-15-2018-2649=1

Package List:

  • SUSE Linux Enterprise Module for Development Tools 15 (aarch64 ppc64le s390x x86_64):
    • guile-2.0.14-5.3.1
    • guile-debuginfo-2.0.14-5.3.1
    • guile-debugsource-2.0.14-5.3.1
    • guile-devel-2.0.14-5.3.1
    • guile-modules-2_0-2.0.14-5.3.1
    • libguile-2_0-22-2.0.14-5.3.1
    • libguile-2_0-22-debuginfo-2.0.14-5.3.1
    • libguilereadline-v-18-18-2.0.14-5.3.1
    • libguilereadline-v-18-18-debuginfo-2.0.14-5.3.1

References: