Recommended update for libzypp

SUSE Recommended Update: Recommended update for libzypp
Announcement ID: SUSE-RU-2018:3584-1
Rating: moderate
References: #1099982 #1109877 #408814 #556664 #939392
Affected Products:
  • SUSE OpenStack Cloud 7
  • SUSE Linux Enterprise Server for SAP 12-SP2
  • SUSE Linux Enterprise Server 12-SP2-LTSS
  • SUSE Linux Enterprise Server 12-SP2-BCL
  • SUSE Enterprise Storage 4
  • OpenStack Cloud Magnum Orchestration 7

An update that has 5 recommended fixes can now be installed.

Description:

This update for libzypp fixes the following issues:

  • Add filesize check for downloads with known size to avoid endless data attacks (bsc#408814)
  • Fix conversion of string and glob to regex when compiling queries (bsc#1099982, bsc#939392, bsc#556664)
  • Fix blocking wait for finished child process (bsc#1109877)

Patch Instructions:

To install this SUSE Recommended Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
Alternatively you can run the command listed for your product:

  • SUSE OpenStack Cloud 7:
    zypper in -t patch SUSE-OpenStack-Cloud-7-2018-2534=1
  • SUSE Linux Enterprise Server for SAP 12-SP2:
    zypper in -t patch SUSE-SLE-SAP-12-SP2-2018-2534=1
  • SUSE Linux Enterprise Server 12-SP2-LTSS:
    zypper in -t patch SUSE-SLE-SERVER-12-SP2-2018-2534=1
  • SUSE Linux Enterprise Server 12-SP2-BCL:
    zypper in -t patch SUSE-SLE-SERVER-12-SP2-BCL-2018-2534=1
  • SUSE Enterprise Storage 4:
    zypper in -t patch SUSE-Storage-4-2018-2534=1
  • OpenStack Cloud Magnum Orchestration 7:
    zypper in -t patch SUSE-OpenStack-Cloud-Magnum-Orchestration-7-2018-2534=1

Package List:

  • SUSE OpenStack Cloud 7 (s390x x86_64):
    • libzypp-16.19.0-27.55.1
    • libzypp-debuginfo-16.19.0-27.55.1
    • libzypp-debugsource-16.19.0-27.55.1
  • SUSE Linux Enterprise Server for SAP 12-SP2 (ppc64le x86_64):
    • libzypp-16.19.0-27.55.1
    • libzypp-debuginfo-16.19.0-27.55.1
    • libzypp-debugsource-16.19.0-27.55.1
  • SUSE Linux Enterprise Server 12-SP2-LTSS (ppc64le s390x x86_64):
    • libzypp-16.19.0-27.55.1
    • libzypp-debuginfo-16.19.0-27.55.1
    • libzypp-debugsource-16.19.0-27.55.1
  • SUSE Linux Enterprise Server 12-SP2-BCL (x86_64):
    • libzypp-16.19.0-27.55.1
    • libzypp-debuginfo-16.19.0-27.55.1
    • libzypp-debugsource-16.19.0-27.55.1
  • SUSE Enterprise Storage 4 (x86_64):
    • libzypp-16.19.0-27.55.1
    • libzypp-debuginfo-16.19.0-27.55.1
    • libzypp-debugsource-16.19.0-27.55.1
  • OpenStack Cloud Magnum Orchestration 7 (x86_64):
    • libzypp-16.19.0-27.55.1
    • libzypp-debuginfo-16.19.0-27.55.1
    • libzypp-debugsource-16.19.0-27.55.1

References: