Recommended update for snapper

SUSE Recommended Update: Recommended update for snapper
Announcement ID: SUSE-RU-2018:2718-1
Rating: moderate
References: #1051922
Affected Products:
  • SUSE Linux Enterprise Software Development Kit 12-SP3
  • SUSE Linux Enterprise Server 12-SP3
  • SUSE Linux Enterprise Desktop 12-SP3
  • SUSE CaaS Platform ALL
  • SUSE CaaS Platform 3.0

An update that has one recommended fix can now be installed.

Description:

This update for snapper fixes the following issues:

  • fixed logging during shutdown of snapperd to avoid core dumps. (bsc#1051922)

Patch Instructions:

To install this SUSE Recommended Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
Alternatively you can run the command listed for your product:

  • SUSE Linux Enterprise Software Development Kit 12-SP3:
    zypper in -t patch SUSE-SLE-SDK-12-SP3-2018-1907=1
  • SUSE Linux Enterprise Server 12-SP3:
    zypper in -t patch SUSE-SLE-SERVER-12-SP3-2018-1907=1
  • SUSE Linux Enterprise Desktop 12-SP3:
    zypper in -t patch SUSE-SLE-DESKTOP-12-SP3-2018-1907=1
  • SUSE CaaS Platform ALL:
    To install this update, use the SUSE CaaS Platform Velum dashboard. It will inform you if it detects new updates and let you then trigger updating of the complete cluster in a controlled way.
  • SUSE CaaS Platform 3.0:
    To install this update, use the SUSE CaaS Platform Velum dashboard. It will inform you if it detects new updates and let you then trigger updating of the complete cluster in a controlled way.

Package List:

  • SUSE Linux Enterprise Software Development Kit 12-SP3 (aarch64 ppc64le s390x x86_64):
    • libsnapper-devel-0.5.0-3.5.1
    • snapper-debuginfo-0.5.0-3.5.1
    • snapper-debugsource-0.5.0-3.5.1
  • SUSE Linux Enterprise Server 12-SP3 (aarch64 ppc64le s390x x86_64):
    • libsnapper4-0.5.0-3.5.1
    • libsnapper4-debuginfo-0.5.0-3.5.1
    • pam_snapper-0.5.0-3.5.1
    • pam_snapper-debuginfo-0.5.0-3.5.1
    • snapper-0.5.0-3.5.1
    • snapper-debuginfo-0.5.0-3.5.1
    • snapper-debugsource-0.5.0-3.5.1
  • SUSE Linux Enterprise Server 12-SP3 (noarch):
    • snapper-zypp-plugin-0.5.0-3.5.1
  • SUSE Linux Enterprise Desktop 12-SP3 (x86_64):
    • libsnapper4-0.5.0-3.5.1
    • libsnapper4-debuginfo-0.5.0-3.5.1
    • pam_snapper-0.5.0-3.5.1
    • pam_snapper-debuginfo-0.5.0-3.5.1
    • snapper-0.5.0-3.5.1
    • snapper-debuginfo-0.5.0-3.5.1
    • snapper-debugsource-0.5.0-3.5.1
  • SUSE Linux Enterprise Desktop 12-SP3 (noarch):
    • snapper-zypp-plugin-0.5.0-3.5.1
  • SUSE CaaS Platform ALL (x86_64):
    • libsnapper4-0.5.0-3.5.1
    • libsnapper4-debuginfo-0.5.0-3.5.1
    • snapper-0.5.0-3.5.1
    • snapper-debuginfo-0.5.0-3.5.1
    • snapper-debugsource-0.5.0-3.5.1
  • SUSE CaaS Platform 3.0 (x86_64):
    • libsnapper4-0.5.0-3.5.1
    • libsnapper4-debuginfo-0.5.0-3.5.1
    • snapper-0.5.0-3.5.1
    • snapper-debuginfo-0.5.0-3.5.1
    • snapper-debugsource-0.5.0-3.5.1

References: