Security update for xen

SUSE Security Update: Security update for xen
Announcement ID: SUSE-SU-2017:3239-1
Rating: important
References: #1055047 #1056336 #1061075 #1061081 #1061086 #1063123 #1068187 #1068191
Affected Products:
  • SUSE Linux Enterprise Server 12-LTSS

  • An update that solves 5 vulnerabilities and has three fixes is now available.

    Description:

    This update for xen fixes several issues.

    These security issues were fixed:

    - bsc#1068187: Failure to recognize errors in the Populate on Demand (PoD)
    code allowed for DoS (XSA-246)
    - bsc#1068191: Missing p2m error checking in PoD code allowed unprivileged
    guests to retain a writable mapping of freed memory leading to
    information leaks, privilege escalation or DoS (XSA-247).
    - CVE-2017-15289: The mode4and5 write functions allowed local OS guest
    privileged users to cause a denial of service (out-of-bounds write
    access and Qemu process crash) via vectors related to dst calculation
    (bsc#1063123)
    - CVE-2017-15597: A grant copy operation being done on a grant of a dying
    domain allowed a malicious guest administrator to corrupt hypervisor
    memory, allowing for DoS or potentially privilege escalation and
    information leaks (bsc#1061075).
    - CVE-2017-15595: x86 PV guest OS users were able to cause a DoS
    (unbounded recursion, stack consumption, and hypervisor crash) or
    possibly gain privileges via crafted page-table stacking (bsc#1061081).
    - CVE-2017-15592: x86 HVM guest OS users were able to cause a DoS
    (hypervisor crash) or possibly gain privileges because self-linear
    shadow mappings were mishandled for translated guests (bsc#1061086).
    - CVE-2017-13672: The VGA display emulator support allowed local guest OS
    privileged users to cause a denial of service (out-of-bounds read and
    QEMU process crash) via vectors involving display update (bsc#1056336)

    This non-security issue was fixed:

    - bsc#1055047: Fixed --initrd-inject option in virt-install

    Patch Instructions:

    To install this SUSE Security Update use YaST online_update.
    Alternatively you can run the command listed for your product:

    • SUSE Linux Enterprise Server 12-LTSS:
      zypper in -t patch SUSE-SLE-SERVER-12-2017-2019=1

    To bring your system up-to-date, use "zypper patch".

    Package List:

    • SUSE Linux Enterprise Server 12-LTSS (x86_64):
      • xen-4.4.4_26-22.59.3
      • xen-debugsource-4.4.4_26-22.59.3
      • xen-doc-html-4.4.4_26-22.59.3
      • xen-kmp-default-4.4.4_26_k3.12.61_52.101-22.59.3
      • xen-kmp-default-debuginfo-4.4.4_26_k3.12.61_52.101-22.59.3
      • xen-libs-32bit-4.4.4_26-22.59.3
      • xen-libs-4.4.4_26-22.59.3
      • xen-libs-debuginfo-32bit-4.4.4_26-22.59.3
      • xen-libs-debuginfo-4.4.4_26-22.59.3
      • xen-tools-4.4.4_26-22.59.3
      • xen-tools-debuginfo-4.4.4_26-22.59.3
      • xen-tools-domU-4.4.4_26-22.59.3
      • xen-tools-domU-debuginfo-4.4.4_26-22.59.3

    References: