SUSE Support

Here When You Need Us

fadump: Crash info header is not valid

This document (000021429) is provided subject to the disclaimer at the end of this document.

Environment

SUSE Linux Enterprise Server 15 SP5
SUSE Linux Enterprise Server 15 SP4

Situation

On Power10 systems with LMB (Logical Memory Block) size greater than 256MB, and fadump enabled, the console log after a crash displays:
Quiescing Open Firmware ...
Booting Linux via __start() @ 0x00000000092e0000 ...
[    0.101119][    T1] rtas fadump: Crash info header is not valid.

It is also possible that capturing the dump fails with:
open_dump_memory: Can't open the dump memory(/proc/vmcore). No such file or directory 
makedumpfile Failed.

Resolution

The grub2 package released November/2023 includes the patch:
SLES15 SP5 - grub2-2.06-150500.29.11.1
SLES15 SP4 - grub2-2.06-150400.11.41.1

Alternatively as a workaround:
Set the crashkernel minimum memory reservation equal to the supported LMB size.
For example if LMB size is 4096 MB, reserve at least 4096 MB:
fadump=on crashkernel=4096M

'lsmem' displays the LMB size (Memory block size)
 

Cause

The firmware used to support an LBM size of 256MB.
The latest firmware on Power10 systems now supports LBM sizes of 1024MB and more, so the memory reservation for fadump needs to be adjusted.

Additional Information

For additional details see IBM's Support document "Kernel dump corruption with Firmware-Assisted Dump (FADump)"

Disclaimer

This Support Knowledgebase provides a valuable tool for SUSE customers and parties interested in our products and solutions to acquire information, ideas and learn from one another. Materials are provided for informational, personal or non-commercial use within your organization and are presented "AS IS" WITHOUT WARRANTY OF ANY KIND.

  • Document ID:000021429
  • Creation Date: 19-Apr-2024
  • Modified Date:19-Apr-2024
    • SUSE Linux Enterprise Server

< Back to Support Search

For questions or concerns with the SUSE Knowledgebase please contact: tidfeedback[at]suse.com

SUSE Support Forums

Get your questions answered by experienced Sys Ops or interact with other SUSE community experts.

Support Resources

Learn how to get the most from the technical support you receive with your SUSE Subscription, Premium Support, Academic Program, or Partner Program.

Open an Incident

Open an incident with SUSE Technical Support, manage your subscriptions, download patches, or manage user access.