SUSE Support

Here When You Need Us

After updating to libxmlsec1-openssl1-1.2.37-8.9.2.x86_64 apache service with splunk fails to start

This document (000021291) is provided subject to the disclaimer at the end of this document.

Environment

SUSE Linux Enterprise Server 12 SP5

Situation

After applying patch libxmlsec1-openssl1-1.2.37-8.9.2.x86_64 apache fails to start and systemctl status apache2 shows:

Dec 07 00:17:35 linux systemd[1]: Started The Apache Webserver.
Common::Realize_profile[profile::splunk_service::searchhead_cl_member]/Apache::Vhost[default!default]/Apache::Instance[default]/Apache::Instan
ce::Service[default]/Common::Utils::Systemd_service[apache2]/Service[apache2]/ensure) ensure changed 'stopped' to 'running'
Dec 07 00:17:35 linux start_apache2_default[22261]: httpd: Syntax error on line 71 of /srv/appl/etc/apache2/httpd.conf: Syntax error on line 43 of /srv/appl/etc/apache2/modules.conf: Cannot load /srv/apache/apache-2.4.58/usr/lib64/apache2/mod_auth_mellon.so into server: /usr/lib64/libxmlsec1-openssl.so.1: undefined symbol: UI_null
Dec 07 00:17:35 linux systemd[1]: apache2.service: Main process exited, code=exited, status=1/FAILURE
Dec 07 00:17:35 linux systemd[1]: apache2.service: Unit entered failed state.
Dec 07 00:17:35 linux systemd[1]: apache2.service: Failed with result 'exit-code'.

 

Resolution

Workaround is to downgrade to previous version.

SUSE Engineering is working on a fix that will be published when available.

Cause

Updated package of xmlsec1 is using "UI_null()" symbol which is only defined in OpenSSL>=1.0 versions.
The missing symbol definition caused that apache2 was unable to load  libxmlsec1-openssl1 library
and service start terminated with failure.

Status

Reported to Engineering

Disclaimer

This Support Knowledgebase provides a valuable tool for SUSE customers and parties interested in our products and solutions to acquire information, ideas and learn from one another. Materials are provided for informational, personal or non-commercial use within your organization and are presented "AS IS" WITHOUT WARRANTY OF ANY KIND.

  • Document ID:000021291
  • Creation Date: 14-Dec-2023
  • Modified Date:19-Dec-2023
    • SUSE Linux Enterprise Server

< Back to Support Search

For questions or concerns with the SUSE Knowledgebase please contact: tidfeedback[at]suse.com

SUSE Support Forums

Get your questions answered by experienced Sys Ops or interact with other SUSE community experts.

Support Resources

Learn how to get the most from the technical support you receive with your SUSE Subscription, Premium Support, Academic Program, or Partner Program.

Open an Incident

Open an incident with SUSE Technical Support, manage your subscriptions, download patches, or manage user access.