SUSE Support

Here When You Need Us

HANA blocking and crash when signal interrupted clock_gettime

This document (000021186) is provided subject to the disclaimer at the end of this document.

Environment

SUSE Linux Enterprise Server for SAP Applications 15 SP4
SUSE Linux Enterprise Server 15 SP4

Situation

There have been instances where HANA has shown symptoms like blocking, hanging, and crashes. After analyzing the gstack output, it became evident that there is a fault occurring within the __kernel_clock_gettime function when a signal interrupts the clock_gettime:
#8  <signal handler called>
#9  0x00007fffa3ef04c4 in __kernel_clock_gettime () at ../arch/powerpc/kernel/vdso64/gettimeofday.S:36
#10 0x00007fff6df7c41c in clock_gettime@@GLIBC_2.17 () from /lib64/libc.so.6

Resolution

This problem has been resolved in kernel version 5.14.21-150400.24.11.1 and onwards for the IBM POWER architecture:
SUSE versionArchitectureAffected KernelsResolved
SLES15 SP4IBM POWER5.14.21-150400.22.15.14.21-150400.24.11.1 and onwards

Cause

This bug affects only the initial (GA) SLES15 SP4 kernel version 5.14.21-150400.22.1 on the IBM POWER architecture. It was introduced due to changes in vdso files, which disrupted the call frame info. Specifically, in the .eh_frame for __kernel_clock_gettime, lr is indicated to be in r0. However, it calls __c_kernel_clock_gettime, which causes r0 to be altered. There's a brief period after c_k_c_g returns but before r0 is restored from the stack, during which a signal could lead to a problem. To address this, the cfi should correctly reflect lr's location on the stack rather than in r0. Additionally, cfi should cover the changes for r1 as well.

Status

Reported to Engineering

Disclaimer

This Support Knowledgebase provides a valuable tool for SUSE customers and parties interested in our products and solutions to acquire information, ideas and learn from one another. Materials are provided for informational, personal or non-commercial use within your organization and are presented "AS IS" WITHOUT WARRANTY OF ANY KIND.

  • Document ID:000021186
  • Creation Date: 28-Aug-2023
  • Modified Date:29-Aug-2023
    • SUSE Linux Enterprise Server
    • SUSE Linux Enterprise Server for SAP Applications

< Back to Support Search

For questions or concerns with the SUSE Knowledgebase please contact: tidfeedback[at]suse.com

SUSE Support Forums

Get your questions answered by experienced Sys Ops or interact with other SUSE community experts.

Support Resources

Learn how to get the most from the technical support you receive with your SUSE Subscription, Premium Support, Academic Program, or Partner Program.

Open an Incident

Open an incident with SUSE Technical Support, manage your subscriptions, download patches, or manage user access.