SUSE Support

Here When You Need Us

Some Mexican timezones moved to Central Time from Mountain Time after update to timezone-2022f

This document (000021063) is provided subject to the disclaimer at the end of this document.

Environment

SUSE Linux Enterprise 12 SP5
SUSE Linux Enterprise 15 SP4
SUSE Linux Enterprise 15 SP5

Situation

Time zones in the Mexican state of Chihuahua changed from Mountain Time to Pacific Time after an update of the timezone package to version 2022f or later.

Cause

The Mexican state of Chihuahua officially changed their time zone from Mountain Time to Central Time in October 2022, with a few exceptions. From the changelog of the IANA tz data 2022f release:
 

     Mexico will no longer observe DST after 2022, except for areas
     near the US border that continue to observe US DST rules.
     On 2022-10-30 at 02:00 the Mexican state of Chihuahua moves
     from -07 (-06 with DST) to year-round -06, thus not changing
     its clocks that day.  The new law states that Chihuahua
     near the US border no longer observes US DST.

This means:

  • Mexico does not observe Daylight Savings Time (DST) any more, except for some areas near the US border (such as Ojinaga, State of Chihuahua) that continue to observe DST.
  • The timezone of the state of Chihuahua has changed from -07 (Mountain Standard Time, MST) to -06 (Central Standard Time, CST) except for some areas near the US border.
  • The City of Chihuahua, State of Chihuahua, despite being close to the US, does not observe DST.

For example, this results in the border town of Ojinaga observing daylight savings in the Central Time timezone, the city of Chihuahua being on Standard Time all year long, but the town of Ciudad Juárez being on Mountain Time observing DST, despite all three cities being located in the State of Chihuahua:

# TZ=America/Ojinaga date
Fr 5. Mai 04:16:56 CDT 2023
# TZ=America/Chihuahua date
Fr 5. Mai 03:17:09 CST 2023
# TZ=America/Ciudad_Juarez date
Fr 5. Mai 06:16:36 MDT 2023

 

Status

Top Issue

Disclaimer

This Support Knowledgebase provides a valuable tool for SUSE customers and parties interested in our products and solutions to acquire information, ideas and learn from one another. Materials are provided for informational, personal or non-commercial use within your organization and are presented "AS IS" WITHOUT WARRANTY OF ANY KIND.

  • Document ID:000021063
  • Creation Date: 05-May-2023
  • Modified Date:05-May-2023
    • SUSE Linux Enterprise Server

< Back to Support Search

For questions or concerns with the SUSE Knowledgebase please contact: tidfeedback[at]suse.com

SUSE Support Forums

Get your questions answered by experienced Sys Ops or interact with other SUSE community experts.

Support Resources

Learn how to get the most from the technical support you receive with your SUSE Subscription, Premium Support, Academic Program, or Partner Program.

Open an Incident

Open an incident with SUSE Technical Support, manage your subscriptions, download patches, or manage user access.