SUSE Support

Here When You Need Us

Azure BYOS instance cannot be registered via SUSEConnect

This document (000020872) is provided subject to the disclaimer at the end of this document.

Environment

SUSE Linux Enterprise Server 15 SP3

Microsoft Azure


Situation

After changing from PAYG instance to BYOS or installing new one licenseType: SLES_BYOS is set.
Registration to SCC completes successfully, but after up to 1 minute the registration and repositories got removed.

Following info messages within /var/log/cloudregister

2022-11-24 10:02:01,000 INFO:Calling ['registercloudguest', '--clean']
2022-11-24 10:02:01,000 INFO:Calling ['systemctl', 'disable', 'guestregister']
2022-11-24 10:03:01,000 INFO:Calling ['registercloudguest', '--clean']
2022-11-24 10:03:01,000 INFO:Calling ['systemctl', 'disable', 'guestregister']
2022-11-24 10:04:01,000 INFO:Calling ['registercloudguest', '--clean']
2022-11-24 10:04:01,000 INFO:Calling ['systemctl', 'disable', 'guestregister']
...

 


 

Resolution

Stop regionsrv-enabler-azure.timer, then update to the latest cloud-regionsrv-client* packages available:

systemctl stop regionsrv-enabler-azure.timer
SUSEConnect -r <regcode>
SUSEConnect -p sle-module-public-cloud/15.3/x86_64
zypper update cloud-regionsrv-client cloud-regionsrv-client-addon-azure cloud-regionsrv-client-plugin-azure
systemctl start regionsrv-enabler-azure.timer


Note: Minimum required version of cloud-regionsrv-client-addon-azure is 1.0.4-150000.6.70.1

Other known workarounds are:
- Stop and disable the timer regionsrv-enabler-azure.timer
- Remove all cloud-regionsrv-client* addon-azure* packages

Cause

There was a bug in the addon logic that was responsible for removing repositories when they should not have been removed.

Disclaimer

This Support Knowledgebase provides a valuable tool for SUSE customers and parties interested in our products and solutions to acquire information, ideas and learn from one another. Materials are provided for informational, personal or non-commercial use within your organization and are presented "AS IS" WITHOUT WARRANTY OF ANY KIND.

  • Document ID:000020872
  • Creation Date: 23-Nov-2022
  • Modified Date:25-Nov-2022
    • SUSE Linux Enterprise Server

< Back to Support Search

For questions or concerns with the SUSE Knowledgebase please contact: tidfeedback[at]suse.com

SUSE Support Forums

Get your questions answered by experienced Sys Ops or interact with other SUSE community experts.

Support Resources

Learn how to get the most from the technical support you receive with your SUSE Subscription, Premium Support, Academic Program, or Partner Program.

Open an Incident

Open an incident with SUSE Technical Support, manage your subscriptions, download patches, or manage user access.