Pay-as-you-go instances are unable to be connected to SUSE Manager
This document (000020849) is provided subject to the disclaimer at the end of this document.
Environment
SUSE Manager 4.3
SUSE Linux Enterprise Server 15 SP4
Situation
Running rpm -q release-notes-susemanager shows the SUSE Manager version.
release-notes-susemanager-4.2.9-...
When trying to add an PAYG Instance under Admin => Setup Wizard => Pay-as-you-go, the following error occurs:
Error getting instance data: CA file
The following errors are observed in the /var/log/rhn/rhn_taskomatic_daemon.log.
2022-11-03 10:40:00,939 [DefaultQuartzScheduler_Worker-7] ERROR com.redhat.rhn.taskomatic.task.payg.PaygAuthDataExtractor - Exit status: 6 2022-11-03 10:40:00,939 [DefaultQuartzScheduler_Worker-7] ERROR com.redhat.rhn.taskomatic.task.payg.PaygAuthDataExtractor - stderr: CA file for server <name_or_ip_address> not found (/usr/share/pki/trust/anchors/registration_server_<name_or_ip_address>.pem) 2022-11-03 10:40:00,939 [DefaultQuartzScheduler_Worker-7] ERROR com.redhat.rhn.taskomatic.task.payg.PaygUpdateAuthTask - error getting instance data com.redhat.rhn.taskomatic.task.payg.PaygDataExtractException: CA file for server <name_or_ip_address> not found (/usr/share/pki/trust/anchors/registration_server_<name_or_ip_address>.pem) at com.redhat.rhn.taskomatic.task.payg.PaygAuthDataExtractor.extractAuthData(PaygAuthDataExtractor.java:128) at com.redhat.rhn.taskomatic.task.payg.PaygUpdateAuthTask.updateInstanceData(PaygUpdateAuthTask.java:77) at java.base/java.util.ArrayList.forEach(ArrayList.java:1541) at com.redhat.rhn.taskomatic.task.payg.PaygUpdateAuthTask.execute(PaygUpdateAuthTask.java:61) at com.redhat.rhn.taskomatic.task.RhnJavaJob.execute(RhnJavaJob.java:89) at com.redhat.rhn.taskomatic.TaskoJob.execute(TaskoJob.java:170) at org.quartz.core.JobRunShell.run(JobRunShell.java:202) at org.quartz.simpl.SimpleThreadPool$WorkerThread.run(SimpleThreadPool.java:573)
Resolution
- spacewalk-service stop
- zypper ref
- zypper patch
- spacewalk-service start
For SUSE Manager 4.2 minimum Patch Level Upgrade(Z Upgrade) is release-notes-susemanager-4.2.10
For SUSE Manager 4.3 minimum Patch Level Upgrade(Z Upgrade) is release-notes-susemanager-4.3.3
Cause
Disclaimer
This Support Knowledgebase provides a valuable tool for SUSE customers and parties interested in our products and solutions to acquire information, ideas and learn from one another. Materials are provided for informational, personal or non-commercial use within your organization and are presented "AS IS" WITHOUT WARRANTY OF ANY KIND.
- Document ID:000020849
- Creation Date: 09-Nov-2022
- Modified Date:14-Nov-2022
-
- SUSE Manager Server
For questions or concerns with the SUSE Knowledgebase please contact: tidfeedback[at]suse.com