SUSE Support

Here When You Need Us

SLES 12 SP4 Bootstrap Repository not getting created on SUSE Manager 4.2

This document (000020629) is provided subject to the disclaimer at the end of this document.

Environment

SUSE Manager 4.2 with SLES 12 SP4 clients (and possibly other older SLE product versions that are out of general support)

Situation

Adding SLES 12 SP4 as a product to synchronize to SUSE Manager (SUMA) Server, and then attempting to bootstrap a SLES 12 SP4 client to register it to the SUMA Server results in an error that the salt-minion package could not be found. 

If bootstrapping via the web interface, you will get the message below returned:

One or more requisite failed: bootstrap.salt-minion-package

If bootstrapping from the command line interface, you will get the message below returned:

package salt-minion not found

Searching the SUSE Manager Server for the bootstrap repository under /srv/www/htdocs/pub/repositories/sle/12/ reveals that the bootstrap repository for SP4 was not created. In the example below, the subdirectory named "5" shows that the bootstrap repository for SLES 12 SP5 exists, but there is no subdirectory named 4, which indicates that the bootstrap repository for SLES 12 SP4 does not exist:

# ls -l /srv/www/htdocs/pub/repositories/sle/12
total 0
drwxr-xr-x 3 root root 23 Mar 31 07:32 5


SUSE Manager 4.2 (SUMA) normally generates bootstrap repositories automatically for all product versions whose channels are being synchronized to it. You can also manually create a bootstrap repository for a product version using the command mgr-create-bootstrap-repo from the SUMA Server's Command Line Interface (CLI) and you will be presented with a list of synched product versions to choose from. After successfully synchronizing SLES 12 SP4 product channels to the SUMA Server for the first time, it does not automatically generate a bootstrap repository for that product version, and SLES 12 SP4 does not show up as an available product version when running mgr-create-bootstrap-repo from the SUMA Server's CLI:

# mgr-create-bootstrap-repo
1. SLE-12-SP5-x86_64
2. SLE-15-SP2-x86_64
3. SLE-15-SP3-x86_64
Enter a number of a product label:


If you already had SLES 12 SP4 channels synchronized to an earlier version of SUSE Manager and migrated to SUSE Manager 4.2, the problem is not seen.

Resolution

There are 2 ways to handle this condition:

1. If you have a Long Term Service Pack Support (LTSS) subscription, choose to synchronize the SLES 12 SP4 LTSS channel and it will automatically generate the bootstrap repository and you do not need to do anything manually.

2. If you do not have an LTSS subscription, run mgr-create-bootstrap-repo --force and it will list all products that are synchronized, including SLES 12 SP4:

# mgr-create-bootstrap-repo
1. SLE-12-SP5-x86_64
2. SLE-15-SP2-x86_64
3. SLE-15-SP3-x86_64
4. SLE-12-SP4-x86_64
Enter a number of a product label: 4


You can then select the corresponding number next to the SLES 12 SP4 product and the bootstrap repository will be generated. After that, it should automatically be updated whenever new content becomes available, like new versions of the SUSE Manager Tools packages.

Cause

SLES 12 SP4 is out of general support and SUSE Manager 4.2 does not automatically generate bootstrap repositories for product versions that are out of support, nor does it show them by default when running mgr-create-bootstrap-repo. SLES 12 SP4 with LTSS is still in support, so the bootstrap repository is automatically generated for that product when the LTSS channel is also synchronized.

Disclaimer

This Support Knowledgebase provides a valuable tool for SUSE customers and parties interested in our products and solutions to acquire information, ideas and learn from one another. Materials are provided for informational, personal or non-commercial use within your organization and are presented "AS IS" WITHOUT WARRANTY OF ANY KIND.

  • Document ID:000020629
  • Creation Date: 31-Mar-2022
  • Modified Date:31-Mar-2022
    • SUSE Manager Server

< Back to Support Search

For questions or concerns with the SUSE Knowledgebase please contact: tidfeedback[at]suse.com

SUSE Support Forums

Get your questions answered by experienced Sys Ops or interact with other SUSE community experts.

Support Resources

Learn how to get the most from the technical support you receive with your SUSE Subscription, Premium Support, Academic Program, or Partner Program.

Open an Incident

Open an incident with SUSE Technical Support, manage your subscriptions, download patches, or manage user access.