SUSE Support

Here When You Need Us

SP2 to SP3 migration with 41-qeth rules file - no network after migration

This document (000020621) is provided subject to the disclaimer at the end of this document.

Environment

SUSE Linux Enterprise Server 15 SP3
SUSE Linux Enterprise Server 15 SP2

Situation

After a Service Pack migration from SLES 15 SP2 to SP3 the network connection fails, e.g. ssh into the server is not possible.
Either one of the two conditions are present:

1. In the directory /etc/udev/rules.d/ is a 41-qeth-x.x.xxxx.rules.legacy file but no 41-qeth-x.x.xxxx.rules file. For example:

# dir /etc/udev/rules.d/
total 24  
-rw-r--r-- 1 root root 154 Aug 13 2018 41-cio-ignore.rules
-rw-r--r-- 1 root root 396 Aug 13 2018 41-dasd-eckd-0.0.0291.rules
-rw-r--r-- 1 root root 389 Aug 13 2018 41-dasd-fba-0.0.0199.rules
-rw-r--r-- 1 root root 995 Jan 21 12:06 41-qeth-0.0.0100.rules.legacy
-rw-r--r-- 1 root root 628 Aug 17 2020 70-persistent-ipoib.rules
-rw-r--r-- 1 root root 408 Jan 21 12:06 70-persistent-net.rules


In the zypp/history file logs the following line will be present:
# Migrating collect based udev rule /etc/udev/rules.d/41-qeth-0.0.0100.rules to new chzdev based scheme...

2. In the directory /etc/udev/rules.d/ is a 41-qeth-x.x.xxxx.rules file.
However the file wasn't converted to the new format using chzdev and it still uses the 'collect' based udev rule.

The 41-qeth-0.0.0100.rules on SP2 and for condition 2. on SP3 looks like this, note "collect" in the line(s):

# Configure qeth device at 0.0.0100/0.0.0101/0.0.0102  
ACTION=="add", SUBSYSTEM=="drivers", KERNEL=="qeth", IMPORT{program}="collect 0.0.0100 %k 0.0.0100 0.0.0101 0.0.0102 qeth"

[...]
ACTION=="add", SUBSYSTEM=="ccwgroup", KERNEL=="0.0.0100", ATTR{portname}="Port100"  
ACTION=="add", SUBSYSTEM=="ccwgroup", KERNEL=="0.0.0100", ATTR{portno}="0" ACTION=="add", SUBSYSTEM=="ccwgroup", KERNEL=="0.0.0100", ATTR{layer2}="0" ACTION=="add", SUBSYSTEM=="ccwgroup", KERNEL=="0.0.0100", ATTR{online}="1"


Using the systemd version released April 2022 (systemd-246.16-150300.7.42.1) the 41-qeth-x.x.xxxx.rules file wasn't converted to a legacy file but it wasn't changed/converted to the new format either.

Resolution

As workaround for the first problem, the file 41-qeth-x.x.xxxx.rules.legacy in /etc/udev/rules.d/ can be renamed to 41-qeth-x.x.xxxx.rules . After a reboot network should be up.

The systemd update for SP3, systemd-246.16-150300.7.42.1, released April 2022 includes the patch to avoid the first condition (legacy file no rules file).
The update will be installed during the migration process and will take care processing the file correctly.

However it will cause the second condition because the 41-qeth-x.x.xxxx.rules is not converted to the new format.
The problem is reported to Engineering.

Avoid installing the systemd update from April/2022 and use the workaround for the first condition (rename the 41-qeth-x.x.xxxx.rules.legacy file to 41-qeth-x.x.xxxx.rules)
Alternatively open a Case with SUSE Global Services.

Cause

The conversion script (/usr/lib/udev/scripts/convert-rules.sh) finds the obsolete legacy "collect" binary in the 41-qeth* rules file. On migration it triggers chzdev to create a new 41-qeth* rule.
Then finishing the processing the chzdev 41-qeth* rules file is renamed to 41-qeth* rules.legacy

(Usually only the 51-* rules files contain the call to 'collect', 41-rules are chzdev based.)

The second condition is caused by a parsing error in the conversion script and so the conversion of the 41-qeth rules file fails.

Disclaimer

This Support Knowledgebase provides a valuable tool for SUSE customers and parties interested in our products and solutions to acquire information, ideas and learn from one another. Materials are provided for informational, personal or non-commercial use within your organization and are presented "AS IS" WITHOUT WARRANTY OF ANY KIND.

  • Document ID:000020621
  • Creation Date: 26-Apr-2022
  • Modified Date:26-Apr-2022
    • SUSE Linux Enterprise Server

< Back to Support Search

For questions or concerns with the SUSE Knowledgebase please contact: tidfeedback[at]suse.com

SUSE Support Forums

Get your questions answered by experienced Sys Ops or interact with other SUSE community experts.

Support Resources

Learn how to get the most from the technical support you receive with your SUSE Subscription, Premium Support, Academic Program, or Partner Program.

Open an Incident

Open an incident with SUSE Technical Support, manage your subscriptions, download patches, or manage user access.