SUSE Support

Here When You Need Us

chroot failing with: cannot run command `/bin/bash': No such file or directory

This document (000020553) is provided subject to the disclaimer at the end of this document.

Environment

SUSE Linux Enterprise Server 15
SUSE Linux Enterprise Server 12
SUSE Linux Enterprise Server 11

Situation

After booting the server from a DVD via the "Rescue System" option, changing root into the installed OS is failing with: 
chroot: failed to run command ‘/bin/bash’: No such file or directory

 

Resolution

The problem could be fixed by: 
  • Making sure the real root filesystem is mounted. 
  • Ensuring that /bin/bash exists.
  • All needed libraries are installed.
  • Restoring the system from a valid backup. 

Cause

The cause of the error above could be:
  • Wrong root filesystem mounted. Double check if mounted disk is the real root filesystem.
  • The /bin/bash executable is missing or symbolic link pointing to non-existing/wrong file.
  • The libraries needed to run /bin/bash are missing. "ldd" could be used to check for the needed libraries. 
  • The root filesystem is missing either /lib or /lib64 directory.

Additional Information

Disclaimer

This Support Knowledgebase provides a valuable tool for SUSE customers and parties interested in our products and solutions to acquire information, ideas and learn from one another. Materials are provided for informational, personal or non-commercial use within your organization and are presented "AS IS" WITHOUT WARRANTY OF ANY KIND.

  • Document ID:000020553
  • Creation Date: 21-Jan-2022
  • Modified Date:24-Feb-2022
    • SUSE Linux Enterprise Server

< Back to Support Search

For questions or concerns with the SUSE Knowledgebase please contact: tidfeedback[at]suse.com

tick icon

SUSE Support Forums

Get your questions answered by experienced Sys Ops or interact with other SUSE community experts.

tick icon

Support Resources

Learn how to get the most from the technical support you receive with your SUSE Subscription, Premium Support, Academic Program, or Partner Program.

tick icon

Open an Incident

Open an incident with SUSE Technical Support, manage your subscriptions, download patches, or manage user access.