SUSE Support

Here When You Need Us

YaST mail server module missing ldap support after upgrade from SLES 11 SP4 to SLES 15

This document (000019719) is provided subject to the disclaimer at the end of this document.

Environment

SUSE Linux Enterprise Server SLES 15 SP2
​​​​​SUSE Linux Enterprise Server SLES 15 SP1
SUSE Linux Enterprise Server SLES 15
SUSE Linux Enterprise Server SLES 11 SP4

Situation

After upgrading, attempting to start the YaST2 mail server configuration module results in the following popup:
The setting MAIL_CREATE_CONFIG is turned off. You have
probably modified the configuration files directly.
If you continue, it will be turned on and
Config Postfix will overwrite manual changes.
         [Cancel]           [Continue]

 

Resolution

Do NOT continue, continuing will destroy the LDAP integration for postfix.

LDAP related configuration for postfix is no longer possible with YaST. The old configuration will still continue to work, but can no longer be changed/edited via YaST !

If already done, it is needed to restore the SLES 11 SP4 postfix configuration /etc/postfix/* from backup. Configuration changes need to be made manually in configuration files directly going forward.

Cause

LDAP support has been removed from the YaST2 mail server configuration module.

Disclaimer

This Support Knowledgebase provides a valuable tool for SUSE customers and parties interested in our products and solutions to acquire information, ideas and learn from one another. Materials are provided for informational, personal or non-commercial use within your organization and are presented "AS IS" WITHOUT WARRANTY OF ANY KIND.

  • Document ID:000019719
  • Creation Date: 18-Sep-2020
  • Modified Date:24-Sep-2020
    • SUSE Linux Enterprise Server

< Back to Support Search

For questions or concerns with the SUSE Knowledgebase please contact: tidfeedback[at]suse.com

SUSE Support Forums

Get your questions answered by experienced Sys Ops or interact with other SUSE community experts.

Support Resources

Learn how to get the most from the technical support you receive with your SUSE Subscription, Premium Support, Academic Program, or Partner Program.

Open an Incident

Open an incident with SUSE Technical Support, manage your subscriptions, download patches, or manage user access.