SUSE Support

Here When You Need Us

Warning messages related to mce are observed when booting SLES15 SP1 on AMD Zen 2 Systems

This document (7023967) is provided subject to the disclaimer at the end of this document.

Environment

SUSE Linux Enterprise Server 15 Service Pack 1 (SLES 15 SP1)

Situation

After booting SLES15 SP1 on AMD Zen 2 systems, the below warning message will be logged by kernel. 
[ 0.004000] WARNING: CPU: 8 PID: 0 at ../arch/x86/kernel/cpu/mcheck/mce.c:1481 mcheck_cpu_init+0x1a4/0x4c0

Resolution

This message has no adverse effects on the system state and can be safely ignored. Kernel details will be updated here once the maintenance update is released.

Cause

Linux reads MCG_CAP[Count] to find the number of MCA banks visible to a CPU. Currently, this is assumed to be the same for all CPUs and a warning is shown if there is a difference. This value has historically been the same for every core in the system, but that is not an architectural requirement. Future AMD systems may have different MCG_CAP[Count] values per core, so the assumption that all CPUs will have the same MCG_CAP[Count] value will no longer be valid.

Additional Information

See the following for more details: 
https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/commit/?id=006c077041dc73b9490fffc4c6af5befe0687110

Disclaimer

This Support Knowledgebase provides a valuable tool for SUSE customers and parties interested in our products and solutions to acquire information, ideas and learn from one another. Materials are provided for informational, personal or non-commercial use within your organization and are presented "AS IS" WITHOUT WARRANTY OF ANY KIND.

  • Document ID:7023967
  • Creation Date: 24-Jun-2019
  • Modified Date:03-Mar-2020
    • SUSE Linux Enterprise Server

< Back to Support Search

For questions or concerns with the SUSE Knowledgebase please contact: tidfeedback[at]suse.com

SUSE Support Forums

Get your questions answered by experienced Sys Ops or interact with other SUSE community experts.

Support Resources

Learn how to get the most from the technical support you receive with your SUSE Subscription, Premium Support, Academic Program, or Partner Program.

Open an Incident

Open an incident with SUSE Technical Support, manage your subscriptions, download patches, or manage user access.