SUSE Support

Here When You Need Us

Spacewalk 2.4 certificate expired for SUSE Manager 2.1 in July 2018

This document (7023192) is provided subject to the disclaimer at the end of this document.

Environment

SUSE Manager 2.1

Situation

A message is displayed in the login screen of the SUSE Manager web-UI:
"Your SUSE Manager Certificate has expired. Your SUSE Manager is on day 1 of 24 day restricted period and will soon stop functioning. Please contact SUSE for a new certificate."

Resolution

SUSE Manager 2.1 is out of support since April 2017. An upgrade to a supported version is mandatory. There will be no patch to prevent this issue or any other similar one.
However, customers have reported the following procedure to bypass the problem:

wget https://raw.githubusercontent.com/spacewalkproject/spacewalk/SPACEWALK-2.4/branding/setup/spacewalk-cert-key.gpg
gpg --keyring /etc/webapp-keyring.gpg --no-default-keyring --import spacewalk-cert-key.gpg
wget https://raw.githubusercontent.com/spacewalkproject/spacewalk/SPACEWALK-2.4/branding/setup/spacewalk-public.cert
rhn-satellite-activate --disconnected --rhn-cert=spacewalk-public.cert

Cause

Spacewalk 2.4 still uses certificates. This problem does not exist with following versions, such as 2.5. However, SUSE Manager 2.1 will not receive such updates, which are already available in newer versions.

Additional Information

Please upgrade your server to a supported version immediately. The process for the migration of version 2.1 to 3.0 is documented here:

From version 3.0 (supported till October 2018) upgrades to 3.1 and then to 3.2 are easily available by simply running "zypper migration"

The procedure explained as a workaround is documented by the spacewalk project: https://github.com/spacewalkproject/spacewalk/wiki/Refreshing-certificate

Disclaimer

This Support Knowledgebase provides a valuable tool for SUSE customers and parties interested in our products and solutions to acquire information, ideas and learn from one another. Materials are provided for informational, personal or non-commercial use within your organization and are presented "AS IS" WITHOUT WARRANTY OF ANY KIND.

  • Document ID:7023192
  • Creation Date: 23-Jul-2018
  • Modified Date:03-Mar-2020
    • SUSE Manager

< Back to Support Search

For questions or concerns with the SUSE Knowledgebase please contact: tidfeedback[at]suse.com

SUSE Support Forums

Get your questions answered by experienced Sys Ops or interact with other SUSE community experts.

Support Resources

Learn how to get the most from the technical support you receive with your SUSE Subscription, Premium Support, Academic Program, or Partner Program.

Open an Incident

Open an incident with SUSE Technical Support, manage your subscriptions, download patches, or manage user access.