SUSE Support

Here When You Need Us

snmpd crashes daily on SLES10SP4 when receiving SIGHUP from logrotate

This document (7009372) is provided subject to the disclaimer at the end of this document.

Environment

SUSE Linux Enterprise Server 10 Service Pack 4
 

Situation

net-snmp up to version 5.3.0.1-25.39.1
3rd party snmp agents

snmpd crashes daily with segmentation fault on SLES10SP4 installations.
Messages similar to the following will be available in /var/log/messages:
 
Jun  7 19:15:14 linux kernel: snmpd[3102]: segfault at 00002ba10a770b17 rip 00002ba10a770b17 rsp 00007fffd8c0cc38 error 14
Jun  8 19:15:18 linux kernel: snmpd[1491]: segfault at 00002afee38aeb17 rip 00002afee38aeb17 rsp 00007ffffce3b138 error 14
Jun 11 19:15:18 linux kernel: snmpd[9882]: segfault at 00002b4e6b786b17 rip 00002b4e6b786b17 rsp 00007fff712fffa8 error 14

One prerequisite for this issue to occur is the presence of 3rd party snmp agents, e.g. hp-snmp-agents.
 

Resolution

Edit /etc/logrotate.d/net-snmp and change the line
 
/etc/init.d/snmpd reload ||:

 to

/etc/init.d/snmpd try-restart ||:

Cause

snmpd crashes while receiving a SIGHUP from logrotate to reread its configuration settings.
 

Disclaimer

This Support Knowledgebase provides a valuable tool for SUSE customers and parties interested in our products and solutions to acquire information, ideas and learn from one another. Materials are provided for informational, personal or non-commercial use within your organization and are presented "AS IS" WITHOUT WARRANTY OF ANY KIND.

  • Document ID:7009372
  • Creation Date: 12-Jun-2012
  • Modified Date:10-Mar-2021
    • SUSE Linux Enterprise Server

< Back to Support Search

For questions or concerns with the SUSE Knowledgebase please contact: tidfeedback[at]suse.com

SUSE Support Forums

Get your questions answered by experienced Sys Ops or interact with other SUSE community experts.

Support Resources

Learn how to get the most from the technical support you receive with your SUSE Subscription, Premium Support, Academic Program, or Partner Program.

Open an Incident

Open an incident with SUSE Technical Support, manage your subscriptions, download patches, or manage user access.