Not possible to `ifup` a VLAN device after configuration with YaST

This document (7006714) is provided subject to the disclaimer at the end of this document.

Environment

SUSE Linux Enterprise Server 10 Service Pack 3

Situation

After creation of a new NIC for a VLAN in Yast, it is not possible to start the network device with `ifup`, albeit the configuration file is existent in "/etc/sysconfig/network". The error message might look like the following:

# ifup vlan0
vlan0
Error in getcfg-interface (get_config.c, 303):
Give exactly one argument
...
...
interface  is not available
SIOCGIFFLAGS: No such device
Cannot enable interface vlan0.
interface vlan0 is not up

Resolution

A fix is already available and published. Install yast2-network with version 2.13.139-0.6.1.1 or higher if existent.

Disclaimer

This Support Knowledgebase provides a valuable tool for SUSE customers and parties interested in our products and solutions to acquire information, ideas and learn from one another. Materials are provided for informational, personal or non-commercial use within your organization and are presented "AS IS" WITHOUT WARRANTY OF ANY KIND.

  • Document ID:7006714
  • Creation Date: 24-Aug-2010
  • Modified Date:03-Mar-2020
    • SUSE Linux Enterprise Server

< Back to Support Search

For questions or concerns with the SUSE Knowledgebase please contact: tidfeedback@suse.com

SUSE Support Forums

Get your questions answered by experienced Sys Ops or interact with other SUSE community experts.

Join Our Community

Support Resources

Learn how to get the most from the technical support you receive with your SUSE Subscription, Premium Support, Academic Program, or Partner Program.


SUSE Customer Support Quick Reference Guide SUSE Technical Support Handbook Update Advisories
Support FAQ

Open an Incident

Open an incident with SUSE Technical Support, manage your subscriptions, download patches, or manage user access.

Go to Customer Center