VM's may not start or install after latest SLES 11 SP1 updates

This document (7006491) is provided subject to the disclaimer at the end of this document.

Environment

SUSE Linux Enterprise Server 11 Service Pack 1
XEN

Situation

After applying the lastest round of SLES 11 SP1 updates (specifically the kernel update) the following may occur:
  • Unable to install a new Virtual Machine (VM)
  • Previously working VM will not start
  • Error: 'Device [X] (vif) could not be connected. Hotplug scripts not working.'
  • Error regarding virtual block device not being available / found

Resolution

Apply kernel version 2.6.32.13-0.5 or later.

Additional Information

The problem was introduced in the 2.6.32.13-0.4 kernel.  A deadlock condition can occur that will result in the unwanted behavior.

Disclaimer

This Support Knowledgebase provides a valuable tool for SUSE customers and parties interested in our products and solutions to acquire information, ideas and learn from one another. Materials are provided for informational, personal or non-commercial use within your organization and are presented "AS IS" WITHOUT WARRANTY OF ANY KIND.

  • Document ID:7006491
  • Creation Date: 22-Jul-2010
  • Modified Date:03-Mar-2020
    • SUSE Linux Enterprise Server

< Back to Support Search

For questions or concerns with the SUSE Knowledgebase please contact: tidfeedback@suse.com

SUSE Support Forums

Get your questions answered by experienced Sys Ops or interact with other SUSE community experts.

Join Our Community

Support Resources

Learn how to get the most from the technical support you receive with your SUSE Subscription, Premium Support, Academic Program, or Partner Program.


SUSE Customer Support Quick Reference Guide SUSE Technical Support Handbook Update Advisories
Support FAQ

Open an Incident

Open an incident with SUSE Technical Support, manage your subscriptions, download patches, or manage user access.

Go to Customer Center