XEN: DomU using tap:aio could not be started

This document (7000742) is provided subject to the disclaimer at the end of this document.

Environment

SUSE Linux Enterprise Server 10 Service Pack 1

Situation

Dom0 is running SLES10 SP1.
DomU is is configured to use tap:aio for the disk images.
One of the following messages
Error: Device 51952 (vbd) could not be connected. Hotplug scripts not working
Error: Device /dev/xvdp (tap) could not be disconnected.

is seen when starting domU with
xm start <DomU_ID>

Resolution

  1. Update Dom0 to SLES10 SP2. Refer to TID 7000387 - How to update to SLES/SLED 10 SP2 for details.
  2. When multipath is used, use a multipath configuration /etc/multipath.conf and blacklist the device /dev/xvdp in it.
     

Disclaimer

This Support Knowledgebase provides a valuable tool for SUSE customers and parties interested in our products and solutions to acquire information, ideas and learn from one another. Materials are provided for informational, personal or non-commercial use within your organization and are presented "AS IS" WITHOUT WARRANTY OF ANY KIND.

  • Document ID:7000742
  • Creation Date: 24-Jun-2008
  • Modified Date:14-Mar-2021
    • SUSE Linux Enterprise Server

< Back to Support Search

For questions or concerns with the SUSE Knowledgebase please contact: tidfeedback@suse.com

SUSE Support Forums

Get your questions answered by experienced Sys Ops or interact with other SUSE community experts.

Join Our Community

Support Resources

Learn how to get the most from the technical support you receive with your SUSE Subscription, Premium Support, Academic Program, or Partner Program.


SUSE Customer Support Quick Reference Guide SUSE Technical Support Handbook Update Advisories
Support FAQ

Open an Incident

Open an incident with SUSE Technical Support, manage your subscriptions, download patches, or manage user access.

Go to Customer Center