Upstream information
Description
Authlib is a Python library which builds OAuth and OpenID Connect servers. Prior to 1.9.0, the default RFC 7523 JWTBearerGrant.get_audiences() returns an empty list, causing JWTBearerGrant.verify_claims() to require only that an aud claim exists without matching the current authorization server. An attacker holding a legitimate assertion for another service can present it to a server that shares the signing key and uses the default grant, obtaining an access token across a trust boundary. Implementations that override get_audiences() with the server's valid audience identifiers are not affected. This issue is fixed in version 1.9.0.SUSE information
Overall state of this security issue: Pending
This issue is currently rated as having moderate severity.
| CVSS detail | CNA (GitHub) | SUSE |
|---|---|---|
| Base Score | 6.8 | 6.8 |
| Vector | CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:N | CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:N |
| Attack Vector | Network | Network |
| Attack Complexity | High | High |
| Privileges Required | Low | Low |
| User Interaction | None | None |
| Scope | Unchanged | Unchanged |
| Confidentiality Impact | High | High |
| Integrity Impact | High | High |
| Availability Impact | None | None |
| CVSSv3 Version | 3.1 | 3.1 |
| CVSS detail | SUSE |
|---|---|
| Base Score | 7.6 |
| Vector | CVSS:4.0/AV:N/AC:H/AT:N/PR:L/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N |
| Attack Vector | Network |
| Attack Complexity | High |
| Attack Requirements | None |
| Privileges Required | Low |
| User Interaction | None |
| Vulnerable System Confidentiality Impact | High |
| Vulnerable System Integrity Impact | High |
| Vulnerable System Availability Impact | None |
| Subsequent System Confidentiality Impact | None |
| Subsequent System Integrity Impact | None |
| Subsequent System Availability Impact | None |
| CVSSv4 Version | 4.0 |
Status of this issue by product and package
Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification. The updates are grouped by state of their lifecycle. SUSE product lifecycles are documented on the lifecycle page.
| Product(s) | Source package | State |
|---|---|---|
| Products under general support and receiving all security fixes. | ||
| SUSE Linux Enterprise Desktop 15 SP7 | python-Authlib | Affected |
| SUSE Linux Enterprise Module for Python 3 15 SP7 | python-Authlib | Affected |
| SUSE Linux Enterprise Server 15 SP7 | python-Authlib | Affected |
| SUSE Linux Enterprise Server for SAP Applications 15 SP7 | python-Authlib | Affected |
| Products under Long Term Service Pack support and receiving important and critical security fixes. | ||
| SUSE Linux Enterprise Module for Python 3 15 SP6 | python-Authlib | Affected |
| SUSE Linux Enterprise Server 15 SP6-LTSS | python-Authlib | Affected |
| SUSE Linux Enterprise Server for SAP Applications 15 SP6 | python-Authlib | Affected |
| Products past their end of life and not receiving proactive updates anymore. | ||
| SUSE Linux Enterprise Desktop 15 SP6 | python-Authlib | Affected |
| SUSE Linux Enterprise Server 15 SP6 | python-Authlib | Affected |
| openSUSE Leap 15.6 | python-Authlib | Affected |
SUSE Timeline for this CVE
CVE page created: Tue Oct 27 17:50:08 2026CVE page last modified: Thu Oct 29 17:01:14 2026