Upstream information

CVE-2024-4317 at MITRE

Description

Missing authorization in PostgreSQL built-in views pg_stats_ext and pg_stats_ext_exprs allows an unprivileged database user to read most common values and other statistics from CREATE STATISTICS commands of other users. The most common values may reveal column values the eavesdropper could not otherwise read or results of functions they cannot execute. Installing an unaffected version only fixes fresh PostgreSQL installations, namely those that are created with the initdb utility after installing that version. Current PostgreSQL installations will remain vulnerable until they follow the instructions in the release notes. Within major versions 14-16, minor versions before PostgreSQL 16.3, 15.7, and 14.12 are affected. Versions before PostgreSQL 14 are unaffected.

Upstream Security Advisories:

SUSE information

Overall state of this security issue: Pending

This issue is currently rated as having moderate severity.

CVSS v3 Scores
  SUSE
Base Score 6.2
Vector CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Attack Vector Local
Attack Complexity Low
Privileges Required None
User Interaction None
Scope Unchanged
Confidentiality Impact High
Integrity Impact None
Availability Impact None
CVSSv3 Version 3.1
SUSE Bugzilla entry: 1224038 [IN_PROGRESS]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
Container suse/manager/5.0/x86_64/server-migration-14-16:latest
  • libpq5 >= 16.2-150600.16.2.1
  • postgresql14 >= 14.12-150600.16.3.1
  • postgresql14-contrib >= 14.12-150600.16.3.1
  • postgresql14-server >= 14.12-150600.16.3.1
  • postgresql16 >= 16.2-150600.16.2.1
  • postgresql16-contrib >= 16.2-150600.16.2.1
  • postgresql16-server >= 16.2-150600.16.2.1
Container suse/manager/5.0/x86_64/server:latest
  • libpq5 >= 16.2-150600.16.2.1
  • postgresql16 >= 16.2-150600.16.2.1
  • postgresql16-contrib >= 16.2-150600.16.2.1
  • postgresql16-server >= 16.2-150600.16.2.1
Container suse/postgres:15.7-20.3
  • libpq5 >= 16.3-150200.5.13.1
  • postgresql15 >= 15.7-150200.5.27.1
  • postgresql15-server >= 15.7-150200.5.27.1
Container suse/postgres:16.2-36.4
  • libpq5 >= 16.2-150600.16.2.1
  • postgresql16 >= 16.2-150600.16.2.1
  • postgresql16-server >= 16.2-150600.16.2.1
Image SLES15-SP4-Manager-Server-4-3
Image SLES15-SP4-Manager-Server-4-3-Azure-llc
Image SLES15-SP4-Manager-Server-4-3-Azure-ltd
Image SLES15-SP4-Manager-Server-4-3-BYOS
Image SLES15-SP4-Manager-Server-4-3-BYOS-Azure
Image SLES15-SP4-Manager-Server-4-3-BYOS-EC2
Image SLES15-SP4-Manager-Server-4-3-BYOS-GCE
Image SLES15-SP4-Manager-Server-4-3-EC2-llc
Image SLES15-SP4-Manager-Server-4-3-EC2-ltd
  • libpq5 >= 16.3-150200.5.13.1
  • postgresql14 >= 14.12-150200.5.44.1
  • postgresql14-contrib >= 14.12-150200.5.44.1
  • postgresql14-server >= 14.12-150200.5.44.1
SUSE Linux Enterprise Desktop 15 SP5
SUSE Linux Enterprise Module for Basesystem 15 SP5
  • libpq5 >= 16.3-150200.5.13.1
  • libpq5-32bit >= 16.3-150200.5.13.1
  • postgresql15 >= 15.7-150200.5.27.1
  • postgresql16 >= 16.3-150200.5.13.1
Patchnames:
SUSE-SLE-Module-Basesystem-15-SP5-2024-1652
SUSE-SLE-Module-Basesystem-15-SP5-2024-1777
SUSE Linux Enterprise Desktop 15 SP6
SUSE Linux Enterprise Module for Basesystem 15 SP6
  • libpq5 >= 16.2-150600.16.2.1
  • libpq5-32bit >= 16.2-150600.16.2.1
  • postgresql16 >= 16.2-150600.16.2.1
Patchnames:
SUSE-SLE-Module-Basesystem-15-SP6-2024-2266
SUSE Linux Enterprise High Performance Computing 15 SP5
SUSE Linux Enterprise Server 15 SP5
SUSE Linux Enterprise Server for SAP Applications 15 SP5
  • libecpg6 >= 16.3-150200.5.13.1
  • libpq5 >= 16.3-150200.5.13.1
  • libpq5-32bit >= 16.3-150200.5.13.1
  • postgresql14 >= 14.12-150200.5.44.1
  • postgresql14-contrib >= 14.12-150200.5.44.1
  • postgresql14-devel >= 14.12-150200.5.44.1
  • postgresql14-docs >= 14.12-150200.5.44.1
  • postgresql14-llvmjit >= 14.12-150200.5.44.1
  • postgresql14-llvmjit-devel >= 14.12-150200.5.44.1
  • postgresql14-plperl >= 14.12-150200.5.44.1
  • postgresql14-plpython >= 14.12-150200.5.44.1
  • postgresql14-pltcl >= 14.12-150200.5.44.1
  • postgresql14-server >= 14.12-150200.5.44.1
  • postgresql14-server-devel >= 14.12-150200.5.44.1
  • postgresql15 >= 15.7-150200.5.27.1
  • postgresql15-contrib >= 15.7-150200.5.27.1
  • postgresql15-devel >= 15.7-150200.5.27.1
  • postgresql15-docs >= 15.7-150200.5.27.1
  • postgresql15-plperl >= 15.7-150200.5.27.1
  • postgresql15-plpython >= 15.7-150200.5.27.1
  • postgresql15-pltcl >= 15.7-150200.5.27.1
  • postgresql15-server >= 15.7-150200.5.27.1
  • postgresql15-server-devel >= 15.7-150200.5.27.1
  • postgresql16 >= 16.3-150200.5.13.1
  • postgresql16-contrib >= 16.3-150200.5.13.1
  • postgresql16-devel >= 16.3-150200.5.13.1
  • postgresql16-docs >= 16.3-150200.5.13.1
  • postgresql16-plperl >= 16.3-150200.5.13.1
  • postgresql16-plpython >= 16.3-150200.5.13.1
  • postgresql16-pltcl >= 16.3-150200.5.13.1
  • postgresql16-server >= 16.3-150200.5.13.1
  • postgresql16-server-devel >= 16.3-150200.5.13.1
Patchnames:
SUSE-SLE-Module-Basesystem-15-SP5-2024-1652
SUSE-SLE-Module-Basesystem-15-SP5-2024-1777
SUSE-SLE-Module-Legacy-15-SP5-2024-1768
SUSE-SLE-Module-Server-Applications-15-SP5-2024-1652
SUSE-SLE-Module-Server-Applications-15-SP5-2024-1777
SUSE Linux Enterprise High Performance Computing 15 SP6
SUSE Linux Enterprise Server 15 SP6
SUSE Linux Enterprise Server for SAP Applications 15 SP6
  • libecpg6 >= 16.2-150600.16.2.1
  • libpq5 >= 16.2-150600.16.2.1
  • libpq5-32bit >= 16.2-150600.16.2.1
  • postgresql15 >= 15.7-150600.16.3.1
  • postgresql15-contrib >= 15.7-150600.16.3.1
  • postgresql15-server >= 15.7-150600.16.3.1
  • postgresql16 >= 16.2-150600.16.2.1
  • postgresql16-contrib >= 16.2-150600.16.2.1
  • postgresql16-devel >= 16.2-150600.16.2.1
  • postgresql16-docs >= 16.2-150600.16.2.1
  • postgresql16-plperl >= 16.2-150600.16.2.1
  • postgresql16-plpython >= 16.2-150600.16.2.1
  • postgresql16-pltcl >= 16.2-150600.16.2.1
  • postgresql16-server >= 16.2-150600.16.2.1
  • postgresql16-server-devel >= 16.2-150600.16.2.1
Patchnames:
SUSE-SLE-Module-Basesystem-15-SP6-2024-2266
SUSE-SLE-Module-Legacy-15-SP6-2024-2261
SUSE-SLE-Module-Server-Applications-15-SP6-2024-2266
SUSE Linux Enterprise Module for Legacy 15 SP5
  • postgresql14 >= 14.12-150200.5.44.1
  • postgresql14-contrib >= 14.12-150200.5.44.1
  • postgresql14-devel >= 14.12-150200.5.44.1
  • postgresql14-docs >= 14.12-150200.5.44.1
  • postgresql14-llvmjit >= 14.12-150200.5.44.1
  • postgresql14-llvmjit-devel >= 14.12-150200.5.44.1
  • postgresql14-plperl >= 14.12-150200.5.44.1
  • postgresql14-plpython >= 14.12-150200.5.44.1
  • postgresql14-pltcl >= 14.12-150200.5.44.1
  • postgresql14-server >= 14.12-150200.5.44.1
  • postgresql14-server-devel >= 14.12-150200.5.44.1
Patchnames:
SUSE-SLE-Module-Legacy-15-SP5-2024-1768
SUSE Linux Enterprise Module for Legacy 15 SP6
  • postgresql15 >= 15.7-150600.16.3.1
  • postgresql15-contrib >= 15.7-150600.16.3.1
  • postgresql15-server >= 15.7-150600.16.3.1
Patchnames:
SUSE-SLE-Module-Legacy-15-SP6-2024-2261
SUSE Linux Enterprise Module for Package Hub 15 SP5
  • postgresql14-llvmjit >= 14.12-150200.5.44.1
  • postgresql14-test >= 14.12-150200.5.44.1
  • postgresql16-llvmjit >= 16.3-150200.5.13.1
  • postgresql16-llvmjit-devel >= 16.3-150200.5.13.1
  • postgresql16-test >= 16.3-150200.5.13.1
Patchnames:
SUSE-SLE-Module-Packagehub-Subpackages-15-SP5-2024-1652
SUSE-SLE-Module-Packagehub-Subpackages-15-SP5-2024-1768
SUSE Linux Enterprise Module for Package Hub 15 SP6
  • postgresql14-llvmjit >= 14.12-150600.16.3.1
  • postgresql14-test >= 14.12-150600.16.3.1
Patchnames:
SUSE-SLE-Module-Packagehub-Subpackages-15-SP6-2024-2262
SUSE Linux Enterprise Module for Server Applications 15 SP5
  • libecpg6 >= 16.3-150200.5.13.1
  • postgresql15-contrib >= 15.7-150200.5.27.1
  • postgresql15-devel >= 15.7-150200.5.27.1
  • postgresql15-docs >= 15.7-150200.5.27.1
  • postgresql15-plperl >= 15.7-150200.5.27.1
  • postgresql15-plpython >= 15.7-150200.5.27.1
  • postgresql15-pltcl >= 15.7-150200.5.27.1
  • postgresql15-server >= 15.7-150200.5.27.1
  • postgresql15-server-devel >= 15.7-150200.5.27.1
  • postgresql16-contrib >= 16.3-150200.5.13.1
  • postgresql16-devel >= 16.3-150200.5.13.1
  • postgresql16-docs >= 16.3-150200.5.13.1
  • postgresql16-plperl >= 16.3-150200.5.13.1
  • postgresql16-plpython >= 16.3-150200.5.13.1
  • postgresql16-pltcl >= 16.3-150200.5.13.1
  • postgresql16-server >= 16.3-150200.5.13.1
  • postgresql16-server-devel >= 16.3-150200.5.13.1
Patchnames:
SUSE-SLE-Module-Server-Applications-15-SP5-2024-1652
SUSE-SLE-Module-Server-Applications-15-SP5-2024-1777
SUSE Linux Enterprise Module for Server Applications 15 SP6
  • libecpg6 >= 16.2-150600.16.2.1
  • postgresql16-contrib >= 16.2-150600.16.2.1
  • postgresql16-devel >= 16.2-150600.16.2.1
  • postgresql16-docs >= 16.2-150600.16.2.1
  • postgresql16-plperl >= 16.2-150600.16.2.1
  • postgresql16-plpython >= 16.2-150600.16.2.1
  • postgresql16-pltcl >= 16.2-150600.16.2.1
  • postgresql16-server >= 16.2-150600.16.2.1
  • postgresql16-server-devel >= 16.2-150600.16.2.1
Patchnames:
SUSE-SLE-Module-Server-Applications-15-SP6-2024-2266
SUSE Linux Enterprise Server 12 SP5
SUSE Linux Enterprise Server for SAP Applications 12 SP5
  • libecpg6 >= 16.3-3.13.1
  • libecpg6-32bit >= 16.3-3.13.1
  • libpq5 >= 16.3-3.13.1
  • libpq5-32bit >= 16.3-3.13.1
  • postgresql14 >= 14.12-3.41.1
  • postgresql14-contrib >= 14.12-3.41.1
  • postgresql14-devel >= 14.12-3.41.1
  • postgresql14-docs >= 14.12-3.41.1
  • postgresql14-plperl >= 14.12-3.41.1
  • postgresql14-plpython >= 14.12-3.41.1
  • postgresql14-pltcl >= 14.12-3.41.1
  • postgresql14-server >= 14.12-3.41.1
  • postgresql14-server-devel >= 14.12-3.41.1
  • postgresql15 >= 15.7-3.25.1
  • postgresql15-contrib >= 15.7-3.25.1
  • postgresql15-devel >= 15.7-3.25.1
  • postgresql15-docs >= 15.7-3.25.1
  • postgresql15-plperl >= 15.7-3.25.1
  • postgresql15-plpython >= 15.7-3.25.1
  • postgresql15-pltcl >= 15.7-3.25.1
  • postgresql15-server >= 15.7-3.25.1
  • postgresql15-server-devel >= 15.7-3.25.1
  • postgresql16 >= 16.3-3.13.1
  • postgresql16-contrib >= 16.3-3.13.1
  • postgresql16-devel >= 16.3-3.13.1
  • postgresql16-docs >= 16.3-3.13.1
  • postgresql16-plperl >= 16.3-3.13.1
  • postgresql16-plpython >= 16.3-3.13.1
  • postgresql16-pltcl >= 16.3-3.13.1
  • postgresql16-server >= 16.3-3.13.1
  • postgresql16-server-devel >= 16.3-3.13.1
Patchnames:
SUSE-SLE-SDK-12-SP5-2024-1651
SUSE-SLE-SDK-12-SP5-2024-1653
SUSE-SLE-SDK-12-SP5-2024-1703
SUSE-SLE-SERVER-12-SP5-2024-1651
SUSE-SLE-SERVER-12-SP5-2024-1653
SUSE-SLE-SERVER-12-SP5-2024-1703
SUSE Linux Enterprise Software Development Kit 12 SP5
  • postgresql14-devel >= 14.12-3.41.1
  • postgresql14-server-devel >= 14.12-3.41.1
  • postgresql15-devel >= 15.7-3.25.1
  • postgresql15-server-devel >= 15.7-3.25.1
  • postgresql16-devel >= 16.3-3.13.1
  • postgresql16-server-devel >= 16.3-3.13.1
Patchnames:
SUSE-SLE-SDK-12-SP5-2024-1651
SUSE-SLE-SDK-12-SP5-2024-1653
SUSE-SLE-SDK-12-SP5-2024-1703
openSUSE Leap 15.5
  • libecpg6 >= 16.3-150200.5.13.1
  • libecpg6-32bit >= 16.3-150200.5.13.1
  • libpq5 >= 16.3-150200.5.13.1
  • libpq5-32bit >= 16.3-150200.5.13.1
  • postgresql14 >= 14.12-150200.5.44.1
  • postgresql14-contrib >= 14.12-150200.5.44.1
  • postgresql14-devel >= 14.12-150200.5.44.1
  • postgresql14-docs >= 14.12-150200.5.44.1
  • postgresql14-llvmjit >= 14.12-150200.5.44.1
  • postgresql14-llvmjit-devel >= 14.12-150200.5.44.1
  • postgresql14-plperl >= 14.12-150200.5.44.1
  • postgresql14-plpython >= 14.12-150200.5.44.1
  • postgresql14-pltcl >= 14.12-150200.5.44.1
  • postgresql14-server >= 14.12-150200.5.44.1
  • postgresql14-server-devel >= 14.12-150200.5.44.1
  • postgresql14-test >= 14.12-150200.5.44.1
  • postgresql15 >= 15.7-150200.5.27.1
  • postgresql15-contrib >= 15.7-150200.5.27.1
  • postgresql15-devel >= 15.7-150200.5.27.1
  • postgresql15-docs >= 15.7-150200.5.27.1
  • postgresql15-llvmjit >= 15.7-150200.5.27.1
  • postgresql15-llvmjit-devel >= 15.7-150200.5.27.1
  • postgresql15-plperl >= 15.7-150200.5.27.1
  • postgresql15-plpython >= 15.7-150200.5.27.1
  • postgresql15-pltcl >= 15.7-150200.5.27.1
  • postgresql15-server >= 15.7-150200.5.27.1
  • postgresql15-server-devel >= 15.7-150200.5.27.1
  • postgresql15-test >= 15.7-150200.5.27.1
  • postgresql16 >= 16.3-150200.5.13.1
  • postgresql16-contrib >= 16.3-150200.5.13.1
  • postgresql16-devel >= 16.3-150200.5.13.1
  • postgresql16-devel-mini >= 16.3-150200.5.13.1
  • postgresql16-docs >= 16.3-150200.5.13.1
  • postgresql16-llvmjit >= 16.3-150200.5.13.1
  • postgresql16-llvmjit-devel >= 16.3-150200.5.13.1
  • postgresql16-plperl >= 16.3-150200.5.13.1
  • postgresql16-plpython >= 16.3-150200.5.13.1
  • postgresql16-pltcl >= 16.3-150200.5.13.1
  • postgresql16-server >= 16.3-150200.5.13.1
  • postgresql16-server-devel >= 16.3-150200.5.13.1
  • postgresql16-test >= 16.3-150200.5.13.1
Patchnames:
openSUSE-SLE-15.5-2024-1652
openSUSE-SLE-15.5-2024-1768
openSUSE-SLE-15.5-2024-1777
openSUSE Leap 15.6
  • libecpg6 >= 16.2-150600.16.2.1
  • libecpg6-32bit >= 16.2-150600.16.2.1
  • libpq5 >= 16.2-150600.16.2.1
  • libpq5-32bit >= 16.2-150600.16.2.1
  • postgresql14 >= 14.12-150600.16.3.1
  • postgresql14-contrib >= 14.12-150600.16.3.1
  • postgresql14-devel >= 14.12-150600.16.3.1
  • postgresql14-docs >= 14.12-150600.16.3.1
  • postgresql14-llvmjit >= 14.12-150600.16.3.1
  • postgresql14-llvmjit-devel >= 14.12-150600.16.3.1
  • postgresql14-plperl >= 14.12-150600.16.3.1
  • postgresql14-plpython >= 14.12-150600.16.3.1
  • postgresql14-pltcl >= 14.12-150600.16.3.1
  • postgresql14-server >= 14.12-150600.16.3.1
  • postgresql14-server-devel >= 14.12-150600.16.3.1
  • postgresql14-test >= 14.12-150600.16.3.1
  • postgresql15 >= 15.7-150600.16.3.1
  • postgresql15-contrib >= 15.7-150600.16.3.1
  • postgresql15-devel >= 15.7-150600.16.3.1
  • postgresql15-docs >= 15.7-150600.16.3.1
  • postgresql15-llvmjit >= 15.7-150600.16.3.1
  • postgresql15-llvmjit-devel >= 15.7-150600.16.3.1
  • postgresql15-plperl >= 15.7-150600.16.3.1
  • postgresql15-plpython >= 15.7-150600.16.3.1
  • postgresql15-pltcl >= 15.7-150600.16.3.1
  • postgresql15-server >= 15.7-150600.16.3.1
  • postgresql15-server-devel >= 15.7-150600.16.3.1
  • postgresql15-test >= 15.7-150600.16.3.1
  • postgresql16 >= 16.2-150600.16.2.1
  • postgresql16-contrib >= 16.2-150600.16.2.1
  • postgresql16-devel >= 16.2-150600.16.2.1
  • postgresql16-docs >= 16.2-150600.16.2.1
  • postgresql16-llvmjit >= 16.2-150600.16.2.1
  • postgresql16-llvmjit-devel >= 16.2-150600.16.2.1
  • postgresql16-plperl >= 16.2-150600.16.2.1
  • postgresql16-plpython >= 16.2-150600.16.2.1
  • postgresql16-pltcl >= 16.2-150600.16.2.1
  • postgresql16-server >= 16.2-150600.16.2.1
  • postgresql16-server-devel >= 16.2-150600.16.2.1
  • postgresql16-test >= 16.2-150600.16.2.1
Patchnames:
openSUSE-SLE-15.6-2024-2261
openSUSE-SLE-15.6-2024-2262
openSUSE-SLE-15.6-2024-2266
openSUSE Tumbleweed
  • libecpg6 >= 16.3-1.1
  • libecpg6-32bit >= 16.3-1.1
  • libpq5 >= 16.3-1.1
  • libpq5-32bit >= 16.3-1.1
  • postgresql14 >= 14.12-1.1
  • postgresql14-contrib >= 14.12-1.1
  • postgresql14-devel >= 14.12-1.1
  • postgresql14-docs >= 14.12-1.1
  • postgresql14-llvmjit >= 14.12-1.1
  • postgresql14-llvmjit-devel >= 14.12-1.1
  • postgresql14-plperl >= 14.12-1.1
  • postgresql14-plpython >= 14.12-1.1
  • postgresql14-pltcl >= 14.12-1.1
  • postgresql14-server >= 14.12-1.1
  • postgresql14-server-devel >= 14.12-1.1
  • postgresql14-test >= 14.12-1.1
  • postgresql15 >= 15.7-1.1
  • postgresql15-contrib >= 15.7-1.1
  • postgresql15-devel >= 15.7-1.1
  • postgresql15-docs >= 15.7-1.1
  • postgresql15-llvmjit >= 15.7-1.1
  • postgresql15-llvmjit-devel >= 15.7-1.1
  • postgresql15-plperl >= 15.7-1.1
  • postgresql15-plpython >= 15.7-1.1
  • postgresql15-pltcl >= 15.7-1.1
  • postgresql15-server >= 15.7-1.1
  • postgresql15-server-devel >= 15.7-1.1
  • postgresql15-test >= 15.7-1.1
  • postgresql16 >= 16.3-1.1
  • postgresql16-contrib >= 16.3-1.1
  • postgresql16-devel >= 16.3-1.1
  • postgresql16-docs >= 16.3-1.1
  • postgresql16-llvmjit >= 16.3-1.1
  • postgresql16-llvmjit-devel >= 16.3-1.1
  • postgresql16-plperl >= 16.3-1.1
  • postgresql16-plpython >= 16.3-1.1
  • postgresql16-pltcl >= 16.3-1.1
  • postgresql16-server >= 16.3-1.1
  • postgresql16-server-devel >= 16.3-1.1
  • postgresql16-test >= 16.3-1.1
Patchnames:
openSUSE-Tumbleweed-2024-13946
openSUSE-Tumbleweed-2024-13947
openSUSE-Tumbleweed-2024-13950

List of packages in QA

Product(s) Package(s)
SUSE Linux Enterprise Module for Legacy 15 SP6
  • postgresql14 >= 14.12-150600.16.3.1
  • postgresql14-contrib >= 14.12-150600.16.3.1
  • postgresql14-server >= 14.12-150600.16.3.1
SUSE Linux Enterprise Server 15 SP6
  • postgresql14 >= 14.12-150600.16.3.1
  • postgresql14-contrib >= 14.12-150600.16.3.1
  • postgresql14-server >= 14.12-150600.16.3.1
SUSE Linux Enterprise Server for SAP Applications 15 SP6
  • postgresql14 >= 14.12-150600.16.3.1
  • postgresql14-contrib >= 14.12-150600.16.3.1
  • postgresql14-server >= 14.12-150600.16.3.1
SUSE Linux Enterprise High Performance Computing 15 SP6
  • postgresql14 >= 14.12-150600.16.3.1
  • postgresql14-contrib >= 14.12-150600.16.3.1
  • postgresql14-server >= 14.12-150600.16.3.1


First public cloud image revisions this CVE is fixed in:


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification. The updates are grouped by state of their lifecycle. SUSE product lifecycles are documented on the lifecycle page.

Product(s) Source package State
Products under general support and receiving all security fixes.
SUSE Enterprise Storage 7.1 postgresql10 Not affected
SUSE Enterprise Storage 7.1 postgresql12 Not affected
SUSE Enterprise Storage 7.1 postgresql13 Not affected
SUSE Enterprise Storage 7.1 postgresql14 Affected
SUSE Enterprise Storage 7.1 postgresql15 Affected
SUSE Enterprise Storage 7.1 postgresql16 Affected
SUSE Linux Enterprise Desktop 15 SP5 postgresql15 Released
SUSE Linux Enterprise Desktop 15 SP5 postgresql16 Released
SUSE Linux Enterprise Desktop 15 SP6 postgresql16 Released
SUSE Linux Enterprise High Performance Computing 12 SP5 postgresql10 Not affected
SUSE Linux Enterprise High Performance Computing 12 SP5 postgresql12 Not affected
SUSE Linux Enterprise High Performance Computing 12 SP5 postgresql13 Not affected
SUSE Linux Enterprise High Performance Computing 12 SP5 postgresql14 Released
SUSE Linux Enterprise High Performance Computing 12 SP5 postgresql15 Released
SUSE Linux Enterprise High Performance Computing 12 SP5 postgresql16 Released
SUSE Linux Enterprise High Performance Computing 15 SP5 postgresql14 Released
SUSE Linux Enterprise High Performance Computing 15 SP5 postgresql15 Released
SUSE Linux Enterprise High Performance Computing 15 SP5 postgresql16 Released
SUSE Linux Enterprise High Performance Computing 15 SP6 postgresql14 In progress
SUSE Linux Enterprise High Performance Computing 15 SP6 postgresql15 Released
SUSE Linux Enterprise High Performance Computing 15 SP6 postgresql16 Released
SUSE Linux Enterprise Module for Basesystem 15 SP5 postgresql15 Released
SUSE Linux Enterprise Module for Basesystem 15 SP5 postgresql16 Released
SUSE Linux Enterprise Module for Basesystem 15 SP6 postgresql16 Released
SUSE Linux Enterprise Module for Legacy 15 SP5 postgresql14 Released
SUSE Linux Enterprise Module for Legacy 15 SP6 postgresql14 In progress
SUSE Linux Enterprise Module for Legacy 15 SP6 postgresql15 Released
SUSE Linux Enterprise Module for Package Hub 15 SP5 postgresql14 Released
SUSE Linux Enterprise Module for Package Hub 15 SP5 postgresql16 Released
SUSE Linux Enterprise Module for Package Hub 15 SP6 postgresql14 Released
SUSE Linux Enterprise Module for Server Applications 15 SP5 postgresql15 Released
SUSE Linux Enterprise Module for Server Applications 15 SP5 postgresql16 Released
SUSE Linux Enterprise Module for Server Applications 15 SP6 postgresql16 Released
SUSE Linux Enterprise Server 12 SP5 postgresql10 Not affected
SUSE Linux Enterprise Server 12 SP5 postgresql12 Not affected
SUSE Linux Enterprise Server 12 SP5 postgresql13 Not affected
SUSE Linux Enterprise Server 12 SP5 postgresql14 Released
SUSE Linux Enterprise Server 12 SP5 postgresql15 Released
SUSE Linux Enterprise Server 12 SP5 postgresql16 Released
SUSE Linux Enterprise Server 15 SP5 postgresql14 Released
SUSE Linux Enterprise Server 15 SP5 postgresql15 Released
SUSE Linux Enterprise Server 15 SP5 postgresql16 Released
SUSE Linux Enterprise Server 15 SP6 postgresql14 In progress
SUSE Linux Enterprise Server 15 SP6 postgresql15 Released
SUSE Linux Enterprise Server 15 SP6 postgresql16 Released
SUSE Linux Enterprise Server for SAP Applications 12 SP5 postgresql10 Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP5 postgresql12 Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP5 postgresql13 Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP5 postgresql14 Released
SUSE Linux Enterprise Server for SAP Applications 12 SP5 postgresql15 Released
SUSE Linux Enterprise Server for SAP Applications 12 SP5 postgresql16 Released
SUSE Linux Enterprise Server for SAP Applications 15 SP5 postgresql14 Released
SUSE Linux Enterprise Server for SAP Applications 15 SP5 postgresql15 Released
SUSE Linux Enterprise Server for SAP Applications 15 SP5 postgresql16 Released
SUSE Linux Enterprise Server for SAP Applications 15 SP6 postgresql14 In progress
SUSE Linux Enterprise Server for SAP Applications 15 SP6 postgresql15 Released
SUSE Linux Enterprise Server for SAP Applications 15 SP6 postgresql16 Released
SUSE Linux Enterprise Software Development Kit 12 SP5 postgresql10 Not affected
SUSE Linux Enterprise Software Development Kit 12 SP5 postgresql12 Not affected
SUSE Linux Enterprise Software Development Kit 12 SP5 postgresql13 Not affected
SUSE Linux Enterprise Software Development Kit 12 SP5 postgresql14 Released
SUSE Linux Enterprise Software Development Kit 12 SP5 postgresql15 Released
SUSE Linux Enterprise Software Development Kit 12 SP5 postgresql16 Released
SUSE Manager Proxy 4.3 postgresql13 Not affected
SUSE Manager Proxy 4.3 postgresql14 Affected
SUSE Manager Proxy 4.3 postgresql15 Affected
SUSE Manager Proxy 4.3 postgresql16 Affected
SUSE Manager Retail Branch Server 4.3 postgresql13 Not affected
SUSE Manager Retail Branch Server 4.3 postgresql14 Affected
SUSE Manager Retail Branch Server 4.3 postgresql15 Affected
SUSE Manager Retail Branch Server 4.3 postgresql16 Affected
SUSE Manager Server 4.3 postgresql13 Not affected
SUSE Manager Server 4.3 postgresql14 Affected
SUSE Manager Server 4.3 postgresql15 Affected
SUSE Manager Server 4.3 postgresql16 Affected
openSUSE Leap 15.5 postgresql10 Not affected
openSUSE Leap 15.5 postgresql12 Not affected
openSUSE Leap 15.5 postgresql13 Not affected
openSUSE Leap 15.5 postgresql14 Released
openSUSE Leap 15.5 postgresql15 Released
openSUSE Leap 15.5 postgresql16 Released
openSUSE Leap 15.6 postgresql10 Not affected
openSUSE Leap 15.6 postgresql12 Not affected
openSUSE Leap 15.6 postgresql13 Not affected
openSUSE Leap 15.6 postgresql14 Released
openSUSE Leap 15.6 postgresql15 Released
openSUSE Leap 15.6 postgresql16 Affected
Products under Long Term Service Pack support and receiving important and critical security fixes.
SUSE Linux Enterprise Desktop 15 SP4 postgresql14 Affected
SUSE Linux Enterprise Desktop 15 SP4 postgresql15 Affected
SUSE Linux Enterprise Desktop 15 SP4 postgresql16 Affected
SUSE Linux Enterprise High Performance Computing 15 SP2 postgresql10 Not affected
SUSE Linux Enterprise High Performance Computing 15 SP2 postgresql12 Not affected
SUSE Linux Enterprise High Performance Computing 15 SP2 postgresql13 Not affected
SUSE Linux Enterprise High Performance Computing 15 SP2 postgresql14 Affected
SUSE Linux Enterprise High Performance Computing 15 SP2-ESPOS postgresql10 Not affected
SUSE Linux Enterprise High Performance Computing 15 SP2-ESPOS postgresql12 Not affected
SUSE Linux Enterprise High Performance Computing 15 SP2-ESPOS postgresql13 Not affected
SUSE Linux Enterprise High Performance Computing 15 SP2-ESPOS postgresql14 Affected
SUSE Linux Enterprise High Performance Computing 15 SP2-ESPOS postgresql15 Affected
SUSE Linux Enterprise High Performance Computing 15 SP2-LTSS postgresql10 Not affected
SUSE Linux Enterprise High Performance Computing 15 SP2-LTSS postgresql12 Not affected
SUSE Linux Enterprise High Performance Computing 15 SP2-LTSS postgresql13 Not affected
SUSE Linux Enterprise High Performance Computing 15 SP2-LTSS postgresql14 Affected
SUSE Linux Enterprise High Performance Computing 15 SP2-LTSS postgresql16 Affected
SUSE Linux Enterprise High Performance Computing 15 SP3 postgresql10 Not affected
SUSE Linux Enterprise High Performance Computing 15 SP3 postgresql12 Not affected
SUSE Linux Enterprise High Performance Computing 15 SP3 postgresql13 Not affected
SUSE Linux Enterprise High Performance Computing 15 SP3 postgresql14 Affected
SUSE Linux Enterprise High Performance Computing 15 SP3 postgresql15 Affected
SUSE Linux Enterprise High Performance Computing 15 SP3-ESPOS postgresql10 Not affected
SUSE Linux Enterprise High Performance Computing 15 SP3-ESPOS postgresql12 Not affected
SUSE Linux Enterprise High Performance Computing 15 SP3-ESPOS postgresql13 Not affected
SUSE Linux Enterprise High Performance Computing 15 SP3-ESPOS postgresql14 Affected
SUSE Linux Enterprise High Performance Computing 15 SP3-ESPOS postgresql15 Affected
SUSE Linux Enterprise High Performance Computing 15 SP3-ESPOS postgresql16 Affected
SUSE Linux Enterprise High Performance Computing 15 SP3-LTSS postgresql10 Not affected
SUSE Linux Enterprise High Performance Computing 15 SP3-LTSS postgresql12 Not affected
SUSE Linux Enterprise High Performance Computing 15 SP3-LTSS postgresql13 Not affected
SUSE Linux Enterprise High Performance Computing 15 SP3-LTSS postgresql14 Affected
SUSE Linux Enterprise High Performance Computing 15 SP3-LTSS postgresql15 Affected
SUSE Linux Enterprise High Performance Computing 15 SP3-LTSS postgresql16 Affected
SUSE Linux Enterprise High Performance Computing 15 SP4 postgresql13 Not affected
SUSE Linux Enterprise High Performance Computing 15 SP4 postgresql14 Affected
SUSE Linux Enterprise High Performance Computing 15 SP4 postgresql15 Affected
SUSE Linux Enterprise High Performance Computing 15 SP4 postgresql16 Affected
SUSE Linux Enterprise High Performance Computing 15 SP4-ESPOS postgresql13 Not affected
SUSE Linux Enterprise High Performance Computing 15 SP4-ESPOS postgresql14 Affected
SUSE Linux Enterprise High Performance Computing 15 SP4-ESPOS postgresql15 Affected
SUSE Linux Enterprise High Performance Computing 15 SP4-ESPOS postgresql16 Affected
SUSE Linux Enterprise High Performance Computing 15 SP4-LTSS postgresql13 Not affected
SUSE Linux Enterprise High Performance Computing 15 SP4-LTSS postgresql14 Affected
SUSE Linux Enterprise High Performance Computing 15 SP4-LTSS postgresql15 Affected
SUSE Linux Enterprise High Performance Computing 15 SP4-LTSS postgresql16 Affected
SUSE Linux Enterprise Module for Basesystem 15 SP2 postgresql10 Not affected
SUSE Linux Enterprise Module for Basesystem 15 SP2 postgresql12 Not affected
SUSE Linux Enterprise Module for Basesystem 15 SP2 postgresql13 Not affected
SUSE Linux Enterprise Module for Basesystem 15 SP2 postgresql14 Affected
SUSE Linux Enterprise Module for Basesystem 15 SP3 postgresql13 Not affected
SUSE Linux Enterprise Module for Basesystem 15 SP3 postgresql14 Affected
SUSE Linux Enterprise Module for Basesystem 15 SP3 postgresql15 Affected
SUSE Linux Enterprise Module for Basesystem 15 SP4 postgresql14 Affected
SUSE Linux Enterprise Module for Basesystem 15 SP4 postgresql15 Affected
SUSE Linux Enterprise Module for Basesystem 15 SP4 postgresql16 Affected
SUSE Linux Enterprise Module for Legacy 15 SP3 postgresql10 Not affected
SUSE Linux Enterprise Module for Legacy 15 SP3 postgresql12 Not affected
SUSE Linux Enterprise Module for Legacy 15 SP4 postgresql13 Not affected
SUSE Linux Enterprise Module for Server Applications 15 SP2 postgresql10 Not affected
SUSE Linux Enterprise Module for Server Applications 15 SP2 postgresql12 Not affected
SUSE Linux Enterprise Module for Server Applications 15 SP2 postgresql13 Not affected
SUSE Linux Enterprise Module for Server Applications 15 SP2 postgresql14 Affected
SUSE Linux Enterprise Module for Server Applications 15 SP3 postgresql13 Not affected
SUSE Linux Enterprise Module for Server Applications 15 SP3 postgresql14 Affected
SUSE Linux Enterprise Module for Server Applications 15 SP3 postgresql15 Affected
SUSE Linux Enterprise Module for Server Applications 15 SP4 postgresql14 Affected
SUSE Linux Enterprise Module for Server Applications 15 SP4 postgresql15 Affected
SUSE Linux Enterprise Module for Server Applications 15 SP4 postgresql16 Affected
SUSE Linux Enterprise Server 15 SP2 postgresql10 Not affected
SUSE Linux Enterprise Server 15 SP2 postgresql12 Not affected
SUSE Linux Enterprise Server 15 SP2 postgresql13 Not affected
SUSE Linux Enterprise Server 15 SP2 postgresql14 Affected
SUSE Linux Enterprise Server 15 SP2-LTSS postgresql10 Not affected
SUSE Linux Enterprise Server 15 SP2-LTSS postgresql12 Not affected
SUSE Linux Enterprise Server 15 SP2-LTSS postgresql13 Not affected
SUSE Linux Enterprise Server 15 SP2-LTSS postgresql14 Affected
SUSE Linux Enterprise Server 15 SP2-LTSS postgresql16 Affected
SUSE Linux Enterprise Server 15 SP3 postgresql10 Not affected
SUSE Linux Enterprise Server 15 SP3 postgresql12 Not affected
SUSE Linux Enterprise Server 15 SP3 postgresql13 Not affected
SUSE Linux Enterprise Server 15 SP3 postgresql14 Affected
SUSE Linux Enterprise Server 15 SP3 postgresql15 Affected
SUSE Linux Enterprise Server 15 SP3-LTSS postgresql10 Not affected
SUSE Linux Enterprise Server 15 SP3-LTSS postgresql12 Not affected
SUSE Linux Enterprise Server 15 SP3-LTSS postgresql13 Not affected
SUSE Linux Enterprise Server 15 SP3-LTSS postgresql14 Affected
SUSE Linux Enterprise Server 15 SP3-LTSS postgresql15 Affected
SUSE Linux Enterprise Server 15 SP3-LTSS postgresql16 Affected
SUSE Linux Enterprise Server 15 SP4 postgresql13 Not affected
SUSE Linux Enterprise Server 15 SP4 postgresql14 Affected
SUSE Linux Enterprise Server 15 SP4 postgresql15 Affected
SUSE Linux Enterprise Server 15 SP4 postgresql16 Affected
SUSE Linux Enterprise Server 15 SP4-LTSS postgresql13 Not affected
SUSE Linux Enterprise Server 15 SP4-LTSS postgresql14 Affected
SUSE Linux Enterprise Server 15 SP4-LTSS postgresql15 Affected
SUSE Linux Enterprise Server 15 SP4-LTSS postgresql16 Affected
SUSE Linux Enterprise Server for SAP Applications 15 SP2 postgresql10 Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP2 postgresql12 Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP2 postgresql13 Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP2 postgresql14 Affected
SUSE Linux Enterprise Server for SAP Applications 15 SP2 postgresql16 Affected
SUSE Linux Enterprise Server for SAP Applications 15 SP3 postgresql10 Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP3 postgresql12 Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP3 postgresql13 Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP3 postgresql14 Affected
SUSE Linux Enterprise Server for SAP Applications 15 SP3 postgresql15 Affected
SUSE Linux Enterprise Server for SAP Applications 15 SP3 postgresql16 Affected
SUSE Linux Enterprise Server for SAP Applications 15 SP4 postgresql13 Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP4 postgresql14 Affected
SUSE Linux Enterprise Server for SAP Applications 15 SP4 postgresql15 Affected
SUSE Linux Enterprise Server for SAP Applications 15 SP4 postgresql16 Affected
Products past their end of life and not receiving proactive updates anymore.
HPE Helion OpenStack 8 postgresql10 Not affected
HPE Helion OpenStack 8 postgresql14 Affected
HPE Helion OpenStack 8 postgresql96 Not affected
SUSE CaaS Platform 4.0 postgresql10 Not affected
SUSE CaaS Platform 4.0 postgresql12 Not affected
SUSE Enterprise Storage 6 postgresql10 Not affected
SUSE Enterprise Storage 6 postgresql12 Not affected
SUSE Enterprise Storage 7 postgresql10 Not affected
SUSE Enterprise Storage 7 postgresql12 Not affected
SUSE Enterprise Storage 7 postgresql13 Not affected
SUSE Enterprise Storage 7 postgresql14 Affected
SUSE Linux Enterprise Desktop 11 SP3 postgresql94 Not affected
SUSE Linux Enterprise Desktop 11 SP4 postgresql94 Not affected
SUSE Linux Enterprise Desktop 15 postgresql10 Not affected
SUSE Linux Enterprise Desktop 15 SP1 postgresql10 Not affected
SUSE Linux Enterprise Desktop 15 SP1 postgresql12 Not affected
SUSE Linux Enterprise Desktop 15 SP2 postgresql10 Not affected
SUSE Linux Enterprise Desktop 15 SP2 postgresql12 Not affected
SUSE Linux Enterprise Desktop 15 SP2 postgresql13 Not affected
SUSE Linux Enterprise Desktop 15 SP2 postgresql14 Affected
SUSE Linux Enterprise Desktop 15 SP3 postgresql13 Not affected
SUSE Linux Enterprise Desktop 15 SP3 postgresql14 Affected
SUSE Linux Enterprise Desktop 15 SP3 postgresql15 Affected
SUSE Linux Enterprise High Performance Computing 15 postgresql10 Not affected
SUSE Linux Enterprise High Performance Computing 15 SP1 postgresql10 Not affected
SUSE Linux Enterprise High Performance Computing 15 SP1 postgresql12 Not affected
SUSE Linux Enterprise High Performance Computing 15 SP1-ESPOS postgresql10 Not affected
SUSE Linux Enterprise High Performance Computing 15 SP1-ESPOS postgresql12 Not affected
SUSE Linux Enterprise High Performance Computing 15 SP1-LTSS postgresql10 Not affected
SUSE Linux Enterprise High Performance Computing 15 SP1-LTSS postgresql12 Not affected
SUSE Linux Enterprise High Performance Computing 15-ESPOS postgresql10 Not affected
SUSE Linux Enterprise High Performance Computing 15-LTSS postgresql10 Not affected
SUSE Linux Enterprise Module for Basesystem 15 postgresql10 Not affected
SUSE Linux Enterprise Module for Basesystem 15 SP1 postgresql10 Not affected
SUSE Linux Enterprise Module for Basesystem 15 SP1 postgresql12 Not affected
SUSE Linux Enterprise Module for Package Hub 15 postgresql10 Not affected
SUSE Linux Enterprise Module for Package Hub 15 SP2 postgresql12 Not affected
SUSE Linux Enterprise Module for Package Hub 15 SP2 postgresql13 Not affected
SUSE Linux Enterprise Module for Package Hub 15 SP2 postgresql14 Affected
SUSE Linux Enterprise Module for Package Hub 15 SP3 postgresql12 Not affected
SUSE Linux Enterprise Module for Package Hub 15 SP3 postgresql13 Not affected
SUSE Linux Enterprise Module for Package Hub 15 SP3 postgresql14 Affected
SUSE Linux Enterprise Module for Package Hub 15 SP3 postgresql15 Affected
SUSE Linux Enterprise Module for Package Hub 15 SP4 postgresql14 Affected
SUSE Linux Enterprise Module for Package Hub 15 SP4 postgresql15 Affected
SUSE Linux Enterprise Module for Package Hub 15 SP4 postgresql16 Affected
SUSE Linux Enterprise Module for Server Applications 15 postgresql10 Not affected
SUSE Linux Enterprise Module for Server Applications 15 SP1 postgresql10 Not affected
SUSE Linux Enterprise Module for Server Applications 15 SP1 postgresql12 Not affected
SUSE Linux Enterprise Point of Sale 11 SP3 postgresql94 Not affected
SUSE Linux Enterprise Point of Sale 12 SP2-CLIENT postgresql10 Not affected
SUSE Linux Enterprise Point of Sale 12 SP2-CLIENT postgresql13 Not affected
SUSE Linux Enterprise Point of Sale 12 SP2-CLIENT postgresql96 Not affected
SUSE Linux Enterprise Real Time 15 SP2 postgresql10 Not affected
SUSE Linux Enterprise Real Time 15 SP2 postgresql12 Not affected
SUSE Linux Enterprise Real Time 15 SP2 postgresql13 Not affected
SUSE Linux Enterprise Real Time 15 SP2 postgresql14 Affected
SUSE Linux Enterprise Real Time 15 SP3 postgresql13 Not affected
SUSE Linux Enterprise Real Time 15 SP3 postgresql14 Affected
SUSE Linux Enterprise Real Time 15 SP3 postgresql15 Affected
SUSE Linux Enterprise Real Time 15 SP3 postgresql16 Affected
SUSE Linux Enterprise Real Time 15 SP4 postgresql14 Affected
SUSE Linux Enterprise Real Time 15 SP4 postgresql15 Affected
SUSE Linux Enterprise Real Time 15 SP4 postgresql16 Affected
SUSE Linux Enterprise Server 11 SP3 postgresql94 Not affected
SUSE Linux Enterprise Server 11 SP3-LTSS postgresql94 Not affected
SUSE Linux Enterprise Server 11 SP4 postgresql94 Not affected
SUSE Linux Enterprise Server 11 SP4 LTSS postgresql94 Not affected
SUSE Linux Enterprise Server 11 SP4-LTSS postgresql94 Not affected
SUSE Linux Enterprise Server 12 SP2-BCL postgresql10 Not affected
SUSE Linux Enterprise Server 12 SP2-BCL postgresql15 Affected
SUSE Linux Enterprise Server 12 SP2-BCL postgresql96 Not affected
SUSE Linux Enterprise Server 12 SP2-ESPOS postgresql10 Not affected
SUSE Linux Enterprise Server 12 SP2-ESPOS postgresql13 Not affected
SUSE Linux Enterprise Server 12 SP2-ESPOS postgresql96 Not affected
SUSE Linux Enterprise Server 12 SP2-LTSS postgresql10 Not affected
SUSE Linux Enterprise Server 12 SP2-LTSS postgresql13 Not affected
SUSE Linux Enterprise Server 12 SP2-LTSS postgresql96 Not affected
SUSE Linux Enterprise Server 12 SP3-BCL postgresql10 Not affected
SUSE Linux Enterprise Server 12 SP3-BCL postgresql15 Affected
SUSE Linux Enterprise Server 12 SP3-BCL postgresql96 Not affected
SUSE Linux Enterprise Server 12 SP3-ESPOS postgresql10 Not affected
SUSE Linux Enterprise Server 12 SP3-ESPOS postgresql14 Affected
SUSE Linux Enterprise Server 12 SP3-ESPOS postgresql96 Not affected
SUSE Linux Enterprise Server 12 SP3-LTSS postgresql10 Not affected
SUSE Linux Enterprise Server 12 SP3-LTSS postgresql14 Affected
SUSE Linux Enterprise Server 12 SP3-LTSS postgresql96 Not affected
SUSE Linux Enterprise Server 12 SP4-ESPOS postgresql10 Not affected
SUSE Linux Enterprise Server 12 SP4-ESPOS postgresql15 Affected
SUSE Linux Enterprise Server 12 SP4-LTSS postgresql10 Not affected
SUSE Linux Enterprise Server 12 SP4-LTSS postgresql15 Affected
SUSE Linux Enterprise Server 15 postgresql10 Not affected
SUSE Linux Enterprise Server 15 SP1 postgresql10 Not affected
SUSE Linux Enterprise Server 15 SP1 postgresql12 Not affected
SUSE Linux Enterprise Server 15 SP1-BCL postgresql10 Not affected
SUSE Linux Enterprise Server 15 SP1-BCL postgresql12 Not affected
SUSE Linux Enterprise Server 15 SP1-LTSS postgresql10 Not affected
SUSE Linux Enterprise Server 15 SP1-LTSS postgresql12 Not affected
SUSE Linux Enterprise Server 15 SP2-BCL postgresql10 Not affected
SUSE Linux Enterprise Server 15 SP2-BCL postgresql12 Not affected
SUSE Linux Enterprise Server 15 SP2-BCL postgresql13 Not affected
SUSE Linux Enterprise Server 15 SP2-BCL postgresql14 Affected
SUSE Linux Enterprise Server 15 SP2-BCL postgresql15 Affected
SUSE Linux Enterprise Server 15 SP3-BCL postgresql13 Not affected
SUSE Linux Enterprise Server 15 SP3-BCL postgresql14 Affected
SUSE Linux Enterprise Server 15 SP3-BCL postgresql15 Affected
SUSE Linux Enterprise Server 15-LTSS postgresql10 Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP2 postgresql10 Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP2 postgresql13 Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP2 postgresql96 Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP3 postgresql10 Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP3 postgresql14 Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP3 postgresql96 Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP4 postgresql10 Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP4 postgresql15 Affected
SUSE Linux Enterprise Server for SAP Applications 15 postgresql10 Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP1 postgresql10 Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP1 postgresql12 Not affected
SUSE Manager 2.1 postgresql94 Not affected
SUSE Manager Proxy 4.0 postgresql10 Not affected
SUSE Manager Proxy 4.0 postgresql12 Not affected
SUSE Manager Proxy 4.1 postgresql10 Not affected
SUSE Manager Proxy 4.1 postgresql12 Not affected
SUSE Manager Proxy 4.1 postgresql13 Not affected
SUSE Manager Proxy 4.1 postgresql14 Affected
SUSE Manager Proxy 4.2 postgresql10 Not affected
SUSE Manager Proxy 4.2 postgresql12 Not affected
SUSE Manager Proxy 4.2 postgresql13 Not affected
SUSE Manager Proxy 4.2 postgresql14 Affected
SUSE Manager Proxy 4.2 postgresql15 Affected
SUSE Manager Proxy 4.2 postgresql16 Affected
SUSE Manager Retail Branch Server 4.0 postgresql10 Not affected
SUSE Manager Retail Branch Server 4.0 postgresql12 Not affected
SUSE Manager Retail Branch Server 4.1 postgresql10 Not affected
SUSE Manager Retail Branch Server 4.1 postgresql12 Not affected
SUSE Manager Retail Branch Server 4.1 postgresql13 Not affected
SUSE Manager Retail Branch Server 4.1 postgresql14 Affected
SUSE Manager Retail Branch Server 4.2 postgresql10 Not affected
SUSE Manager Retail Branch Server 4.2 postgresql12 Not affected
SUSE Manager Retail Branch Server 4.2 postgresql13 Not affected
SUSE Manager Retail Branch Server 4.2 postgresql14 Affected
SUSE Manager Retail Branch Server 4.2 postgresql15 Affected
SUSE Manager Retail Branch Server 4.2 postgresql16 Affected
SUSE Manager Server 4.0 postgresql10 Not affected
SUSE Manager Server 4.0 postgresql12 Not affected
SUSE Manager Server 4.1 postgresql10 Not affected
SUSE Manager Server 4.1 postgresql12 Not affected
SUSE Manager Server 4.1 postgresql13 Not affected
SUSE Manager Server 4.1 postgresql14 Affected
SUSE Manager Server 4.2 postgresql10 Not affected
SUSE Manager Server 4.2 postgresql12 Not affected
SUSE Manager Server 4.2 postgresql13 Not affected
SUSE Manager Server 4.2 postgresql14 Affected
SUSE Manager Server 4.2 postgresql15 Affected
SUSE Manager Server 4.2 postgresql16 Affected
SUSE OpenStack Cloud 7 postgresql10 Not affected
SUSE OpenStack Cloud 7 postgresql13 Not affected
SUSE OpenStack Cloud 7 postgresql96 Not affected
SUSE OpenStack Cloud 8 postgresql10 Not affected
SUSE OpenStack Cloud 8 postgresql14 Affected
SUSE OpenStack Cloud 8 postgresql96 Not affected
SUSE OpenStack Cloud 9 postgresql10 Not affected
SUSE OpenStack Cloud 9 postgresql15 Affected
SUSE OpenStack Cloud Crowbar 8 postgresql10 Not affected
SUSE OpenStack Cloud Crowbar 8 postgresql14 Affected
SUSE OpenStack Cloud Crowbar 8 postgresql96 Not affected
SUSE OpenStack Cloud Crowbar 9 postgresql10 Not affected
SUSE OpenStack Cloud Crowbar 9 postgresql15 Affected
openSUSE Leap 15.3 postgresql10 Not affected
openSUSE Leap 15.3 postgresql12 Not affected
openSUSE Leap 15.3 postgresql13 Not affected
openSUSE Leap 15.3 postgresql14 Affected
openSUSE Leap 15.3 postgresql15 Affected
openSUSE Leap 15.4 postgresql10 Not affected
openSUSE Leap 15.4 postgresql12 Not affected
openSUSE Leap 15.4 postgresql13 Not affected
openSUSE Leap 15.4 postgresql14 Affected
openSUSE Leap 15.4 postgresql15 Affected
openSUSE Leap 15.4 postgresql16 Affected
Container Status
suse/postgres:10 postgresql10Not affected
suse/postgres:12 postgresql12Not affected
suse/postgres:13 postgresql13Not affected
suse/manager/5.0/x86_64/server-migration-14-16 postgresql14Released
suse/postgres:14
trento/trento-db
postgresql14In progress
suse/postgres:15 postgresql15Released
suse/postgres postgresql15In progress
suse/manager/5.0/x86_64/server
suse/manager/5.0/x86_64/server-migration-14-16
suse/postgres
postgresql16Affected


SUSE Timeline for this CVE

CVE page created: Wed May 8 10:05:12 2024
CVE page last modified: Fri Jul 19 11:50:40 2024