Upstream information

CVE-2024-4216 at MITRE

Description

pgAdmin <= 8.5 is affected by XSS vulnerability in /settings/store API response json payload. This vulnerability allows attackers to execute malicious script at the client end.

SUSE information

Overall state of this security issue: Pending

This issue is currently rated as having moderate severity.

CVSS v3 Scores
  SUSE
Base Score 5.8
Vector CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:L/I:L/A:L
Attack Vector Network
Attack Complexity High
Privileges Required None
User Interaction Required
Scope Changed
Confidentiality Impact Low
Integrity Impact Low
Availability Impact Low
CVSSv3 Version 3.1
SUSE Bugzilla entry: 1223868 [IN_PROGRESS]

No SUSE Security Announcements cross referenced.

List of released packages

Product(s) Fixed package version(s) References
openSUSE Tumbleweed
  • pgadmin4 >= 8.8-1.1
  • pgadmin4-cloud >= 8.8-1.1
  • pgadmin4-desktop >= 8.8-1.1
  • pgadmin4-doc >= 8.8-1.1
  • pgadmin4-web-uwsgi >= 8.8-1.1
  • system-user-pgadmin >= 8.8-1.1
Patchnames:
openSUSE-Tumbleweed-2024-14052


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification. The updates are grouped by state of their lifecycle. SUSE product lifecycles are documented on the lifecycle page.

Product(s) Source package State
Products under general support and receiving all security fixes.
SUSE Enterprise Storage 7.1 pgadmin4 Affected
SUSE Linux Enterprise Desktop 15 SP6 pgadmin4 Affected
SUSE Linux Enterprise High Performance Computing 15 SP5 pgadmin4 Affected
SUSE Linux Enterprise High Performance Computing 15 SP6 pgadmin4 Affected
SUSE Linux Enterprise Module for Python 3 15 SP6 pgadmin4 Affected
SUSE Linux Enterprise Module for Server Applications 15 SP5 pgadmin4 Affected
SUSE Linux Enterprise Server 15 SP5 pgadmin4 Affected
SUSE Linux Enterprise Server 15 SP6 pgadmin4 Affected
SUSE Linux Enterprise Server for SAP Applications 15 SP5 pgadmin4 Affected
SUSE Linux Enterprise Server for SAP Applications 15 SP6 pgadmin4 Affected
SUSE Manager Proxy 4.3 pgadmin4 Affected
SUSE Manager Retail Branch Server 4.3 pgadmin4 Affected
SUSE Manager Server 4.3 pgadmin4 Affected
openSUSE Leap 15.5 pgadmin4 Affected
openSUSE Leap 15.6 pgadmin4 Affected
Products under Long Term Service Pack support and receiving important and critical security fixes.
SUSE Linux Enterprise High Performance Computing 15 SP2 pgadmin4 Affected
SUSE Linux Enterprise High Performance Computing 15 SP2-ESPOS pgadmin4 Affected
SUSE Linux Enterprise High Performance Computing 15 SP2-LTSS pgadmin4 Affected
SUSE Linux Enterprise High Performance Computing 15 SP3 pgadmin4 Affected
SUSE Linux Enterprise High Performance Computing 15 SP3-ESPOS pgadmin4 Affected
SUSE Linux Enterprise High Performance Computing 15 SP3-LTSS pgadmin4 Affected
SUSE Linux Enterprise High Performance Computing 15 SP4 pgadmin4 Affected
SUSE Linux Enterprise High Performance Computing 15 SP4-ESPOS pgadmin4 Affected
SUSE Linux Enterprise High Performance Computing 15 SP4-LTSS pgadmin4 Affected
SUSE Linux Enterprise Module for Server Applications 15 SP2 pgadmin4 Affected
SUSE Linux Enterprise Module for Server Applications 15 SP3 pgadmin4 Affected
SUSE Linux Enterprise Module for Server Applications 15 SP4 pgadmin4 Affected
SUSE Linux Enterprise Server 15 SP2 pgadmin4 Affected
SUSE Linux Enterprise Server 15 SP2-LTSS pgadmin4 Affected
SUSE Linux Enterprise Server 15 SP3 pgadmin4 Affected
SUSE Linux Enterprise Server 15 SP3-LTSS pgadmin4 Affected
SUSE Linux Enterprise Server 15 SP4 pgadmin4 Affected
SUSE Linux Enterprise Server 15 SP4-LTSS pgadmin4 Affected
SUSE Linux Enterprise Server for SAP Applications 15 SP2 pgadmin4 Affected
SUSE Linux Enterprise Server for SAP Applications 15 SP3 pgadmin4 Affected
SUSE Linux Enterprise Server for SAP Applications 15 SP4 pgadmin4 Affected
Products past their end of life and not receiving proactive updates anymore.
SUSE CaaS Platform 4.0 pgadmin4 Affected
SUSE Enterprise Storage 6 pgadmin4 Affected
SUSE Enterprise Storage 7 pgadmin4 Affected
SUSE Linux Enterprise High Performance Computing 15 SP1 pgadmin4 Affected
SUSE Linux Enterprise High Performance Computing 15 SP1-ESPOS pgadmin4 Affected
SUSE Linux Enterprise High Performance Computing 15 SP1-LTSS pgadmin4 Affected
SUSE Linux Enterprise Module for Server Applications 15 SP1 pgadmin4 Affected
SUSE Linux Enterprise Real Time 15 SP2 pgadmin4 Affected
SUSE Linux Enterprise Real Time 15 SP3 pgadmin4 Affected
SUSE Linux Enterprise Real Time 15 SP4 pgadmin4 Affected
SUSE Linux Enterprise Server 15 SP1 pgadmin4 Affected
SUSE Linux Enterprise Server 15 SP1-BCL pgadmin4 Affected
SUSE Linux Enterprise Server 15 SP1-LTSS pgadmin4 Affected
SUSE Linux Enterprise Server 15 SP2-BCL pgadmin4 Affected
SUSE Linux Enterprise Server 15 SP3-BCL pgadmin4 Affected
SUSE Linux Enterprise Server for SAP Applications 15 SP1 pgadmin4 Affected
SUSE Manager Proxy 4.0 pgadmin4 Affected
SUSE Manager Proxy 4.1 pgadmin4 Affected
SUSE Manager Proxy 4.2 pgadmin4 Affected
SUSE Manager Retail Branch Server 4.0 pgadmin4 Affected
SUSE Manager Retail Branch Server 4.1 pgadmin4 Affected
SUSE Manager Retail Branch Server 4.2 pgadmin4 Affected
SUSE Manager Server 4.0 pgadmin4 Affected
SUSE Manager Server 4.1 pgadmin4 Affected
SUSE Manager Server 4.2 pgadmin4 Affected


SUSE Timeline for this CVE

CVE page created: Thu May 2 22:00:46 2024
CVE page last modified: Wed Jun 19 16:41:47 2024