Upstream information

CVE-2024-32458 at MITRE

Description

FreeRDP is a free implementation of the Remote Desktop Protocol. FreeRDP based clients that use a version of FreeRDP prior to 3.5.0 or 2.11.6 are vulnerable to out-of-bounds read. Versions 3.5.0 and 2.11.6 patch the issue. As a workaround, use `/gfx` or `/rfx` modes (on by default, require server side support).

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v3 Scores
  SUSE
Base Score 5.3
Vector CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
Attack Vector Network
Attack Complexity Low
Privileges Required None
User Interaction None
Scope Unchanged
Confidentiality Impact Low
Integrity Impact None
Availability Impact None
CVSSv3 Version 3.1
SUSE Bugzilla entry: 1223296 [IN_PROGRESS]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 15 SP5
SUSE Linux Enterprise Server 15 SP5
SUSE Linux Enterprise Server for SAP Applications 15 SP5
SUSE Linux Enterprise Workstation Extension 15 SP5
  • freerdp >= 2.4.0-150400.3.29.1
  • freerdp-devel >= 2.4.0-150400.3.29.1
  • freerdp-proxy >= 2.4.0-150400.3.29.1
  • libfreerdp2 >= 2.4.0-150400.3.29.1
  • libwinpr2 >= 2.4.0-150400.3.29.1
  • winpr2-devel >= 2.4.0-150400.3.29.1
Patchnames:
SUSE-SLE-Product-WE-15-SP5-2024-1610
SUSE Linux Enterprise Module for Package Hub 15 SP5
  • freerdp >= 2.4.0-150400.3.29.1
  • freerdp-devel >= 2.4.0-150400.3.29.1
  • freerdp-proxy >= 2.4.0-150400.3.29.1
  • freerdp-server >= 2.4.0-150400.3.29.1
  • freerdp-wayland >= 2.4.0-150400.3.29.1
  • libfreerdp2 >= 2.4.0-150400.3.29.1
  • libuwac0-0 >= 2.4.0-150400.3.29.1
  • libwinpr2 >= 2.4.0-150400.3.29.1
  • uwac0-0-devel >= 2.4.0-150400.3.29.1
  • winpr2-devel >= 2.4.0-150400.3.29.1
Patchnames:
SUSE-SLE-Module-Packagehub-Subpackages-15-SP5-2024-1610
SUSE Linux Enterprise Server 12 SP5
SUSE Linux Enterprise Server for SAP Applications 12 SP5
  • freerdp >= 2.1.2-12.44.1
  • freerdp-devel >= 2.1.2-12.44.1
  • freerdp-proxy >= 2.1.2-12.44.1
  • freerdp-server >= 2.1.2-12.44.1
  • libfreerdp2 >= 2.1.2-12.44.1
  • libwinpr2 >= 2.1.2-12.44.1
  • winpr2-devel >= 2.1.2-12.44.1
Patchnames:
SUSE-SLE-SDK-12-SP5-2024-1609
SUSE-SLE-WE-12-SP5-2024-1609
SUSE Linux Enterprise Software Development Kit 12 SP5
  • freerdp-devel >= 2.1.2-12.44.1
  • libfreerdp2 >= 2.1.2-12.44.1
  • libwinpr2 >= 2.1.2-12.44.1
  • winpr2-devel >= 2.1.2-12.44.1
Patchnames:
SUSE-SLE-SDK-12-SP5-2024-1609
SUSE Linux Enterprise Workstation Extension 12 SP5
  • freerdp >= 2.1.2-12.44.1
  • freerdp-proxy >= 2.1.2-12.44.1
  • freerdp-server >= 2.1.2-12.44.1
  • libfreerdp2 >= 2.1.2-12.44.1
  • libwinpr2 >= 2.1.2-12.44.1
Patchnames:
SUSE-SLE-WE-12-SP5-2024-1609
openSUSE Leap 15.5
  • freerdp >= 2.4.0-150400.3.29.1
  • freerdp-devel >= 2.4.0-150400.3.29.1
  • freerdp-proxy >= 2.4.0-150400.3.29.1
  • freerdp-server >= 2.4.0-150400.3.29.1
  • freerdp-wayland >= 2.4.0-150400.3.29.1
  • libfreerdp2 >= 2.4.0-150400.3.29.1
  • libuwac0-0 >= 2.4.0-150400.3.29.1
  • libwinpr2 >= 2.4.0-150400.3.29.1
  • uwac0-0-devel >= 2.4.0-150400.3.29.1
  • winpr2-devel >= 2.4.0-150400.3.29.1
Patchnames:
openSUSE-SLE-15.5-2024-1610
openSUSE Tumbleweed
  • freerdp >= 3.5.1-1.1
  • freerdp-devel >= 3.5.1-1.1
  • freerdp-proxy >= 3.5.1-1.1
  • freerdp-proxy-plugins >= 3.5.1-1.1
  • freerdp-sdl >= 3.5.1-1.1
  • freerdp-server >= 3.5.1-1.1
  • freerdp-wayland >= 3.5.1-1.1
  • freerdp2 >= 2.11.7-1.1
  • freerdp2-devel >= 2.11.7-1.1
  • freerdp2-proxy >= 2.11.7-1.1
  • freerdp2-server >= 2.11.7-1.1
  • libfreerdp-server-proxy3-3 >= 3.5.1-1.1
  • libfreerdp2-2 >= 2.11.7-1.1
  • libfreerdp3-3 >= 3.5.1-1.1
  • librdtk0-0 >= 3.5.1-1.1
  • libuwac0-0 >= 3.5.1-1.1
  • libwinpr2-2 >= 2.11.7-1.1
  • libwinpr3-3 >= 3.5.1-1.1
  • rdtk0-devel >= 3.5.1-1.1
  • uwac0-devel >= 3.5.1-1.1
  • winpr-devel >= 3.5.1-1.1
  • winpr2-devel >= 2.11.7-1.1
Patchnames:
openSUSE Tumbleweed GA freerdp-3.5.1-1.1
openSUSE Tumbleweed GA freerdp2-2.11.7-1.1


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification. The updates are grouped by state of their lifecycle. SUSE product lifecycles are documented on the lifecycle page.

Product(s) Source package State
Products under general support and receiving all security fixes.
SUSE Linux Enterprise Desktop 15 SP5 freerdp Released
SUSE Linux Enterprise Desktop 15 SP6 freerdp Already fixed
SUSE Linux Enterprise Module for Package Hub 15 SP5 freerdp Released
SUSE Linux Enterprise Module for Package Hub 15 SP6 freerdp Already fixed
SUSE Linux Enterprise Server 12 SP5 freerdp Released
SUSE Linux Enterprise Server 15 SP5 freerdp Released
SUSE Linux Enterprise Server 15 SP6 freerdp Already fixed
SUSE Linux Enterprise Server for SAP Applications 12 SP5 freerdp Released
SUSE Linux Enterprise Server for SAP Applications 15 SP5 freerdp Released
SUSE Linux Enterprise Server for SAP Applications 15 SP6 freerdp Already fixed
SUSE Linux Enterprise Software Development Kit 12 SP5 freerdp Released
SUSE Linux Enterprise Workstation Extension 12 SP5 freerdp Released
SUSE Linux Enterprise Workstation Extension 15 SP5 freerdp Released
SUSE Linux Enterprise Workstation Extension 15 SP6 freerdp Already fixed
openSUSE Leap 15.5 freerdp Released
openSUSE Leap 15.6 freerdp Already fixed
Products under Long Term Service Pack support and receiving important and critical security fixes.
SUSE Linux Enterprise Desktop 15 SP4 freerdp Affected
SUSE Linux Enterprise Desktop 15 SP4 LTSS freerdp Released
SUSE Linux Enterprise Server 15 SP4 freerdp Affected
SUSE Linux Enterprise Server for SAP Applications 15 SP4 freerdp Affected
Products past their end of life and not receiving proactive updates anymore.
SUSE Linux Enterprise Desktop 12 SP2 freerdp Affected
SUSE Linux Enterprise Desktop 12 SP3 freerdp Affected
SUSE Linux Enterprise Desktop 12 SP4 freerdp Affected
SUSE Linux Enterprise Module for Package Hub 15 SP4 freerdp Affected
SUSE Linux Enterprise Server 12 SP2 freerdp Affected
SUSE Linux Enterprise Server 12 SP3 freerdp Affected
SUSE Linux Enterprise Server 12 SP4 freerdp Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP2 freerdp Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP3 freerdp Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP4 freerdp Affected
SUSE Linux Enterprise Software Development Kit 12 SP2 freerdp Affected
SUSE Linux Enterprise Software Development Kit 12 SP3 freerdp Affected
SUSE Linux Enterprise Software Development Kit 12 SP4 freerdp Affected
SUSE Linux Enterprise Workstation Extension 12 SP2 freerdp Affected
SUSE Linux Enterprise Workstation Extension 12 SP3 freerdp Affected
SUSE Linux Enterprise Workstation Extension 12 SP4 freerdp Affected
SUSE Linux Enterprise Workstation Extension 15 SP4 freerdp Affected
openSUSE Leap 15.4 freerdp Released


SUSE Timeline for this CVE

CVE page created: Tue Apr 23 00:00:08 2024
CVE page last modified: Fri Jun 7 10:19:51 2024