Upstream information

CVE-2024-32021 at MITRE

Description

Git is a revision control system. Prior to versions 2.45.1, 2.44.1, 2.43.4, 2.42.2, 2.41.1, 2.40.2, and 2.39.4, when cloning a local source repository that contains symlinks via the filesystem, Git may create hardlinks to arbitrary user-readable files on the same filesystem as the target repository in the `objects/` directory. Cloning a local repository over the filesystem may creating hardlinks to arbitrary user-owned files on the same filesystem in the target Git repository's `objects/` directory. When cloning a repository over the filesystem (without explicitly specifying the `file://` protocol or `--no-local`), the optimizations for local cloning will be used, which include attempting to hard link the object files instead of copying them. While the code includes checks against symbolic links in the source repository, which were added during the fix for CVE-2022-39253, these checks can still be raced because the hard link operation ultimately follows symlinks. If the object on the filesystem appears as a file during the check, and then a symlink during the operation, this will allow the adversary to bypass the check and create hardlinks in the destination objects directory to arbitrary, user-readable files. The problem has been patched in versions 2.45.1, 2.44.1, 2.43.4, 2.42.2, 2.41.1, 2.40.2, and 2.39.4.

SUSE information

Overall state of this security issue: Pending

This issue is currently rated as having low severity.

CVSS v3 Scores
  SUSE
Base Score 3.9
Vector CVSS:3.1/AV:L/AC:H/PR:L/UI:R/S:C/C:N/I:L/A:L
Attack Vector Local
Attack Complexity High
Privileges Required Low
User Interaction Required
Scope Changed
Confidentiality Impact None
Integrity Impact Low
Availability Impact Low
CVSSv3 Version 3.1
SUSE Bugzilla entry: 1224172 [NEW]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
Container bci/golang:oldstable-2.34.5
Container bci/golang:oldstable-openssl-34.5
Container bci/golang:stable-openssl-34.5
Container bci/nodejs:20-31.5
Container bci/openjdk:21-16.1
Container bci/python:3.11-42.5
Container bci/python:3.6-42.5
Container bci/ruby:latest
Container suse/git:2.43-17.8
  • git-core >= 2.43.0-150600.3.3.1
Container bci/nodejs:18-21.9
Container bci/openjdk:11-24.1
Container bci/openjdk:17-26.1
  • git-core >= 2.35.3-150300.10.39.1
Container bci/spack:0.21.2-2.1
  • git >= 2.43.0-150600.3.3.1
  • git-core >= 2.43.0-150600.3.3.1
  • perl-Git >= 2.43.0-150600.3.3.1
SUSE Enterprise Storage 7.1
  • git >= 2.35.3-150300.10.39.1
  • git-arch >= 2.35.3-150300.10.39.1
  • git-core >= 2.35.3-150300.10.39.1
  • git-cvs >= 2.35.3-150300.10.39.1
  • git-daemon >= 2.35.3-150300.10.39.1
  • git-doc >= 2.35.3-150300.10.39.1
  • git-email >= 2.35.3-150300.10.39.1
  • git-gui >= 2.35.3-150300.10.39.1
  • git-svn >= 2.35.3-150300.10.39.1
  • git-web >= 2.35.3-150300.10.39.1
  • gitk >= 2.35.3-150300.10.39.1
  • perl-Git >= 2.35.3-150300.10.39.1
Patchnames:
SUSE-Storage-7.1-2024-1807
SUSE Liberty Linux 8
  • git >= 2.43.5-1.el8_10
  • git-all >= 2.43.5-1.el8_10
  • git-core >= 2.43.5-1.el8_10
  • git-core-doc >= 2.43.5-1.el8_10
  • git-credential-libsecret >= 2.43.5-1.el8_10
  • git-daemon >= 2.43.5-1.el8_10
  • git-email >= 2.43.5-1.el8_10
  • git-gui >= 2.43.5-1.el8_10
  • git-instaweb >= 2.43.5-1.el8_10
  • git-subtree >= 2.43.5-1.el8_10
  • git-svn >= 2.43.5-1.el8_10
  • gitk >= 2.43.5-1.el8_10
  • gitweb >= 2.43.5-1.el8_10
  • perl-Git >= 2.43.5-1.el8_10
  • perl-Git-SVN >= 2.43.5-1.el8_10
Patchnames:
RHSA-2024:4084
SUSE Liberty Linux 9
  • git >= 2.43.5-1.el9_4
  • git-all >= 2.43.5-1.el9_4
  • git-core >= 2.43.5-1.el9_4
  • git-core-doc >= 2.43.5-1.el9_4
  • git-credential-libsecret >= 2.43.5-1.el9_4
  • git-daemon >= 2.43.5-1.el9_4
  • git-email >= 2.43.5-1.el9_4
  • git-gui >= 2.43.5-1.el9_4
  • git-instaweb >= 2.43.5-1.el9_4
  • git-subtree >= 2.43.5-1.el9_4
  • git-svn >= 2.43.5-1.el9_4
  • gitk >= 2.43.5-1.el9_4
  • gitweb >= 2.43.5-1.el9_4
  • perl-Git >= 2.43.5-1.el9_4
  • perl-Git-SVN >= 2.43.5-1.el9_4
Patchnames:
RHSA-2024:4083
SUSE Linux Enterprise Desktop 15 SP5
SUSE Linux Enterprise High Performance Computing 15 SP5
SUSE Linux Enterprise Server 15 SP5
SUSE Linux Enterprise Server for SAP Applications 15 SP5
  • git >= 2.35.3-150300.10.39.1
  • git-arch >= 2.35.3-150300.10.39.1
  • git-core >= 2.35.3-150300.10.39.1
  • git-cvs >= 2.35.3-150300.10.39.1
  • git-daemon >= 2.35.3-150300.10.39.1
  • git-doc >= 2.35.3-150300.10.39.1
  • git-email >= 2.35.3-150300.10.39.1
  • git-gui >= 2.35.3-150300.10.39.1
  • git-svn >= 2.35.3-150300.10.39.1
  • git-web >= 2.35.3-150300.10.39.1
  • gitk >= 2.35.3-150300.10.39.1
  • perl-Git >= 2.35.3-150300.10.39.1
Patchnames:
SUSE-SLE-Module-Basesystem-15-SP5-2024-1807
SUSE-SLE-Module-Development-Tools-15-SP5-2024-1807
SUSE Linux Enterprise Desktop 15 SP6
SUSE Linux Enterprise High Performance Computing 15 SP6
SUSE Linux Enterprise Server 15 SP6
SUSE Linux Enterprise Server for SAP Applications 15 SP6
  • git >= 2.43.0-150600.3.3.1
  • git-arch >= 2.43.0-150600.3.3.1
  • git-core >= 2.43.0-150600.3.3.1
  • git-cvs >= 2.43.0-150600.3.3.1
  • git-daemon >= 2.43.0-150600.3.3.1
  • git-doc >= 2.43.0-150600.3.3.1
  • git-email >= 2.43.0-150600.3.3.1
  • git-gui >= 2.43.0-150600.3.3.1
  • git-svn >= 2.43.0-150600.3.3.1
  • git-web >= 2.43.0-150600.3.3.1
  • gitk >= 2.43.0-150600.3.3.1
  • perl-Git >= 2.43.0-150600.3.3.1
Patchnames:
SUSE-SLE-Module-Basesystem-15-SP6-2024-2277
SUSE-SLE-Module-Development-Tools-15-SP6-2024-2277
SUSE Linux Enterprise High Performance Computing 15 SP2-LTSS
  • git >= 2.26.2-150000.56.1
  • git-arch >= 2.26.2-150000.56.1
  • git-core >= 2.26.2-150000.56.1
  • git-cvs >= 2.26.2-150000.56.1
  • git-daemon >= 2.26.2-150000.56.1
  • git-doc >= 2.26.2-150000.56.1
  • git-email >= 2.26.2-150000.56.1
  • git-gui >= 2.26.2-150000.56.1
  • git-svn >= 2.26.2-150000.56.1
  • git-web >= 2.26.2-150000.56.1
  • gitk >= 2.26.2-150000.56.1
Patchnames:
SUSE-SLE-Product-HPC-15-SP2-LTSS-2024-1854
SUSE Linux Enterprise High Performance Computing 15 SP3-LTSS
  • git >= 2.35.3-150300.10.39.1
  • git-arch >= 2.35.3-150300.10.39.1
  • git-core >= 2.35.3-150300.10.39.1
  • git-cvs >= 2.35.3-150300.10.39.1
  • git-daemon >= 2.35.3-150300.10.39.1
  • git-doc >= 2.35.3-150300.10.39.1
  • git-email >= 2.35.3-150300.10.39.1
  • git-gui >= 2.35.3-150300.10.39.1
  • git-svn >= 2.35.3-150300.10.39.1
  • git-web >= 2.35.3-150300.10.39.1
  • gitk >= 2.35.3-150300.10.39.1
  • perl-Git >= 2.35.3-150300.10.39.1
Patchnames:
SUSE-SLE-Product-HPC-15-SP3-LTSS-2024-1807
SUSE Linux Enterprise High Performance Computing 15 SP4-ESPOS
  • git >= 2.35.3-150300.10.39.1
  • git-arch >= 2.35.3-150300.10.39.1
  • git-core >= 2.35.3-150300.10.39.1
  • git-cvs >= 2.35.3-150300.10.39.1
  • git-daemon >= 2.35.3-150300.10.39.1
  • git-doc >= 2.35.3-150300.10.39.1
  • git-email >= 2.35.3-150300.10.39.1
  • git-gui >= 2.35.3-150300.10.39.1
  • git-svn >= 2.35.3-150300.10.39.1
  • git-web >= 2.35.3-150300.10.39.1
  • gitk >= 2.35.3-150300.10.39.1
  • perl-Git >= 2.35.3-150300.10.39.1
Patchnames:
SUSE-SLE-Product-HPC-15-SP4-ESPOS-2024-1807
SUSE Linux Enterprise High Performance Computing 15 SP4-LTSS
  • git >= 2.35.3-150300.10.39.1
  • git-arch >= 2.35.3-150300.10.39.1
  • git-core >= 2.35.3-150300.10.39.1
  • git-cvs >= 2.35.3-150300.10.39.1
  • git-daemon >= 2.35.3-150300.10.39.1
  • git-doc >= 2.35.3-150300.10.39.1
  • git-email >= 2.35.3-150300.10.39.1
  • git-gui >= 2.35.3-150300.10.39.1
  • git-svn >= 2.35.3-150300.10.39.1
  • git-web >= 2.35.3-150300.10.39.1
  • gitk >= 2.35.3-150300.10.39.1
  • perl-Git >= 2.35.3-150300.10.39.1
Patchnames:
SUSE-SLE-Product-HPC-15-SP4-LTSS-2024-1807
SUSE Linux Enterprise Micro 5.5
  • git >= 2.35.3-150300.10.39.1
  • git-core >= 2.35.3-150300.10.39.1
  • perl-Git >= 2.35.3-150300.10.39.1
Patchnames:
SUSE-SLE-Micro-5.5-2024-1807
SUSE Linux Enterprise Module for Basesystem 15 SP5
  • git-core >= 2.35.3-150300.10.39.1
Patchnames:
SUSE-SLE-Module-Basesystem-15-SP5-2024-1807
SUSE Linux Enterprise Module for Basesystem 15 SP6
  • git-core >= 2.43.0-150600.3.3.1
Patchnames:
SUSE-SLE-Module-Basesystem-15-SP6-2024-2277
SUSE Linux Enterprise Module for Development Tools 15 SP5
  • git >= 2.35.3-150300.10.39.1
  • git-arch >= 2.35.3-150300.10.39.1
  • git-cvs >= 2.35.3-150300.10.39.1
  • git-daemon >= 2.35.3-150300.10.39.1
  • git-doc >= 2.35.3-150300.10.39.1
  • git-email >= 2.35.3-150300.10.39.1
  • git-gui >= 2.35.3-150300.10.39.1
  • git-svn >= 2.35.3-150300.10.39.1
  • git-web >= 2.35.3-150300.10.39.1
  • gitk >= 2.35.3-150300.10.39.1
  • perl-Git >= 2.35.3-150300.10.39.1
Patchnames:
SUSE-SLE-Module-Development-Tools-15-SP5-2024-1807
SUSE Linux Enterprise Module for Development Tools 15 SP6
  • git >= 2.43.0-150600.3.3.1
  • git-arch >= 2.43.0-150600.3.3.1
  • git-cvs >= 2.43.0-150600.3.3.1
  • git-daemon >= 2.43.0-150600.3.3.1
  • git-doc >= 2.43.0-150600.3.3.1
  • git-email >= 2.43.0-150600.3.3.1
  • git-gui >= 2.43.0-150600.3.3.1
  • git-svn >= 2.43.0-150600.3.3.1
  • git-web >= 2.43.0-150600.3.3.1
  • gitk >= 2.43.0-150600.3.3.1
  • perl-Git >= 2.43.0-150600.3.3.1
Patchnames:
SUSE-SLE-Module-Development-Tools-15-SP6-2024-2277
SUSE Linux Enterprise Server 15 SP2-LTSS
  • git >= 2.26.2-150000.56.1
  • git-arch >= 2.26.2-150000.56.1
  • git-core >= 2.26.2-150000.56.1
  • git-cvs >= 2.26.2-150000.56.1
  • git-daemon >= 2.26.2-150000.56.1
  • git-doc >= 2.26.2-150000.56.1
  • git-email >= 2.26.2-150000.56.1
  • git-gui >= 2.26.2-150000.56.1
  • git-svn >= 2.26.2-150000.56.1
  • git-web >= 2.26.2-150000.56.1
  • gitk >= 2.26.2-150000.56.1
Patchnames:
SUSE-SLE-Product-SLES-15-SP2-LTSS-2024-1854
SUSE Linux Enterprise Server 15 SP3-LTSS
  • git >= 2.35.3-150300.10.39.1
  • git-arch >= 2.35.3-150300.10.39.1
  • git-core >= 2.35.3-150300.10.39.1
  • git-cvs >= 2.35.3-150300.10.39.1
  • git-daemon >= 2.35.3-150300.10.39.1
  • git-doc >= 2.35.3-150300.10.39.1
  • git-email >= 2.35.3-150300.10.39.1
  • git-gui >= 2.35.3-150300.10.39.1
  • git-svn >= 2.35.3-150300.10.39.1
  • git-web >= 2.35.3-150300.10.39.1
  • gitk >= 2.35.3-150300.10.39.1
  • perl-Git >= 2.35.3-150300.10.39.1
Patchnames:
SUSE-SLE-Product-SLES-15-SP3-LTSS-2024-1807
SUSE Linux Enterprise Server 15 SP4-LTSS
  • git >= 2.35.3-150300.10.39.1
  • git-arch >= 2.35.3-150300.10.39.1
  • git-core >= 2.35.3-150300.10.39.1
  • git-cvs >= 2.35.3-150300.10.39.1
  • git-daemon >= 2.35.3-150300.10.39.1
  • git-doc >= 2.35.3-150300.10.39.1
  • git-email >= 2.35.3-150300.10.39.1
  • git-gui >= 2.35.3-150300.10.39.1
  • git-svn >= 2.35.3-150300.10.39.1
  • git-web >= 2.35.3-150300.10.39.1
  • gitk >= 2.35.3-150300.10.39.1
  • perl-Git >= 2.35.3-150300.10.39.1
Patchnames:
SUSE-SLE-Product-SLES-15-SP4-LTSS-2024-1807
SUSE Linux Enterprise Server for SAP Applications 15 SP2
  • git >= 2.26.2-150000.56.1
  • git-arch >= 2.26.2-150000.56.1
  • git-core >= 2.26.2-150000.56.1
  • git-cvs >= 2.26.2-150000.56.1
  • git-daemon >= 2.26.2-150000.56.1
  • git-doc >= 2.26.2-150000.56.1
  • git-email >= 2.26.2-150000.56.1
  • git-gui >= 2.26.2-150000.56.1
  • git-svn >= 2.26.2-150000.56.1
  • git-web >= 2.26.2-150000.56.1
  • gitk >= 2.26.2-150000.56.1
Patchnames:
SUSE-SLE-Product-SLES_SAP-15-SP2-2024-1854
SUSE Linux Enterprise Server for SAP Applications 15 SP3
  • git >= 2.35.3-150300.10.39.1
  • git-arch >= 2.35.3-150300.10.39.1
  • git-core >= 2.35.3-150300.10.39.1
  • git-cvs >= 2.35.3-150300.10.39.1
  • git-daemon >= 2.35.3-150300.10.39.1
  • git-doc >= 2.35.3-150300.10.39.1
  • git-email >= 2.35.3-150300.10.39.1
  • git-gui >= 2.35.3-150300.10.39.1
  • git-svn >= 2.35.3-150300.10.39.1
  • git-web >= 2.35.3-150300.10.39.1
  • gitk >= 2.35.3-150300.10.39.1
  • perl-Git >= 2.35.3-150300.10.39.1
Patchnames:
SUSE-SLE-Product-SLES_SAP-15-SP3-2024-1807
SUSE Linux Enterprise Server for SAP Applications 15 SP4
  • git >= 2.35.3-150300.10.39.1
  • git-arch >= 2.35.3-150300.10.39.1
  • git-core >= 2.35.3-150300.10.39.1
  • git-cvs >= 2.35.3-150300.10.39.1
  • git-daemon >= 2.35.3-150300.10.39.1
  • git-doc >= 2.35.3-150300.10.39.1
  • git-email >= 2.35.3-150300.10.39.1
  • git-gui >= 2.35.3-150300.10.39.1
  • git-svn >= 2.35.3-150300.10.39.1
  • git-web >= 2.35.3-150300.10.39.1
  • gitk >= 2.35.3-150300.10.39.1
  • perl-Git >= 2.35.3-150300.10.39.1
Patchnames:
SUSE-SLE-Product-SLES_SAP-15-SP4-2024-1807
SUSE Manager Proxy 4.3
  • git-core >= 2.35.3-150300.10.39.1
Patchnames:
SUSE-SLE-Product-SUSE-Manager-Proxy-4.3-2024-1807
SUSE Manager Retail Branch Server 4.3
  • git-core >= 2.35.3-150300.10.39.1
Patchnames:
SUSE-SLE-Product-SUSE-Manager-Retail-Branch-Server-4.3-2024-1807
SUSE Manager Server 4.3
  • git-core >= 2.35.3-150300.10.39.1
Patchnames:
SUSE-SLE-Product-SUSE-Manager-Server-4.3-2024-1807
openSUSE Leap 15.5
  • git >= 2.35.3-150300.10.39.1
  • git-arch >= 2.35.3-150300.10.39.1
  • git-core >= 2.35.3-150300.10.39.1
  • git-credential-gnome-keyring >= 2.35.3-150300.10.39.1
  • git-credential-libsecret >= 2.35.3-150300.10.39.1
  • git-cvs >= 2.35.3-150300.10.39.1
  • git-daemon >= 2.35.3-150300.10.39.1
  • git-doc >= 2.35.3-150300.10.39.1
  • git-email >= 2.35.3-150300.10.39.1
  • git-gui >= 2.35.3-150300.10.39.1
  • git-p4 >= 2.35.3-150300.10.39.1
  • git-svn >= 2.35.3-150300.10.39.1
  • git-web >= 2.35.3-150300.10.39.1
  • gitk >= 2.35.3-150300.10.39.1
  • perl-Git >= 2.35.3-150300.10.39.1
Patchnames:
openSUSE-SLE-15.5-2024-1807
openSUSE Leap 15.6
  • git >= 2.43.0-150600.3.3.1
  • git-arch >= 2.43.0-150600.3.3.1
  • git-core >= 2.43.0-150600.3.3.1
  • git-credential-libsecret >= 2.43.0-150600.3.3.1
  • git-cvs >= 2.43.0-150600.3.3.1
  • git-daemon >= 2.43.0-150600.3.3.1
  • git-doc >= 2.43.0-150600.3.3.1
  • git-email >= 2.43.0-150600.3.3.1
  • git-gui >= 2.43.0-150600.3.3.1
  • git-p4 >= 2.43.0-150600.3.3.1
  • git-svn >= 2.43.0-150600.3.3.1
  • git-web >= 2.43.0-150600.3.3.1
  • gitk >= 2.43.0-150600.3.3.1
  • perl-Git >= 2.43.0-150600.3.3.1
Patchnames:
openSUSE-SLE-15.6-2024-2277
openSUSE Leap Micro 5.5
  • git >= 2.35.3-150300.10.39.1
  • git-core >= 2.35.3-150300.10.39.1
  • perl-Git >= 2.35.3-150300.10.39.1
Patchnames:
openSUSE-Leap-Micro-5.5-2024-1807
openSUSE Tumbleweed
  • git >= 2.45.1-1.1
  • git-arch >= 2.45.1-1.1
  • git-core >= 2.45.1-1.1
  • git-credential-libsecret >= 2.45.1-1.1
  • git-cvs >= 2.45.1-1.1
  • git-daemon >= 2.45.1-1.1
  • git-doc >= 2.45.1-1.1
  • git-email >= 2.45.1-1.1
  • git-gui >= 2.45.1-1.1
  • git-p4 >= 2.45.1-1.1
  • git-svn >= 2.45.1-1.1
  • git-web >= 2.45.1-1.1
  • gitk >= 2.45.1-1.1
  • perl-Git >= 2.45.1-1.1
Patchnames:
openSUSE-Tumbleweed-2024-13968


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification. The updates are grouped by state of their lifecycle. SUSE product lifecycles are documented on the lifecycle page.

Product(s) Source package State
Products under general support and receiving all security fixes.
SUSE Enterprise Storage 7.1 git Released
SUSE Enterprise Storage 7.1 libgit2 Not affected
SUSE Linux Enterprise Desktop 15 SP5 git Released
SUSE Linux Enterprise Desktop 15 SP5 libgit2 Not affected
SUSE Linux Enterprise Desktop 15 SP6 git Released
SUSE Linux Enterprise Desktop 15 SP6 libgit2 Not affected
SUSE Linux Enterprise High Performance Computing 12 SP5 git Affected
SUSE Linux Enterprise High Performance Computing 15 SP5 git Released
SUSE Linux Enterprise High Performance Computing 15 SP5 libgit2 Not affected
SUSE Linux Enterprise High Performance Computing 15 SP6 git Released
SUSE Linux Enterprise High Performance Computing 15 SP6 libgit2 Not affected
SUSE Linux Enterprise Micro 5.5 git Released
SUSE Linux Enterprise Micro 6.0 git Affected
SUSE Linux Enterprise Module for Basesystem 15 SP5 git Released
SUSE Linux Enterprise Module for Basesystem 15 SP6 git Released
SUSE Linux Enterprise Module for Development Tools 15 SP5 git Released
SUSE Linux Enterprise Module for Development Tools 15 SP5 libgit2 Not affected
SUSE Linux Enterprise Module for Development Tools 15 SP6 git Released
SUSE Linux Enterprise Module for Development Tools 15 SP6 libgit2 Not affected
SUSE Linux Enterprise Server 12 SP5 git Affected
SUSE Linux Enterprise Server 12 SP5 libgit2 Not affected
SUSE Linux Enterprise Server 15 SP5 git Released
SUSE Linux Enterprise Server 15 SP5 libgit2 Not affected
SUSE Linux Enterprise Server 15 SP6 git Released
SUSE Linux Enterprise Server 15 SP6 libgit2 Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP5 git Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP5 libgit2 Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP5 git Released
SUSE Linux Enterprise Server for SAP Applications 15 SP5 libgit2 Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP6 git Released
SUSE Linux Enterprise Server for SAP Applications 15 SP6 libgit2 Not affected
SUSE Linux Enterprise Software Development Kit 12 SP5 git Affected
SUSE Linux Enterprise Software Development Kit 12 SP5 libgit2 Not affected
SUSE Manager Proxy 4.3 git Released
SUSE Manager Proxy 4.3 libgit2 Not affected
SUSE Manager Retail Branch Server 4.3 git Released
SUSE Manager Retail Branch Server 4.3 libgit2 Not affected
SUSE Manager Server 4.3 git Released
SUSE Manager Server 4.3 libgit2 Not affected
SUSE Manager Server Module 4.3 libgit2 Not affected
openSUSE Leap 15.5 git Released
openSUSE Leap 15.5 libgit2 Not affected
openSUSE Leap 15.6 git Released
openSUSE Leap 15.6 libgit2 Not affected
openSUSE Leap Micro 5.5 git Affected
Products under Long Term Service Pack support and receiving important and critical security fixes.
SUSE Linux Enterprise Desktop 15 SP4 git Affected
SUSE Linux Enterprise Desktop 15 SP4 libgit2 Not affected
SUSE Linux Enterprise Desktop 15 SP4 LTSS git Released
SUSE Linux Enterprise High Performance Computing 15 SP2 git Affected
SUSE Linux Enterprise High Performance Computing 15 SP2 libgit2 Not affected
SUSE Linux Enterprise High Performance Computing 15 SP2-ESPOS git Affected
SUSE Linux Enterprise High Performance Computing 15 SP2-ESPOS libgit2 Not affected
SUSE Linux Enterprise High Performance Computing 15 SP2-LTSS git Released
SUSE Linux Enterprise High Performance Computing 15 SP2-LTSS libgit2 Not affected
SUSE Linux Enterprise High Performance Computing 15 SP3 git Affected
SUSE Linux Enterprise High Performance Computing 15 SP3 libgit2 Not affected
SUSE Linux Enterprise High Performance Computing 15 SP3-ESPOS git Affected
SUSE Linux Enterprise High Performance Computing 15 SP3-ESPOS libgit2 Not affected
SUSE Linux Enterprise High Performance Computing 15 SP3-LTSS git Released
SUSE Linux Enterprise High Performance Computing 15 SP3-LTSS libgit2 Not affected
SUSE Linux Enterprise High Performance Computing 15 SP4 git Affected
SUSE Linux Enterprise High Performance Computing 15 SP4 libgit2 Not affected
SUSE Linux Enterprise High Performance Computing 15 SP4-ESPOS git Released
SUSE Linux Enterprise High Performance Computing 15 SP4-ESPOS libgit2 Not affected
SUSE Linux Enterprise High Performance Computing 15 SP4-LTSS git Released
SUSE Linux Enterprise High Performance Computing 15 SP4-LTSS libgit2 Not affected
SUSE Linux Enterprise Module for Basesystem 15 SP2 git Affected
SUSE Linux Enterprise Module for Basesystem 15 SP3 git Affected
SUSE Linux Enterprise Module for Basesystem 15 SP4 git Affected
SUSE Linux Enterprise Module for Development Tools 15 SP2 git Affected
SUSE Linux Enterprise Module for Development Tools 15 SP2 libgit2 Not affected
SUSE Linux Enterprise Module for Development Tools 15 SP3 git Affected
SUSE Linux Enterprise Module for Development Tools 15 SP3 libgit2 Not affected
SUSE Linux Enterprise Module for Development Tools 15 SP4 git Affected
SUSE Linux Enterprise Module for Development Tools 15 SP4 libgit2 Not affected
SUSE Linux Enterprise Server 15 SP2 git Affected
SUSE Linux Enterprise Server 15 SP2 libgit2 Not affected
SUSE Linux Enterprise Server 15 SP2-LTSS git Released
SUSE Linux Enterprise Server 15 SP2-LTSS libgit2 Not affected
SUSE Linux Enterprise Server 15 SP3 git Affected
SUSE Linux Enterprise Server 15 SP3 libgit2 Not affected
SUSE Linux Enterprise Server 15 SP3-LTSS git Released
SUSE Linux Enterprise Server 15 SP3-LTSS libgit2 Not affected
SUSE Linux Enterprise Server 15 SP4 git Affected
SUSE Linux Enterprise Server 15 SP4 libgit2 Not affected
SUSE Linux Enterprise Server 15 SP4-LTSS git Released
SUSE Linux Enterprise Server 15 SP4-LTSS libgit2 Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP2 git Released
SUSE Linux Enterprise Server for SAP Applications 15 SP2 libgit2 Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP3 git Released
SUSE Linux Enterprise Server for SAP Applications 15 SP3 libgit2 Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP4 git Released
SUSE Linux Enterprise Server for SAP Applications 15 SP4 libgit2 Not affected
Products past their end of life and not receiving proactive updates anymore.
HPE Helion OpenStack 8 git Affected
SUSE CaaS Platform 3.0 git Affected
SUSE CaaS Platform 4.0 git Affected
SUSE CaaS Platform 4.0 libgit2 Not affected
SUSE Enterprise Storage 6 git Affected
SUSE Enterprise Storage 6 libgit2 Not affected
SUSE Enterprise Storage 7 git Affected
SUSE Enterprise Storage 7 libgit2 Not affected
SUSE Linux Enterprise Desktop 12 git Affected
SUSE Linux Enterprise Desktop 12 SP1 git Affected
SUSE Linux Enterprise Desktop 12 SP2 git Affected
SUSE Linux Enterprise Desktop 12 SP3 git Affected
SUSE Linux Enterprise Desktop 12 SP4 git Affected
SUSE Linux Enterprise Desktop 15 git Affected
SUSE Linux Enterprise Desktop 15 libgit2 Not affected
SUSE Linux Enterprise Desktop 15 SP1 git Affected
SUSE Linux Enterprise Desktop 15 SP1 libgit2 Not affected
SUSE Linux Enterprise Desktop 15 SP2 git Affected
SUSE Linux Enterprise Desktop 15 SP2 libgit2 Not affected
SUSE Linux Enterprise Desktop 15 SP3 git Affected
SUSE Linux Enterprise Desktop 15 SP3 libgit2 Not affected
SUSE Linux Enterprise High Performance Computing 15 git Affected
SUSE Linux Enterprise High Performance Computing 15 libgit2 Not affected
SUSE Linux Enterprise High Performance Computing 15 SP1 git Affected
SUSE Linux Enterprise High Performance Computing 15 SP1 libgit2 Not affected
SUSE Linux Enterprise High Performance Computing 15 SP1-ESPOS git Affected
SUSE Linux Enterprise High Performance Computing 15 SP1-ESPOS libgit2 Not affected
SUSE Linux Enterprise High Performance Computing 15 SP1-LTSS git Affected
SUSE Linux Enterprise High Performance Computing 15 SP1-LTSS libgit2 Not affected
SUSE Linux Enterprise High Performance Computing 15-ESPOS git Affected
SUSE Linux Enterprise High Performance Computing 15-ESPOS libgit2 Not affected
SUSE Linux Enterprise High Performance Computing 15-LTSS git Affected
SUSE Linux Enterprise High Performance Computing 15-LTSS libgit2 Not affected
SUSE Linux Enterprise Module for Basesystem 15 git Affected
SUSE Linux Enterprise Module for Basesystem 15 SP1 git Affected
SUSE Linux Enterprise Module for Development Tools 15 git Affected
SUSE Linux Enterprise Module for Development Tools 15 libgit2 Not affected
SUSE Linux Enterprise Module for Development Tools 15 SP1 git Affected
SUSE Linux Enterprise Module for Development Tools 15 SP1 libgit2 Not affected
SUSE Linux Enterprise Point of Sale 12 SP2-CLIENT git Affected
SUSE Linux Enterprise Real Time 15 SP2 git Affected
SUSE Linux Enterprise Real Time 15 SP2 libgit2 Not affected
SUSE Linux Enterprise Real Time 15 SP3 git Affected
SUSE Linux Enterprise Real Time 15 SP3 libgit2 Not affected
SUSE Linux Enterprise Real Time 15 SP4 git Affected
SUSE Linux Enterprise Real Time 15 SP4 libgit2 Not affected
SUSE Linux Enterprise Server 12 git Affected
SUSE Linux Enterprise Server 12 SP1 git Affected
SUSE Linux Enterprise Server 12 SP1-LTSS git Affected
SUSE Linux Enterprise Server 12 SP2 git Affected
SUSE Linux Enterprise Server 12 SP2-BCL git Affected
SUSE Linux Enterprise Server 12 SP2-ESPOS git Affected
SUSE Linux Enterprise Server 12 SP2-LTSS git Affected
SUSE Linux Enterprise Server 12 SP3 git Affected
SUSE Linux Enterprise Server 12 SP3-BCL git Affected
SUSE Linux Enterprise Server 12 SP3-ESPOS git Affected
SUSE Linux Enterprise Server 12 SP3-LTSS git Affected
SUSE Linux Enterprise Server 12 SP4 git Affected
SUSE Linux Enterprise Server 12 SP4-ESPOS git Affected
SUSE Linux Enterprise Server 12 SP4-LTSS git Affected
SUSE Linux Enterprise Server 12-LTSS git Affected
SUSE Linux Enterprise Server 15 git Affected
SUSE Linux Enterprise Server 15 libgit2 Not affected
SUSE Linux Enterprise Server 15 SP1 git Affected
SUSE Linux Enterprise Server 15 SP1 libgit2 Not affected
SUSE Linux Enterprise Server 15 SP1-BCL git Affected
SUSE Linux Enterprise Server 15 SP1-BCL libgit2 Not affected
SUSE Linux Enterprise Server 15 SP1-LTSS git Affected
SUSE Linux Enterprise Server 15 SP1-LTSS libgit2 Not affected
SUSE Linux Enterprise Server 15 SP2-BCL git Affected
SUSE Linux Enterprise Server 15 SP2-BCL libgit2 Not affected
SUSE Linux Enterprise Server 15 SP3-BCL git Affected
SUSE Linux Enterprise Server 15 SP3-BCL libgit2 Not affected
SUSE Linux Enterprise Server 15-LTSS git Affected
SUSE Linux Enterprise Server 15-LTSS libgit2 Not affected
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2 git Affected
SUSE Linux Enterprise Server for SAP Applications 12 git Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP1 git Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP2 git Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP3 git Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP4 git Affected
SUSE Linux Enterprise Server for SAP Applications 15 git Affected
SUSE Linux Enterprise Server for SAP Applications 15 libgit2 Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP1 git Affected
SUSE Linux Enterprise Server for SAP Applications 15 SP1 libgit2 Not affected
SUSE Linux Enterprise Software Development Kit 12 git Affected
SUSE Linux Enterprise Software Development Kit 12 SP1 git Affected
SUSE Linux Enterprise Software Development Kit 12 SP2 git Affected
SUSE Linux Enterprise Software Development Kit 12 SP3 git Affected
SUSE Linux Enterprise Software Development Kit 12 SP4 git Affected
SUSE Manager Proxy 4.0 git Affected
SUSE Manager Proxy 4.0 libgit2 Not affected
SUSE Manager Proxy 4.1 git Affected
SUSE Manager Proxy 4.1 libgit2 Not affected
SUSE Manager Proxy 4.2 git Affected
SUSE Manager Proxy 4.2 libgit2 Not affected
SUSE Manager Retail Branch Server 4.0 git Affected
SUSE Manager Retail Branch Server 4.0 libgit2 Not affected
SUSE Manager Retail Branch Server 4.1 git Affected
SUSE Manager Retail Branch Server 4.1 libgit2 Not affected
SUSE Manager Retail Branch Server 4.2 git Affected
SUSE Manager Retail Branch Server 4.2 libgit2 Not affected
SUSE Manager Server 4.0 git Affected
SUSE Manager Server 4.0 libgit2 Not affected
SUSE Manager Server 4.1 git Affected
SUSE Manager Server 4.1 libgit2 Not affected
SUSE Manager Server 4.2 git Affected
SUSE Manager Server 4.2 libgit2 Not affected
SUSE Manager Server Module 4.0 libgit2 Not affected
SUSE Manager Server Module 4.1 libgit2 Not affected
SUSE Manager Server Module 4.2 libgit2 Not affected
SUSE OpenStack Cloud 7 git Affected
SUSE OpenStack Cloud 8 git Affected
SUSE OpenStack Cloud 9 git Affected
SUSE OpenStack Cloud Crowbar 8 git Affected
SUSE OpenStack Cloud Crowbar 9 git Affected
openSUSE Leap 15.3 git Released
openSUSE Leap 15.3 libgit2 Not affected
openSUSE Leap 15.4 git Affected
openSUSE Leap 15.4 libgit2 Not affected
Container Status
bci/spack gitReleased
Harvester master
rancher/fleet-agent:v0.9.2
rancher/fleet:v0.9.2
rancher/gitjob:v0.9.4
rancher/rancher:v2.8.3
git-coreAffected
rancher/nginx-ingress-controller:nginx-1.9.6-hardened1 git
git-core
perl-Git
Affected
Harvester v1.2-head
rancher/rancher:v2.8.2 git-coreAffected
rancher/fleet-agent:v0.9.0
rancher/nginx-ingress-controller:nginx-1.9.3-hardened1
git
git-core
perl-Git
Affected
Harvester v1.2.1
rancher/rancher:v2.7.5 git-coreAffected
longhornio/longhorn-engine:v1.4.3
longhornio/longhorn-instance-manager:v1.4.3
rancher/fleet-agent:v0.7.0
rancher/gitjob:v0.1.54
rancher/nginx-ingress-controller:nginx-1.6.4-hardened4
git
git-core
perl-Git
Affected
Harvester v1.2.2
rancher/rancher:v2.8.2 git-coreAffected
rancher/fleet-agent:v0.9.0
rancher/nginx-ingress-controller:nginx-1.9.3-hardened1
git
git-core
perl-Git
Affected
Harvester v1.3-head
rancher/fleet-agent:v0.9.2
rancher/fleet:v0.9.2
rancher/gitjob:v0.9.4
rancher/rancher:v2.8.3
git-coreAffected
rancher/nginx-ingress-controller:nginx-1.9.6-hardened1 git
git-core
perl-Git
Affected
Harvester v1.3.0
rancher/rancher:v2.8.2 git-coreAffected
rancher/fleet-agent:v0.9.0
rancher/nginx-ingress-controller:nginx-1.9.3-hardened1
git
git-core
perl-Git
Affected
Harvester v1.3.1
rancher/fleet-agent:v0.9.2
rancher/fleet:v0.9.2
rancher/gitjob:v0.9.4
rancher/rancher:v2.8.3
git-coreAffected
rancher/nginx-ingress-controller:nginx-1.9.6-hardened1 git
git-core
perl-Git
Affected
Longhorn v1.5.3
longhornio/longhorn-engine:v1.5.3 git
git-core
perl-Git
Affected
Rancher v2.7-head
rancher/machine:v0.15.0-rancher109
rancher/rancher-agent:v2.7-head
rancher/rancher:v2.7-head
git-coreAffected
rancher/nginx-ingress-controller:nginx-1.2.1-hardened9
rancher/nginx-ingress-controller:nginx-1.4.1-hardened2
rancher/nginx-ingress-controller:nginx-1.6.4-hardened4
rancher/nginx-ingress-controller:nginx-1.7.1-hardened1
rancher/nginx-ingress-controller:nginx-1.9.3-hardened1
rancher/nginx-ingress-controller:nginx-1.9.6-hardened1
rancher/nginx-ingress-controller:v1.10.1-hardened1
git
git-core
perl-Git
Affected
Rancher v2.7.14
rancher/machine:v0.15.0-rancher109 git-coreAffected
rancher/nginx-ingress-controller:nginx-1.2.1-hardened9
rancher/nginx-ingress-controller:nginx-1.4.1-hardened2
rancher/nginx-ingress-controller:nginx-1.6.4-hardened4
rancher/nginx-ingress-controller:nginx-1.7.1-hardened1
rancher/nginx-ingress-controller:nginx-1.9.3-hardened1
rancher/nginx-ingress-controller:nginx-1.9.6-hardened1
git
git-core
perl-Git
Affected
Rancher v2.8-head
rancher/machine:v0.15.0-rancher112 git-coreAffected
rancher/nginx-ingress-controller:nginx-1.7.1-hardened1
rancher/nginx-ingress-controller:nginx-1.9.3-hardened1
rancher/nginx-ingress-controller:nginx-1.9.6-hardened1
rancher/nginx-ingress-controller:v1.10.1-hardened1
git
git-core
perl-Git
Affected
Rancher v2.8.5
rancher/machine:v0.15.0-rancher112 git-coreAffected
rancher/nginx-ingress-controller:nginx-1.7.1-hardened1
rancher/nginx-ingress-controller:nginx-1.9.3-hardened1
rancher/nginx-ingress-controller:nginx-1.9.6-hardened1
git
git-core
perl-Git
Affected
Rancher v2.9-head
rancher/machine:v0.15.0-rancher109 git-coreAffected
rancher/nginx-ingress-controller:nginx-1.7.1-hardened1
rancher/nginx-ingress-controller:nginx-1.9.3-hardened1
rancher/nginx-ingress-controller:nginx-1.9.6-hardened1
rancher/nginx-ingress-controller:v1.10.1-hardened1
git
git-core
perl-Git
Affected


SUSE Timeline for this CVE

CVE page created: Mon May 13 15:15:14 2024
CVE page last modified: Thu Jul 18 11:58:59 2024