Upstream information

CVE-2024-2511 at MITRE

Description

Issue summary: Some non-default TLS server configurations can cause unbounded memory growth when processing TLSv1.3 sessions Impact summary: An attacker may exploit certain server configurations to trigger unbounded memory growth that would lead to a Denial of Service This problem can occur in TLSv1.3 if the non-default SSL_OP_NO_TICKET option is being used (but not if early_data support is also configured and the default anti-replay protection is in use). In this case, under certain conditions, the session cache can get into an incorrect state and it will fail to flush properly as it fills. The session cache will continue to grow in an unbounded manner. A malicious client could deliberately create the scenario for this failure to force a Denial of Service. It may also happen by accident in normal operation. This issue only affects TLS servers supporting TLSv1.3. It does not affect TLS clients. The FIPS modules in 3.2, 3.1 and 3.0 are not affected by this issue. OpenSSL 1.0.2 is also not affected by this issue.

Upstream Security Advisories:

SUSE information

Overall state of this security issue: Pending

This issue is currently rated as having moderate severity.

CVSS v3 Scores
  SUSE
Base Score 5.9
Vector CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H
Attack Vector Network
Attack Complexity High
Privileges Required None
User Interaction None
Scope Unchanged
Confidentiality Impact None
Integrity Impact None
Availability Impact High
CVSSv3 Version 3.1
SUSE Bugzilla entry: 1222548 [IN_PROGRESS]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
Container bci/bci-init:15.5
Container bci/golang:oldstable-2.7.2
Container bci/nodejs:18-21.9
Container bci/nodejs:20-10.9
Container bci/php-apache:8-19.10
Container bci/php-fpm:8-20.8
Container bci/php:8-19.9
Container bci/ruby:2.5-20.9
Container bci/rust:1.78-1.2.7
Container bci/rust:oldstable-2.2.7
Container suse/nginx:1.21-13.11
Container suse/pcp:5.2.5-26.28
Container suse/postgres:15.7-20.10
Container suse/postgres:16.3-9.9
Container suse/rmt-mariadb-client:10.6-17.11
Container suse/rmt-mariadb:10.6-25.11
Container suse/rmt-server:2.16-20.9
  • libopenssl1_1 >= 1.1.1l-150500.17.28.2
  • libopenssl1_1-hmac >= 1.1.1l-150500.17.28.2
Container bci/bci-sle15-kernel-module-devel:15.5
Container bci/openjdk-devel:11-16.17
Container bci/openjdk-devel:17
Container bci/openjdk:11-18.10
Container bci/openjdk:17
Container bci/python:3.11-20.10
Container bci/python:3.6-22.9
Container rancher/elemental-operator:1.5.4-1.13.1
Container rancher/seedimage-builder:1.5.4-1.11.1
Container suse/389-ds:2.2-22.14
Container suse/sle-micro/5.5/toolbox:13.2-2.2.244
Container suse/sle-micro/base-5.5:2.0.4-5.8.9
Container suse/sle15:15.5.36.11.38
  • libopenssl1_1 >= 1.1.1l-150500.17.28.2
  • libopenssl1_1-hmac >= 1.1.1l-150500.17.28.2
  • openssl-1_1 >= 1.1.1l-150500.17.28.2
Container bci/golang:oldstable-openssl-17.2
Container bci/golang:stable-openssl-17.1
  • libopenssl-1_1-devel >= 1.1.1l-150500.17.28.2
  • libopenssl1_1 >= 1.1.1l-150500.17.28.2
  • libopenssl1_1-hmac >= 1.1.1l-150500.17.28.2
  • openssl-1_1 >= 1.1.1l-150500.17.28.2
Container suse/git:2.35-12.7
Container suse/sle-micro/kvm-5.5:2.0.4-3.5.19
Container suse/sle-micro/rt-5.5:2.0.4-4.5.21
  • libopenssl1_1 >= 1.1.1l-150500.17.28.2
Container suse/helm:3.13-11.6
Container suse/registry:2.8-25.8
Container suse/sle-micro/5.5:2.0.4-5.5.15
Image SLES15-SP5-BYOS-EC2
Image SLES15-SP5-BYOS-GCE
Image SLES15-SP5-CHOST-BYOS-Aliyun
Image SLES15-SP5-CHOST-BYOS-Azure
Image SLES15-SP5-CHOST-BYOS-EC2
Image SLES15-SP5-CHOST-BYOS-GCE
Image SLES15-SP5-CHOST-BYOS-SAP-CCloud
Image SLES15-SP5-EC2
Image SLES15-SP5-GCE
Image SLES15-SP5-HPC-BYOS-EC2
Image SLES15-SP5-HPC-BYOS-GCE
Image SLES15-SP5-Hardened-BYOS-GCE
Image SLES15-SP5-Micro-5-5
Image SLES15-SP5-Micro-5-5-BYOS
Image SLES15-SP5-Micro-5-5-BYOS-EC2
Image SLES15-SP5-Micro-5-5-BYOS-GCE
Image SLES15-SP5-Micro-5-5-EC2
Image SLES15-SP5-Micro-5-5-GCE
Image SLES15-SP5-SAP-BYOS-EC2
  • libopenssl1_1 >= 1.1.1l-150500.17.28.2
  • openssl-1_1 >= 1.1.1l-150500.17.28.2
Container suse/ltss/sle15.3/sle15:15.3.4.51
Container suse/sle-micro/5.1/toolbox:13.2-3.8.29
Container suse/sle-micro/5.2/toolbox:13.2-7.8.29
Container suse/sle15:15.2.9.5.449
  • libopenssl1_1 >= 1.1.1d-150200.11.88.1
  • libopenssl1_1-hmac >= 1.1.1d-150200.11.88.1
  • openssl-1_1 >= 1.1.1d-150200.11.88.1
Container suse/ltss/sle15.4/sle15:15.4.3.40
Container suse/manager/4.3/proxy-salt-broker:4.3.12.9.42.16
Container suse/manager/4.3/proxy-tftpd:4.3.12.9.42.7
Container suse/sle-micro/5.3/toolbox:13.2-6.8.43
Container suse/sle-micro/5.4/toolbox:13.2-5.15.42
  • libopenssl1_1 >= 1.1.1l-150400.7.66.2
  • libopenssl1_1-hmac >= 1.1.1l-150400.7.66.2
  • openssl-1_1 >= 1.1.1l-150400.7.66.2
Container suse/manager/4.3/proxy-httpd:4.3.12.9.52.13
Container suse/manager/4.3/proxy-squid:4.3.12.9.51.7
Container suse/manager/4.3/proxy-ssh:4.3.12.9.42.6
  • libopenssl1_1 >= 1.1.1l-150400.7.66.2
  • libopenssl1_1-hmac >= 1.1.1l-150400.7.66.2
Container suse/sle-micro-rancher/5.2:latest
Image SLES15-SP3-Micro-5-1-BYOS-Azure
Image SLES15-SP3-Micro-5-1-BYOS-EC2-HVM
Image SLES15-SP3-Micro-5-1-BYOS-GCE
Image SLES15-SP3-Micro-5-2-BYOS-Azure
Image SLES15-SP3-Micro-5-2-BYOS-EC2-HVM
Image SLES15-SP3-Micro-5-2-BYOS-GCE
  • libopenssl1_1 >= 1.1.1d-150200.11.88.1
  • openssl-1_1 >= 1.1.1d-150200.11.88.1
Container suse/sle-micro-rancher/5.3:latest
Container suse/sle-micro-rancher/5.4:latest
Image SLES15-SP4-CHOST-BYOS
Image SLES15-SP4-CHOST-BYOS-Aliyun
Image SLES15-SP4-CHOST-BYOS-Azure
Image SLES15-SP4-CHOST-BYOS-EC2
Image SLES15-SP4-CHOST-BYOS-GCE
Image SLES15-SP4-CHOST-BYOS-SAP-CCloud
Image SLES15-SP4-Manager-Proxy-4-3-BYOS
Image SLES15-SP4-Manager-Proxy-4-3-BYOS-EC2
Image SLES15-SP4-Manager-Proxy-4-3-BYOS-GCE
Image SLES15-SP4-Manager-Server-4-3-BYOS
Image SLES15-SP4-Manager-Server-4-3-BYOS-Azure
Image SLES15-SP4-Manager-Server-4-3-BYOS-EC2
Image SLES15-SP4-Manager-Server-4-3-BYOS-GCE
Image SLES15-SP4-Micro-5-3
Image SLES15-SP4-Micro-5-3-BYOS
Image SLES15-SP4-Micro-5-3-BYOS-Azure
Image SLES15-SP4-Micro-5-3-BYOS-EC2
Image SLES15-SP4-Micro-5-3-BYOS-GCE
Image SLES15-SP4-Micro-5-3-EC2
Image SLES15-SP4-Micro-5-4
Image SLES15-SP4-Micro-5-4-BYOS
Image SLES15-SP4-Micro-5-4-BYOS-Azure
Image SLES15-SP4-Micro-5-4-EC2
  • libopenssl1_1 >= 1.1.1l-150400.7.66.2
  • openssl-1_1 >= 1.1.1l-150400.7.66.2
Container trento/trento-wanda:1.0.0-build1.5.2
Container trento/trento-web:2.0.0-build4.21.2
  • libopenssl1_1 >= 1.1.1d-150200.11.88.1
  • libopenssl1_1-hmac >= 1.1.1d-150200.11.88.1
Image SLES15-SP2-SAP-Azure-LI-BYOS-Production
Image SLES15-SP2-SAP-Azure-VLI-BYOS-Production
Image SLES15-SP3-SAP-Azure-LI-BYOS-Production
Image SLES15-SP3-SAP-Azure-VLI-BYOS-Production
  • libopenssl1_1 >= 1.1.1d-150200.11.88.1
  • libopenssl1_1-32bit >= 1.1.1d-150200.11.88.1
  • openssl-1_1 >= 1.1.1d-150200.11.88.1
Image SLES15-SP4-SAP-Azure-LI-BYOS
Image SLES15-SP4-SAP-Azure-LI-BYOS-Production
Image SLES15-SP4-SAP-Azure-VLI-BYOS
Image SLES15-SP4-SAP-Azure-VLI-BYOS-Production
  • libopenssl1_1 >= 1.1.1l-150400.7.66.2
  • libopenssl1_1-32bit >= 1.1.1l-150400.7.66.2
  • openssl-1_1 >= 1.1.1l-150400.7.66.2
Image SLES15-SP5-SAP-Azure-LI-BYOS
Image SLES15-SP5-SAP-Azure-LI-BYOS-Production
Image SLES15-SP5-SAP-Azure-VLI-BYOS
Image SLES15-SP5-SAP-Azure-VLI-BYOS-Production
Image SLES15-SP5-SAPCAL-EC2
Image SLES15-SP5-SAPCAL-GCE
  • libopenssl1_1 >= 1.1.1l-150500.17.28.2
  • libopenssl1_1-32bit >= 1.1.1l-150500.17.28.2
  • openssl-1_1 >= 1.1.1l-150500.17.28.2
SUSE Enterprise Storage 7.1
  • libopenssl-1_1-devel >= 1.1.1d-150200.11.88.1
  • libopenssl-1_1-devel-32bit >= 1.1.1d-150200.11.88.1
  • libopenssl1_1 >= 1.1.1d-150200.11.88.1
  • libopenssl1_1-32bit >= 1.1.1d-150200.11.88.1
  • libopenssl1_1-hmac >= 1.1.1d-150200.11.88.1
  • libopenssl1_1-hmac-32bit >= 1.1.1d-150200.11.88.1
  • openssl-1_1 >= 1.1.1d-150200.11.88.1
  • openssl-1_1-doc >= 1.1.1d-150200.11.88.1
Patchnames:
SUSE-Storage-7.1-2024-1633
SUSE Linux Enterprise Desktop 15 SP5
SUSE Linux Enterprise High Performance Computing 15 SP5
SUSE Linux Enterprise Module for Basesystem 15 SP5
SUSE Linux Enterprise Server 15 SP5
SUSE Linux Enterprise Server for SAP Applications 15 SP5
  • libopenssl-1_1-devel >= 1.1.1l-150500.17.28.2
  • libopenssl-3-devel >= 3.0.8-150500.5.30.1
  • libopenssl1_1 >= 1.1.1l-150500.17.28.2
  • libopenssl1_1-32bit >= 1.1.1l-150500.17.28.2
  • libopenssl1_1-hmac >= 1.1.1l-150500.17.28.2
  • libopenssl1_1-hmac-32bit >= 1.1.1l-150500.17.28.2
  • libopenssl3 >= 3.0.8-150500.5.30.1
  • openssl-1_1 >= 1.1.1l-150500.17.28.2
  • openssl-3 >= 3.0.8-150500.5.30.1
Patchnames:
SUSE-SLE-Module-Basesystem-15-SP5-2024-1634
SUSE-SLE-Module-Basesystem-15-SP5-2024-1808
SUSE Linux Enterprise High Performance Computing 15 SP2-LTSS
  • libopenssl-1_1-devel >= 1.1.1d-150200.11.88.1
  • libopenssl1_1 >= 1.1.1d-150200.11.88.1
  • libopenssl1_1-32bit >= 1.1.1d-150200.11.88.1
  • libopenssl1_1-hmac >= 1.1.1d-150200.11.88.1
  • libopenssl1_1-hmac-32bit >= 1.1.1d-150200.11.88.1
  • openssl-1_1 >= 1.1.1d-150200.11.88.1
Patchnames:
SUSE-SLE-Product-HPC-15-SP2-LTSS-2024-1633
SUSE Linux Enterprise High Performance Computing 15 SP3-LTSS
  • libopenssl-1_1-devel >= 1.1.1d-150200.11.88.1
  • libopenssl-1_1-devel-32bit >= 1.1.1d-150200.11.88.1
  • libopenssl1_1 >= 1.1.1d-150200.11.88.1
  • libopenssl1_1-32bit >= 1.1.1d-150200.11.88.1
  • libopenssl1_1-hmac >= 1.1.1d-150200.11.88.1
  • libopenssl1_1-hmac-32bit >= 1.1.1d-150200.11.88.1
  • openssl-1_1 >= 1.1.1d-150200.11.88.1
  • openssl-1_1-doc >= 1.1.1d-150200.11.88.1
Patchnames:
SUSE-SLE-Product-HPC-15-SP3-LTSS-2024-1633
SUSE Linux Enterprise High Performance Computing 15 SP4-ESPOS
  • libopenssl-1_1-devel >= 1.1.1l-150400.7.66.2
  • libopenssl-1_1-devel-32bit >= 1.1.1l-150400.7.66.2
  • libopenssl-3-devel >= 3.0.8-150400.4.54.1
  • libopenssl1_1 >= 1.1.1l-150400.7.66.2
  • libopenssl1_1-32bit >= 1.1.1l-150400.7.66.2
  • libopenssl1_1-hmac >= 1.1.1l-150400.7.66.2
  • libopenssl1_1-hmac-32bit >= 1.1.1l-150400.7.66.2
  • libopenssl3 >= 3.0.8-150400.4.54.1
  • openssl-1_1 >= 1.1.1l-150400.7.66.2
  • openssl-3 >= 3.0.8-150400.4.54.1
Patchnames:
SUSE-SLE-Product-HPC-15-SP4-ESPOS-2024-1947
SUSE-SLE-Product-HPC-15-SP4-ESPOS-2024-1949
SUSE Linux Enterprise High Performance Computing 15 SP4-LTSS
  • libopenssl-1_1-devel >= 1.1.1l-150400.7.66.2
  • libopenssl-1_1-devel-32bit >= 1.1.1l-150400.7.66.2
  • libopenssl-3-devel >= 3.0.8-150400.4.54.1
  • libopenssl1_1 >= 1.1.1l-150400.7.66.2
  • libopenssl1_1-32bit >= 1.1.1l-150400.7.66.2
  • libopenssl1_1-hmac >= 1.1.1l-150400.7.66.2
  • libopenssl1_1-hmac-32bit >= 1.1.1l-150400.7.66.2
  • libopenssl3 >= 3.0.8-150400.4.54.1
  • openssl-1_1 >= 1.1.1l-150400.7.66.2
  • openssl-3 >= 3.0.8-150400.4.54.1
Patchnames:
SUSE-SLE-Product-HPC-15-SP4-LTSS-2024-1947
SUSE-SLE-Product-HPC-15-SP4-LTSS-2024-1949
SUSE Linux Enterprise Micro 5.1
  • libopenssl-1_1-devel >= 1.1.1d-150200.11.88.1
  • libopenssl1_1 >= 1.1.1d-150200.11.88.1
  • libopenssl1_1-hmac >= 1.1.1d-150200.11.88.1
  • openssl-1_1 >= 1.1.1d-150200.11.88.1
Patchnames:
SUSE-SUSE-MicroOS-5.1-2024-1633
SUSE Linux Enterprise Micro 5.2
  • libopenssl-1_1-devel >= 1.1.1d-150200.11.88.1
  • libopenssl1_1 >= 1.1.1d-150200.11.88.1
  • libopenssl1_1-hmac >= 1.1.1d-150200.11.88.1
  • openssl-1_1 >= 1.1.1d-150200.11.88.1
Patchnames:
SUSE-SUSE-MicroOS-5.2-2024-1633
SUSE Linux Enterprise Micro 5.3
  • libopenssl-1_1-devel >= 1.1.1l-150400.7.66.2
  • libopenssl1_1 >= 1.1.1l-150400.7.66.2
  • libopenssl1_1-hmac >= 1.1.1l-150400.7.66.2
  • libopenssl3 >= 3.0.8-150400.4.54.1
  • openssl-1_1 >= 1.1.1l-150400.7.66.2
Patchnames:
SUSE-SLE-Micro-5.3-2024-1947
SUSE-SLE-Micro-5.3-2024-1949
SUSE Linux Enterprise Micro 5.4
  • libopenssl-1_1-devel >= 1.1.1l-150400.7.66.2
  • libopenssl1_1 >= 1.1.1l-150400.7.66.2
  • libopenssl1_1-hmac >= 1.1.1l-150400.7.66.2
  • libopenssl3 >= 3.0.8-150400.4.54.1
  • openssl-1_1 >= 1.1.1l-150400.7.66.2
Patchnames:
SUSE-SLE-Micro-5.4-2024-1947
SUSE-SLE-Micro-5.4-2024-1949
SUSE Linux Enterprise Micro 5.5
  • libopenssl-1_1-devel >= 1.1.1l-150500.17.28.2
  • libopenssl1_1 >= 1.1.1l-150500.17.28.2
  • libopenssl1_1-hmac >= 1.1.1l-150500.17.28.2
  • openssl-1_1 >= 1.1.1l-150500.17.28.2
Patchnames:
SUSE-SLE-Micro-5.5-2024-1808
SUSE Linux Enterprise Server 15 SP2-LTSS
  • libopenssl-1_1-devel >= 1.1.1d-150200.11.88.1
  • libopenssl1_1 >= 1.1.1d-150200.11.88.1
  • libopenssl1_1-32bit >= 1.1.1d-150200.11.88.1
  • libopenssl1_1-hmac >= 1.1.1d-150200.11.88.1
  • libopenssl1_1-hmac-32bit >= 1.1.1d-150200.11.88.1
  • openssl-1_1 >= 1.1.1d-150200.11.88.1
Patchnames:
SUSE-SLE-Product-SLES-15-SP2-LTSS-2024-1633
SUSE Linux Enterprise Server 15 SP3-LTSS
  • libopenssl-1_1-devel >= 1.1.1d-150200.11.88.1
  • libopenssl-1_1-devel-32bit >= 1.1.1d-150200.11.88.1
  • libopenssl1_1 >= 1.1.1d-150200.11.88.1
  • libopenssl1_1-32bit >= 1.1.1d-150200.11.88.1
  • libopenssl1_1-hmac >= 1.1.1d-150200.11.88.1
  • libopenssl1_1-hmac-32bit >= 1.1.1d-150200.11.88.1
  • openssl-1_1 >= 1.1.1d-150200.11.88.1
  • openssl-1_1-doc >= 1.1.1d-150200.11.88.1
Patchnames:
SUSE-SLE-Product-SLES-15-SP3-LTSS-2024-1633
SUSE Linux Enterprise Server 15 SP4-LTSS
  • libopenssl-1_1-devel >= 1.1.1l-150400.7.66.2
  • libopenssl-1_1-devel-32bit >= 1.1.1l-150400.7.66.2
  • libopenssl-3-devel >= 3.0.8-150400.4.54.1
  • libopenssl1_1 >= 1.1.1l-150400.7.66.2
  • libopenssl1_1-32bit >= 1.1.1l-150400.7.66.2
  • libopenssl1_1-hmac >= 1.1.1l-150400.7.66.2
  • libopenssl1_1-hmac-32bit >= 1.1.1l-150400.7.66.2
  • libopenssl3 >= 3.0.8-150400.4.54.1
  • openssl-1_1 >= 1.1.1l-150400.7.66.2
  • openssl-3 >= 3.0.8-150400.4.54.1
Patchnames:
SUSE-SLE-Product-SLES-15-SP4-LTSS-2024-1947
SUSE-SLE-Product-SLES-15-SP4-LTSS-2024-1949
SUSE Linux Enterprise Server for SAP Applications 15 SP2
  • libopenssl-1_1-devel >= 1.1.1d-150200.11.88.1
  • libopenssl1_1 >= 1.1.1d-150200.11.88.1
  • libopenssl1_1-32bit >= 1.1.1d-150200.11.88.1
  • libopenssl1_1-hmac >= 1.1.1d-150200.11.88.1
  • libopenssl1_1-hmac-32bit >= 1.1.1d-150200.11.88.1
  • openssl-1_1 >= 1.1.1d-150200.11.88.1
Patchnames:
SUSE-SLE-Product-SLES_SAP-15-SP2-2024-1633
SUSE Linux Enterprise Server for SAP Applications 15 SP3
  • libopenssl-1_1-devel >= 1.1.1d-150200.11.88.1
  • libopenssl-1_1-devel-32bit >= 1.1.1d-150200.11.88.1
  • libopenssl1_1 >= 1.1.1d-150200.11.88.1
  • libopenssl1_1-32bit >= 1.1.1d-150200.11.88.1
  • libopenssl1_1-hmac >= 1.1.1d-150200.11.88.1
  • libopenssl1_1-hmac-32bit >= 1.1.1d-150200.11.88.1
  • openssl-1_1 >= 1.1.1d-150200.11.88.1
  • openssl-1_1-doc >= 1.1.1d-150200.11.88.1
Patchnames:
SUSE-SLE-Product-SLES_SAP-15-SP3-2024-1633
SUSE Linux Enterprise Server for SAP Applications 15 SP4
  • libopenssl-1_1-devel >= 1.1.1l-150400.7.66.2
  • libopenssl-1_1-devel-32bit >= 1.1.1l-150400.7.66.2
  • libopenssl-3-devel >= 3.0.8-150400.4.54.1
  • libopenssl1_1 >= 1.1.1l-150400.7.66.2
  • libopenssl1_1-32bit >= 1.1.1l-150400.7.66.2
  • libopenssl1_1-hmac >= 1.1.1l-150400.7.66.2
  • libopenssl1_1-hmac-32bit >= 1.1.1l-150400.7.66.2
  • libopenssl3 >= 3.0.8-150400.4.54.1
  • openssl-1_1 >= 1.1.1l-150400.7.66.2
  • openssl-3 >= 3.0.8-150400.4.54.1
Patchnames:
SUSE-SLE-Product-SLES_SAP-15-SP4-2024-1947
SUSE-SLE-Product-SLES_SAP-15-SP4-2024-1949
SUSE Manager Proxy 4.3
  • libopenssl-1_1-devel >= 1.1.1l-150400.7.66.2
  • libopenssl-1_1-devel-32bit >= 1.1.1l-150400.7.66.2
  • libopenssl-3-devel >= 3.0.8-150400.4.54.1
  • libopenssl1_1 >= 1.1.1l-150400.7.66.2
  • libopenssl1_1-32bit >= 1.1.1l-150400.7.66.2
  • libopenssl1_1-hmac >= 1.1.1l-150400.7.66.2
  • libopenssl1_1-hmac-32bit >= 1.1.1l-150400.7.66.2
  • libopenssl3 >= 3.0.8-150400.4.54.1
  • openssl-1_1 >= 1.1.1l-150400.7.66.2
  • openssl-3 >= 3.0.8-150400.4.54.1
Patchnames:
SUSE-SLE-Product-SUSE-Manager-Proxy-4.3-2024-1947
SUSE-SLE-Product-SUSE-Manager-Proxy-4.3-2024-1949
SUSE Manager Retail Branch Server 4.3
  • libopenssl-1_1-devel >= 1.1.1l-150400.7.66.2
  • libopenssl-1_1-devel-32bit >= 1.1.1l-150400.7.66.2
  • libopenssl-3-devel >= 3.0.8-150400.4.54.1
  • libopenssl1_1 >= 1.1.1l-150400.7.66.2
  • libopenssl1_1-32bit >= 1.1.1l-150400.7.66.2
  • libopenssl1_1-hmac >= 1.1.1l-150400.7.66.2
  • libopenssl1_1-hmac-32bit >= 1.1.1l-150400.7.66.2
  • libopenssl3 >= 3.0.8-150400.4.54.1
  • openssl-1_1 >= 1.1.1l-150400.7.66.2
  • openssl-3 >= 3.0.8-150400.4.54.1
Patchnames:
SUSE-SLE-Product-SUSE-Manager-Retail-Branch-Server-4.3-2024-1947
SUSE-SLE-Product-SUSE-Manager-Retail-Branch-Server-4.3-2024-1949
SUSE Manager Server 4.3
  • libopenssl-1_1-devel >= 1.1.1l-150400.7.66.2
  • libopenssl-1_1-devel-32bit >= 1.1.1l-150400.7.66.2
  • libopenssl-3-devel >= 3.0.8-150400.4.54.1
  • libopenssl1_1 >= 1.1.1l-150400.7.66.2
  • libopenssl1_1-32bit >= 1.1.1l-150400.7.66.2
  • libopenssl1_1-hmac >= 1.1.1l-150400.7.66.2
  • libopenssl1_1-hmac-32bit >= 1.1.1l-150400.7.66.2
  • libopenssl3 >= 3.0.8-150400.4.54.1
  • openssl-1_1 >= 1.1.1l-150400.7.66.2
  • openssl-3 >= 3.0.8-150400.4.54.1
Patchnames:
SUSE-SLE-Product-SUSE-Manager-Server-4.3-2024-1947
SUSE-SLE-Product-SUSE-Manager-Server-4.3-2024-1949
openSUSE Leap 15.5
  • libopenssl-1_1-devel >= 1.1.1l-150500.17.28.2
  • libopenssl-1_1-devel-32bit >= 1.1.1l-150500.17.28.2
  • libopenssl-3-devel >= 3.0.8-150500.5.30.1
  • libopenssl-3-devel-32bit >= 3.0.8-150500.5.30.1
  • libopenssl1_1 >= 1.1.1l-150500.17.28.2
  • libopenssl1_1-32bit >= 1.1.1l-150500.17.28.2
  • libopenssl1_1-hmac >= 1.1.1l-150500.17.28.2
  • libopenssl1_1-hmac-32bit >= 1.1.1l-150500.17.28.2
  • libopenssl3 >= 3.0.8-150500.5.30.1
  • libopenssl3-32bit >= 3.0.8-150500.5.30.1
  • openssl-1_1 >= 1.1.1l-150500.17.28.2
  • openssl-1_1-doc >= 1.1.1l-150500.17.28.2
  • openssl-3 >= 3.0.8-150500.5.30.1
  • openssl-3-doc >= 3.0.8-150500.5.30.1
Patchnames:
openSUSE-SLE-15.5-2024-1634
openSUSE-SLE-15.5-2024-1808
openSUSE Leap Micro 5.3
  • libopenssl-1_1-devel >= 1.1.1l-150400.7.66.2
  • libopenssl1_1 >= 1.1.1l-150400.7.66.2
  • libopenssl1_1-hmac >= 1.1.1l-150400.7.66.2
  • libopenssl3 >= 3.0.8-150400.4.54.1
  • openssl-1_1 >= 1.1.1l-150400.7.66.2
Patchnames:
openSUSE-Leap-Micro-5.3-2024-1947
openSUSE-Leap-Micro-5.3-2024-1949
openSUSE Leap Micro 5.4
  • libopenssl-1_1-devel >= 1.1.1l-150400.7.66.2
  • libopenssl1_1 >= 1.1.1l-150400.7.66.2
  • libopenssl1_1-hmac >= 1.1.1l-150400.7.66.2
  • libopenssl3 >= 3.0.8-150400.4.54.1
  • openssl-1_1 >= 1.1.1l-150400.7.66.2
Patchnames:
openSUSE-Leap-Micro-5.4-2024-1947
openSUSE-Leap-Micro-5.4-2024-1949
openSUSE Leap Micro 5.5
  • libopenssl-1_1-devel >= 1.1.1l-150500.17.28.2
  • libopenssl1_1 >= 1.1.1l-150500.17.28.2
  • libopenssl1_1-hmac >= 1.1.1l-150500.17.28.2
  • openssl-1_1 >= 1.1.1l-150500.17.28.2
Patchnames:
openSUSE-Leap-Micro-5.5-2024-1808
openSUSE Tumbleweed
  • libopenssl-1_1-devel >= 1.1.1w-9.1
  • libopenssl-1_1-devel-32bit >= 1.1.1w-9.1
  • libopenssl-3-devel >= 3.1.4-6.1
  • libopenssl-3-devel-32bit >= 3.1.4-6.1
  • libopenssl-3-fips-provider >= 3.1.4-6.1
  • libopenssl-3-fips-provider-32bit >= 3.1.4-6.1
  • libopenssl-3-fips-provider-x86-64-v3 >= 3.1.4-6.1
  • libopenssl1_1 >= 1.1.1w-9.1
  • libopenssl1_1-32bit >= 1.1.1w-9.1
  • libopenssl3 >= 3.1.4-6.1
  • libopenssl3-32bit >= 3.1.4-6.1
  • libopenssl3-x86-64-v3 >= 3.1.4-6.1
  • openssl-1_1 >= 1.1.1w-9.1
  • openssl-1_1-doc >= 1.1.1w-9.1
  • openssl-3 >= 3.1.4-6.1
  • openssl-3-doc >= 3.1.4-6.1
Patchnames:
openSUSE-Tumbleweed-2024-13937
openSUSE-Tumbleweed-2024-13942


First public cloud image revisions this CVE is fixed in:


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification. The updates are grouped by state of their lifecycle. SUSE product lifecycles are documented on the lifecycle page.

Product(s) Source package State
Products under general support and receiving all security fixes.
SLES15-SP5-CHOST-BYOS-Aliyun openssl-1_1 Released
SLES15-SP5-CHOST-BYOS-Azure openssl Not affected
SLES15-SP5-CHOST-BYOS-Azure openssl-1_1 Released
SLES15-SP5-CHOST-BYOS-EC2 openssl Not affected
SLES15-SP5-CHOST-BYOS-EC2 openssl-1_1 Released
SLES15-SP5-CHOST-BYOS-GCE openssl Not affected
SLES15-SP5-CHOST-BYOS-GCE openssl-1_1 Released
SLES15-SP5-CHOST-BYOS-SAP-CCloud openssl Not affected
SLES15-SP5-CHOST-BYOS-SAP-CCloud openssl-1_1 Released
SUSE Enterprise Storage 7.1 openssl Not affected
SUSE Enterprise Storage 7.1 openssl-1_0_0 Not affected
SUSE Enterprise Storage 7.1 openssl-1_1 Released
SUSE Linux Enterprise Desktop 15 SP5 openssl Not affected
SUSE Linux Enterprise Desktop 15 SP5 openssl-1_1 Released
SUSE Linux Enterprise Desktop 15 SP5 openssl-3 Released
SUSE Linux Enterprise Desktop 15 SP6 openssl Not affected
SUSE Linux Enterprise Desktop 15 SP6 openssl-1_1 Already fixed
SUSE Linux Enterprise Desktop 15 SP6 openssl-3 Already fixed
SUSE Linux Enterprise High Performance Computing 12 compat-openssl098 Not affected
SUSE Linux Enterprise High Performance Computing 12 SP5 openssl Not affected
SUSE Linux Enterprise High Performance Computing 12 SP5 openssl-1_0_0 Not affected
SUSE Linux Enterprise High Performance Computing 12 SP5 openssl-1_1 Affected
SUSE Linux Enterprise High Performance Computing 15 SP5 openssl Not affected
SUSE Linux Enterprise High Performance Computing 15 SP5 openssl-1_0_0 Not affected
SUSE Linux Enterprise High Performance Computing 15 SP5 openssl-1_1 Released
SUSE Linux Enterprise High Performance Computing 15 SP5 openssl-3 Released
SUSE Linux Enterprise High Performance Computing 15 SP6 openssl Not affected
SUSE Linux Enterprise High Performance Computing 15 SP6 openssl-1_0_0 Not affected
SUSE Linux Enterprise High Performance Computing 15 SP6 openssl-1_1 Already fixed
SUSE Linux Enterprise High Performance Computing 15 SP6 openssl-3 Already fixed
SUSE Linux Enterprise Live Patching 15 SP5 openssl-1_1-livepatches Not affected
SUSE Linux Enterprise Live Patching 15 SP6 openssl-1_1-livepatches Not affected
SUSE Linux Enterprise Micro 5.1 openssl Not affected
SUSE Linux Enterprise Micro 5.1 openssl-1_1 Released
SUSE Linux Enterprise Micro 5.2 openssl Not affected
SUSE Linux Enterprise Micro 5.2 openssl-1_1 Released
SUSE Linux Enterprise Micro 5.3 openssl Not affected
SUSE Linux Enterprise Micro 5.3 openssl-1_1 Released
SUSE Linux Enterprise Micro 5.3 openssl-3 Released
SUSE Linux Enterprise Micro 5.4 openssl Not affected
SUSE Linux Enterprise Micro 5.4 openssl-1_1 Released
SUSE Linux Enterprise Micro 5.4 openssl-3 Released
SUSE Linux Enterprise Micro 5.5 openssl Not affected
SUSE Linux Enterprise Micro 5.5 openssl-1_1 Released
SUSE Linux Enterprise Micro 6.0 openssl Not affected
SUSE Linux Enterprise Micro 6.0 openssl-3 Affected
SUSE Linux Enterprise Micro for Rancher 5.2 openssl-1_1 Released
SUSE Linux Enterprise Micro for Rancher 5.3 openssl-1_1 Released
SUSE Linux Enterprise Micro for Rancher 5.3 openssl-3 Released
SUSE Linux Enterprise Micro for Rancher 5.4 openssl-1_1 Released
SUSE Linux Enterprise Micro for Rancher 5.4 openssl-3 Released
SUSE Linux Enterprise Module for Basesystem 15 SP5 openssl Not affected
SUSE Linux Enterprise Module for Basesystem 15 SP5 openssl-1_1 Released
SUSE Linux Enterprise Module for Basesystem 15 SP5 openssl-3 Released
SUSE Linux Enterprise Module for Basesystem 15 SP6 openssl Not affected
SUSE Linux Enterprise Module for Basesystem 15 SP6 openssl-1_1 Already fixed
SUSE Linux Enterprise Module for Basesystem 15 SP6 openssl-3 Already fixed
SUSE Linux Enterprise Module for Development Tools 15 SP6 openssl-1_1 Already fixed
SUSE Linux Enterprise Module for Legacy 12 compat-openssl098 Not affected
SUSE Linux Enterprise Module for Legacy 15 SP5 openssl-1_0_0 Not affected
SUSE Linux Enterprise Module for Legacy 15 SP6 openssl-1_0_0 Not affected
SUSE Linux Enterprise Module for Legacy 15 SP6 openssl-1_1 Already fixed
SUSE Linux Enterprise Server 12 SP5 compat-openssl098 Not affected
SUSE Linux Enterprise Server 12 SP5 openssl Not affected
SUSE Linux Enterprise Server 12 SP5 openssl-1_0_0 Not affected
SUSE Linux Enterprise Server 12 SP5 openssl-1_1 Affected
SUSE Linux Enterprise Server 15 SP5 openssl Not affected
SUSE Linux Enterprise Server 15 SP5 openssl-1_0_0 Not affected
SUSE Linux Enterprise Server 15 SP5 openssl-1_1 Released
SUSE Linux Enterprise Server 15 SP5 openssl-3 Released
SUSE Linux Enterprise Server 15 SP6 openssl Not affected
SUSE Linux Enterprise Server 15 SP6 openssl-1_0_0 Not affected
SUSE Linux Enterprise Server 15 SP6 openssl-1_1 Already fixed
SUSE Linux Enterprise Server 15 SP6 openssl-3 Already fixed
SUSE Linux Enterprise Server for SAP Applications 12 SP5 compat-openssl098 Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP5 openssl Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP5 openssl-1_0_0 Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP5 openssl-1_1 Affected
SUSE Linux Enterprise Server for SAP Applications 15 SP5 openssl Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP5 openssl-1_0_0 Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP5 openssl-1_1 Released
SUSE Linux Enterprise Server for SAP Applications 15 SP5 openssl-3 Released
SUSE Linux Enterprise Server for SAP Applications 15 SP6 openssl Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP6 openssl-1_0_0 Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP6 openssl-1_1 Already fixed
SUSE Linux Enterprise Server for SAP Applications 15 SP6 openssl-3 Already fixed
SUSE Linux Enterprise Software Development Kit 12 SP5 openssl Not affected
SUSE Linux Enterprise Software Development Kit 12 SP5 openssl-1_0_0 Not affected
SUSE Linux Enterprise Software Development Kit 12 SP5 openssl-1_1 Affected
SUSE Manager Proxy 4.3 openssl Not affected
SUSE Manager Proxy 4.3 openssl-1_0_0 Not affected
SUSE Manager Proxy 4.3 openssl-1_1 Released
SUSE Manager Proxy 4.3 openssl-3 Released
SUSE Manager Retail Branch Server 4.3 openssl Not affected
SUSE Manager Retail Branch Server 4.3 openssl-1_0_0 Not affected
SUSE Manager Retail Branch Server 4.3 openssl-1_1 Released
SUSE Manager Retail Branch Server 4.3 openssl-3 Released
SUSE Manager Server 4.3 openssl Not affected
SUSE Manager Server 4.3 openssl-1_0_0 Not affected
SUSE Manager Server 4.3 openssl-1_1 Released
SUSE Manager Server 4.3 openssl-3 Released
openSUSE Leap 15.5 openssl Not affected
openSUSE Leap 15.5 openssl-1_0_0 Not affected
openSUSE Leap 15.5 openssl-1_1 Released
openSUSE Leap 15.5 openssl-3 Released
openSUSE Leap 15.6 openssl Not affected
openSUSE Leap 15.6 openssl-1_0_0 Not affected
openSUSE Leap 15.6 openssl-1_1 Already fixed
openSUSE Leap 15.6 openssl-3 Already fixed
openSUSE Leap Micro 5.5 openssl Not affected
openSUSE Leap Micro 5.5 openssl-1_1 Affected
Products under Long Term Service Pack support and receiving important and critical security fixes.
SLES15-EC2-CHOST-HVM-BYOS openssl Not affected
SLES15-EC2-CHOST-HVM-BYOS openssl-1_1 Not affected
SLES15-SP1-CHOST-BYOS-Azure openssl Not affected
SLES15-SP1-CHOST-BYOS-Azure openssl-1_1 Not affected
SLES15-SP1-CHOST-BYOS-EC2 openssl Not affected
SLES15-SP1-CHOST-BYOS-EC2 openssl-1_1 Not affected
SLES15-SP1-CHOST-BYOS-GCE openssl Not affected
SLES15-SP1-CHOST-BYOS-GCE openssl-1_1 Not affected
SLES15-SP2-CHOST-BYOS-Aliyun openssl Not affected
SLES15-SP2-CHOST-BYOS-Aliyun openssl-1_1 In progress
SLES15-SP2-CHOST-BYOS-Azure openssl Not affected
SLES15-SP2-CHOST-BYOS-Azure openssl-1_1 In progress
SLES15-SP2-CHOST-BYOS-EC2 openssl Not affected
SLES15-SP2-CHOST-BYOS-EC2 openssl-1_1 In progress
SLES15-SP2-CHOST-BYOS-GCE openssl Not affected
SLES15-SP2-CHOST-BYOS-GCE openssl-1_1 In progress
SLES15-SP3-CHOST-BYOS-Aliyun openssl-1_1 In progress
SLES15-SP3-CHOST-BYOS-Azure openssl Not affected
SLES15-SP3-CHOST-BYOS-Azure openssl-1_1 In progress
SLES15-SP3-CHOST-BYOS-EC2 openssl Not affected
SLES15-SP3-CHOST-BYOS-EC2 openssl-1_1 In progress
SLES15-SP3-CHOST-BYOS-GCE openssl Not affected
SLES15-SP3-CHOST-BYOS-GCE openssl-1_1 In progress
SLES15-SP3-CHOST-BYOS-SAP-CCloud openssl Not affected
SLES15-SP3-CHOST-BYOS-SAP-CCloud openssl-1_1 In progress
SLES15-SP4-CHOST-BYOS openssl Not affected
SLES15-SP4-CHOST-BYOS openssl-1_1 Released
SLES15-SP4-CHOST-BYOS-Aliyun openssl-1_1 Released
SLES15-SP4-CHOST-BYOS-Azure openssl Not affected
SLES15-SP4-CHOST-BYOS-Azure openssl-1_1 Released
SLES15-SP4-CHOST-BYOS-EC2 openssl Not affected
SLES15-SP4-CHOST-BYOS-EC2 openssl-1_1 Released
SLES15-SP4-CHOST-BYOS-GCE openssl Not affected
SLES15-SP4-CHOST-BYOS-GCE openssl-1_1 Released
SLES15-SP4-CHOST-BYOS-SAP-CCloud openssl Not affected
SLES15-SP4-CHOST-BYOS-SAP-CCloud openssl-1_1 Released
SUSE Linux Enterprise Desktop 15 SP4 openssl Not affected
SUSE Linux Enterprise Desktop 15 SP4 openssl-1_1 Affected
SUSE Linux Enterprise Desktop 15 SP4 openssl-3 Affected
SUSE Linux Enterprise Desktop 15 SP4 LTSS openssl-1_1 Released
SUSE Linux Enterprise Desktop 15 SP4 LTSS openssl-3 Released
SUSE Linux Enterprise High Performance Computing 15 SP2 openssl Not affected
SUSE Linux Enterprise High Performance Computing 15 SP2 openssl-1_0_0 Not affected
SUSE Linux Enterprise High Performance Computing 15 SP2 openssl-1_1 Affected
SUSE Linux Enterprise High Performance Computing 15 SP2-ESPOS openssl Not affected
SUSE Linux Enterprise High Performance Computing 15 SP2-ESPOS openssl-1_1 Affected
SUSE Linux Enterprise High Performance Computing 15 SP2-LTSS openssl Not affected
SUSE Linux Enterprise High Performance Computing 15 SP2-LTSS openssl-1_1 Released
SUSE Linux Enterprise High Performance Computing 15 SP3 openssl Not affected
SUSE Linux Enterprise High Performance Computing 15 SP3 openssl-1_0_0 Not affected
SUSE Linux Enterprise High Performance Computing 15 SP3 openssl-1_1 Affected
SUSE Linux Enterprise High Performance Computing 15 SP3-ESPOS openssl Not affected
SUSE Linux Enterprise High Performance Computing 15 SP3-ESPOS openssl-1_0_0 Not affected
SUSE Linux Enterprise High Performance Computing 15 SP3-ESPOS openssl-1_1 Affected
SUSE Linux Enterprise High Performance Computing 15 SP3-LTSS openssl Not affected
SUSE Linux Enterprise High Performance Computing 15 SP3-LTSS openssl-1_0_0 Not affected
SUSE Linux Enterprise High Performance Computing 15 SP3-LTSS openssl-1_1 Released
SUSE Linux Enterprise High Performance Computing 15 SP4 openssl Not affected
SUSE Linux Enterprise High Performance Computing 15 SP4 openssl-1_0_0 Not affected
SUSE Linux Enterprise High Performance Computing 15 SP4 openssl-1_1 Affected
SUSE Linux Enterprise High Performance Computing 15 SP4 openssl-3 Affected
SUSE Linux Enterprise High Performance Computing 15 SP4-ESPOS openssl Not affected
SUSE Linux Enterprise High Performance Computing 15 SP4-ESPOS openssl-1_0_0 Not affected
SUSE Linux Enterprise High Performance Computing 15 SP4-ESPOS openssl-1_1 Released
SUSE Linux Enterprise High Performance Computing 15 SP4-ESPOS openssl-3 Released
SUSE Linux Enterprise High Performance Computing 15 SP4-LTSS openssl Not affected
SUSE Linux Enterprise High Performance Computing 15 SP4-LTSS openssl-1_0_0 Not affected
SUSE Linux Enterprise High Performance Computing 15 SP4-LTSS openssl-1_1 Released
SUSE Linux Enterprise High Performance Computing 15 SP4-LTSS openssl-3 Released
SUSE Linux Enterprise Live Patching 15 SP4 openssl-1_1-livepatches Not affected
SUSE Linux Enterprise Module for Basesystem 15 SP2 openssl Not affected
SUSE Linux Enterprise Module for Basesystem 15 SP2 openssl-1_1 Affected
SUSE Linux Enterprise Module for Basesystem 15 SP3 openssl Not affected
SUSE Linux Enterprise Module for Basesystem 15 SP3 openssl-1_1 Affected
SUSE Linux Enterprise Module for Basesystem 15 SP4 openssl Not affected
SUSE Linux Enterprise Module for Basesystem 15 SP4 openssl-1_1 Affected
SUSE Linux Enterprise Module for Basesystem 15 SP4 openssl-3 Affected
SUSE Linux Enterprise Module for Certifications 15 SP3 openssl-1_1 Affected
SUSE Linux Enterprise Module for Legacy 15 SP2 openssl-1_0_0 Not affected
SUSE Linux Enterprise Module for Legacy 15 SP3 openssl-1_0_0 Not affected
SUSE Linux Enterprise Module for Legacy 15 SP4 openssl-1_0_0 Not affected
SUSE Linux Enterprise Server 11 SP4 LTSS EXTREME CORE openssl Not affected
SUSE Linux Enterprise Server 11 SP4 LTSS EXTREME CORE openssl1 Not affected
SUSE Linux Enterprise Server 15 SP2 openssl Not affected
SUSE Linux Enterprise Server 15 SP2 openssl-1_0_0 Not affected
SUSE Linux Enterprise Server 15 SP2 openssl-1_1 Affected
SUSE Linux Enterprise Server 15 SP2-LTSS openssl Not affected
SUSE Linux Enterprise Server 15 SP2-LTSS openssl-1_0_0 Not affected
SUSE Linux Enterprise Server 15 SP2-LTSS openssl-1_1 Released
SUSE Linux Enterprise Server 15 SP3 openssl Not affected
SUSE Linux Enterprise Server 15 SP3 openssl-1_0_0 Not affected
SUSE Linux Enterprise Server 15 SP3 openssl-1_1 Affected
SUSE Linux Enterprise Server 15 SP3-LTSS openssl Not affected
SUSE Linux Enterprise Server 15 SP3-LTSS openssl-1_0_0 Not affected
SUSE Linux Enterprise Server 15 SP3-LTSS openssl-1_1 Released
SUSE Linux Enterprise Server 15 SP4 openssl Not affected
SUSE Linux Enterprise Server 15 SP4 openssl-1_0_0 Not affected
SUSE Linux Enterprise Server 15 SP4 openssl-1_1 Affected
SUSE Linux Enterprise Server 15 SP4 openssl-3 Affected
SUSE Linux Enterprise Server 15 SP4-LTSS openssl Not affected
SUSE Linux Enterprise Server 15 SP4-LTSS openssl-1_0_0 Not affected
SUSE Linux Enterprise Server 15 SP4-LTSS openssl-1_1 Released
SUSE Linux Enterprise Server 15 SP4-LTSS openssl-3 Released
SUSE Linux Enterprise Server for SAP Applications 15 SP2 openssl Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP2 openssl-1_0_0 Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP2 openssl-1_1 Released
SUSE Linux Enterprise Server for SAP Applications 15 SP3 openssl Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP3 openssl-1_0_0 Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP3 openssl-1_1 Released
SUSE Linux Enterprise Server for SAP Applications 15 SP4 openssl Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP4 openssl-1_0_0 Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP4 openssl-1_1 Released
SUSE Linux Enterprise Server for SAP Applications 15 SP4 openssl-3 Released
Products past their end of life and not receiving proactive updates anymore.
HPE Helion OpenStack 8 openssl Not affected
SUSE CaaS Platform 3.0 openssl Not affected
SUSE CaaS Platform 4.0 openssl Not affected
SUSE CaaS Platform 4.0 openssl-1_0_0 Not affected
SUSE CaaS Platform 4.0 openssl-1_1 Not affected
SUSE Enterprise Storage 6 openssl Not affected
SUSE Enterprise Storage 6 openssl-1_0_0 Not affected
SUSE Enterprise Storage 6 openssl-1_1 Not affected
SUSE Enterprise Storage 7 openssl Not affected
SUSE Enterprise Storage 7 openssl-1_0_0 Not affected
SUSE Enterprise Storage 7 openssl-1_1 Affected
SUSE Linux Enterprise Desktop 11 SP2 openssl Not affected
SUSE Linux Enterprise Desktop 11 SP3 openssl Not affected
SUSE Linux Enterprise Desktop 11 SP4 openssl Not affected
SUSE Linux Enterprise Desktop 12 compat-openssl098 Not affected
SUSE Linux Enterprise Desktop 12 SP1 compat-openssl098 Not affected
SUSE Linux Enterprise Desktop 12 SP2 compat-openssl098 Not affected
SUSE Linux Enterprise Desktop 12 SP2 openssl Not affected
SUSE Linux Enterprise Desktop 12 SP3 compat-openssl098 Not affected
SUSE Linux Enterprise Desktop 12 SP3 openssl Not affected
SUSE Linux Enterprise Desktop 12 SP4 compat-openssl098 Not affected
SUSE Linux Enterprise Desktop 12 SP4 openssl Not affected
SUSE Linux Enterprise Desktop 12 SP4 openssl-1_0_0 Not affected
SUSE Linux Enterprise Desktop 12 SP4 openssl-1_1 Affected
SUSE Linux Enterprise Desktop 15 openssl Not affected
SUSE Linux Enterprise Desktop 15 openssl-1_1 Not affected
SUSE Linux Enterprise Desktop 15 SP1 openssl Not affected
SUSE Linux Enterprise Desktop 15 SP1 openssl-1_1 Not affected
SUSE Linux Enterprise Desktop 15 SP2 openssl Not affected
SUSE Linux Enterprise Desktop 15 SP2 openssl-1_1 Affected
SUSE Linux Enterprise Desktop 15 SP3 openssl Not affected
SUSE Linux Enterprise Desktop 15 SP3 openssl-1_1 Affected
SUSE Linux Enterprise High Performance Computing 15 openssl Not affected
SUSE Linux Enterprise High Performance Computing 15 openssl-1_0_0 Not affected
SUSE Linux Enterprise High Performance Computing 15 openssl-1_1 Not affected
SUSE Linux Enterprise High Performance Computing 15 SP1 openssl Not affected
SUSE Linux Enterprise High Performance Computing 15 SP1 openssl-1_0_0 Not affected
SUSE Linux Enterprise High Performance Computing 15 SP1 openssl-1_1 Not affected
SUSE Linux Enterprise High Performance Computing 15 SP1-ESPOS openssl Not affected
SUSE Linux Enterprise High Performance Computing 15 SP1-ESPOS openssl-1_1 Not affected
SUSE Linux Enterprise High Performance Computing 15 SP1-LTSS openssl Not affected
SUSE Linux Enterprise High Performance Computing 15 SP1-LTSS openssl-1_1 Not affected
SUSE Linux Enterprise High Performance Computing 15-ESPOS openssl Not affected
SUSE Linux Enterprise High Performance Computing 15-ESPOS openssl-1_1 Not affected
SUSE Linux Enterprise High Performance Computing 15-LTSS openssl Not affected
SUSE Linux Enterprise High Performance Computing 15-LTSS openssl-1_1 Not affected
SUSE Linux Enterprise Micro 5.0 openssl Not affected
SUSE Linux Enterprise Micro 5.0 openssl-1_1 Affected
SUSE Linux Enterprise Module for Basesystem 15 openssl Not affected
SUSE Linux Enterprise Module for Basesystem 15 openssl-1_1 Not affected
SUSE Linux Enterprise Module for Basesystem 15 SP1 openssl Not affected
SUSE Linux Enterprise Module for Basesystem 15 SP1 openssl-1_1 Not affected
SUSE Linux Enterprise Module for Legacy 15 openssl-1_0_0 Not affected
SUSE Linux Enterprise Module for Legacy 15 SP1 openssl-1_0_0 Not affected
SUSE Linux Enterprise Point of Sale 11 SP3 openssl Not affected
SUSE Linux Enterprise Point of Sale 12 SP2-CLIENT openssl Not affected
SUSE Linux Enterprise Real Time 15 SP2 openssl Not affected
SUSE Linux Enterprise Real Time 15 SP2 openssl-1_1 Affected
SUSE Linux Enterprise Real Time 15 SP3 openssl Not affected
SUSE Linux Enterprise Real Time 15 SP3 openssl-1_1 Affected
SUSE Linux Enterprise Real Time 15 SP4 openssl Not affected
SUSE Linux Enterprise Real Time 15 SP4 openssl-1_1 Affected
SUSE Linux Enterprise Real Time 15 SP4 openssl-3 Affected
SUSE Linux Enterprise Server 11 SP1-LTSS openssl Not affected
SUSE Linux Enterprise Server 11 SP2 openssl Not affected
SUSE Linux Enterprise Server 11 SP2-LTSS openssl Not affected
SUSE Linux Enterprise Server 11 SP3 openssl Not affected
SUSE Linux Enterprise Server 11 SP3-LTSS openssl Not affected
SUSE Linux Enterprise Server 11 SP4 openssl Not affected
SUSE Linux Enterprise Server 11 SP4 LTSS openssl Not affected
SUSE Linux Enterprise Server 11 SP4-LTSS openssl Not affected
SUSE Linux Enterprise Server 11-SECURITY openssl1 Not affected
SUSE Linux Enterprise Server 12 compat-openssl098 Not affected
SUSE Linux Enterprise Server 12 SP2 openssl Not affected
SUSE Linux Enterprise Server 12 SP2-BCL openssl Not affected
SUSE Linux Enterprise Server 12 SP2-ESPOS openssl Not affected
SUSE Linux Enterprise Server 12 SP2-LTSS openssl Not affected
SUSE Linux Enterprise Server 12 SP3 compat-openssl098 Not affected
SUSE Linux Enterprise Server 12 SP3 openssl Not affected
SUSE Linux Enterprise Server 12 SP3-BCL openssl Not affected
SUSE Linux Enterprise Server 12 SP3-ESPOS openssl Not affected
SUSE Linux Enterprise Server 12 SP3-LTSS openssl Not affected
SUSE Linux Enterprise Server 12 SP4 compat-openssl098 Not affected
SUSE Linux Enterprise Server 12 SP4 openssl Not affected
SUSE Linux Enterprise Server 12 SP4 openssl-1_0_0 Not affected
SUSE Linux Enterprise Server 12 SP4 openssl-1_1 Affected
SUSE Linux Enterprise Server 12 SP4-ESPOS openssl Not affected
SUSE Linux Enterprise Server 12 SP4-ESPOS openssl-1_0_0 Not affected
SUSE Linux Enterprise Server 12 SP4-ESPOS openssl-1_1 Affected
SUSE Linux Enterprise Server 12 SP4-LTSS openssl Not affected
SUSE Linux Enterprise Server 12 SP4-LTSS openssl-1_0_0 Not affected
SUSE Linux Enterprise Server 12 SP4-LTSS openssl-1_1 Affected
SUSE Linux Enterprise Server 15 openssl Not affected
SUSE Linux Enterprise Server 15 openssl-1_0_0 Not affected
SUSE Linux Enterprise Server 15 openssl-1_1 Not affected
SUSE Linux Enterprise Server 15 SP1 openssl Not affected
SUSE Linux Enterprise Server 15 SP1 openssl-1_0_0 Not affected
SUSE Linux Enterprise Server 15 SP1 openssl-1_1 Not affected
SUSE Linux Enterprise Server 15 SP1-BCL openssl Not affected
SUSE Linux Enterprise Server 15 SP1-BCL openssl-1_0_0 Not affected
SUSE Linux Enterprise Server 15 SP1-BCL openssl-1_1 Not affected
SUSE Linux Enterprise Server 15 SP1-LTSS openssl Not affected
SUSE Linux Enterprise Server 15 SP1-LTSS openssl-1_0_0 Not affected
SUSE Linux Enterprise Server 15 SP1-LTSS openssl-1_1 Not affected
SUSE Linux Enterprise Server 15 SP2-BCL openssl Not affected
SUSE Linux Enterprise Server 15 SP2-BCL openssl-1_1 Affected
SUSE Linux Enterprise Server 15 SP3-BCL openssl Not affected
SUSE Linux Enterprise Server 15 SP3-BCL openssl-1_1 Affected
SUSE Linux Enterprise Server 15-LTSS openssl Not affected
SUSE Linux Enterprise Server 15-LTSS openssl-1_0_0 Not affected
SUSE Linux Enterprise Server 15-LTSS openssl-1_1 Not affected
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2 openssl Not affected
SUSE Linux Enterprise Server for SAP Applications 11 SP2 openssl Not affected
SUSE Linux Enterprise Server for SAP Applications 11 SP3 openssl Not affected
SUSE Linux Enterprise Server for SAP Applications 11 SP4 openssl Not affected
SUSE Linux Enterprise Server for SAP Applications 12 compat-openssl098 Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP1 compat-openssl098 Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP2 compat-openssl098 Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP2 openssl Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP3 compat-openssl098 Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP3 openssl Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP4 compat-openssl098 Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP4 openssl Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP4 openssl-1_0_0 Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP4 openssl-1_1 Affected
SUSE Linux Enterprise Server for SAP Applications 15 openssl Not affected
SUSE Linux Enterprise Server for SAP Applications 15 openssl-1_0_0 Not affected
SUSE Linux Enterprise Server for SAP Applications 15 openssl-1_1 Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP1 openssl Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP1 openssl-1_0_0 Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP1 openssl-1_1 Not affected
SUSE Linux Enterprise Software Development Kit 11 SP2 openssl Not affected
SUSE Linux Enterprise Software Development Kit 11 SP3 openssl Not affected
SUSE Linux Enterprise Software Development Kit 11 SP4 openssl Not affected
SUSE Linux Enterprise Software Development Kit 12 SP2 openssl Not affected
SUSE Linux Enterprise Software Development Kit 12 SP3 openssl Not affected
SUSE Linux Enterprise Software Development Kit 12 SP4 openssl Not affected
SUSE Linux Enterprise Software Development Kit 12 SP4 openssl-1_0_0 Not affected
SUSE Linux Enterprise Software Development Kit 12 SP4 openssl-1_1 Affected
SUSE Manager Proxy 4.0 openssl Not affected
SUSE Manager Proxy 4.0 openssl-1_0_0 Not affected
SUSE Manager Proxy 4.0 openssl-1_1 Not affected
SUSE Manager Proxy 4.1 openssl Not affected
SUSE Manager Proxy 4.1 openssl-1_0_0 Not affected
SUSE Manager Proxy 4.1 openssl-1_1 Affected
SUSE Manager Proxy 4.2 openssl Not affected
SUSE Manager Proxy 4.2 openssl-1_0_0 Not affected
SUSE Manager Proxy 4.2 openssl-1_1 Affected
SUSE Manager Retail Branch Server 4.0 openssl Not affected
SUSE Manager Retail Branch Server 4.0 openssl-1_0_0 Not affected
SUSE Manager Retail Branch Server 4.0 openssl-1_1 Not affected
SUSE Manager Retail Branch Server 4.1 openssl Not affected
SUSE Manager Retail Branch Server 4.1 openssl-1_0_0 Not affected
SUSE Manager Retail Branch Server 4.1 openssl-1_1 Affected
SUSE Manager Retail Branch Server 4.2 openssl Not affected
SUSE Manager Retail Branch Server 4.2 openssl-1_0_0 Not affected
SUSE Manager Retail Branch Server 4.2 openssl-1_1 Affected
SUSE Manager Server 4.0 openssl Not affected
SUSE Manager Server 4.0 openssl-1_0_0 Not affected
SUSE Manager Server 4.0 openssl-1_1 Not affected
SUSE Manager Server 4.1 openssl Not affected
SUSE Manager Server 4.1 openssl-1_0_0 Not affected
SUSE Manager Server 4.1 openssl-1_1 Affected
SUSE Manager Server 4.2 openssl Not affected
SUSE Manager Server 4.2 openssl-1_0_0 Not affected
SUSE Manager Server 4.2 openssl-1_1 Affected
SUSE OpenStack Cloud 7 openssl Not affected
SUSE OpenStack Cloud 8 openssl Not affected
SUSE OpenStack Cloud 9 openssl Not affected
SUSE OpenStack Cloud 9 openssl-1_0_0 Not affected
SUSE OpenStack Cloud 9 openssl-1_1 Affected
SUSE OpenStack Cloud Crowbar 8 openssl Not affected
SUSE OpenStack Cloud Crowbar 9 openssl Not affected
SUSE OpenStack Cloud Crowbar 9 openssl-1_0_0 Not affected
SUSE OpenStack Cloud Crowbar 9 openssl-1_1 Affected
SUSE Studio Onsite 1.3 openssl Not affected
openSUSE Leap 15.3 openssl Not affected
openSUSE Leap 15.3 openssl-1_0_0 Not affected
openSUSE Leap 15.3 openssl-1_1 Affected
openSUSE Leap 15.4 openssl Not affected
openSUSE Leap 15.4 openssl-1_0_0 Not affected
openSUSE Leap 15.4 openssl-1_1 Released
openSUSE Leap 15.4 openssl-3 Released
openSUSE Leap Micro 5.2 openssl Not affected
openSUSE Leap Micro 5.2 openssl-1_1 Affected
openSUSE Leap Micro 5.3 openssl Not affected
openSUSE Leap Micro 5.3 openssl-1_1 Released
openSUSE Leap Micro 5.3 openssl-3 Released
openSUSE Leap Micro 5.4 openssl Not affected
openSUSE Leap Micro 5.4 openssl-1_1 Released
openSUSE Leap Micro 5.4 openssl-3 Released
Products at an unknown state of their lifecycle.
SLES15-SP6-CHOST-BYOS openssl Not affected
SLES15-SP6-CHOST-BYOS openssl-3 Already fixed
SLES15-SP6-CHOST-BYOS-Aliyun openssl Not affected
SLES15-SP6-CHOST-BYOS-Aliyun openssl-3 Already fixed
SLES15-SP6-CHOST-BYOS-Azure openssl Not affected
SLES15-SP6-CHOST-BYOS-Azure openssl-3 Already fixed
SLES15-SP6-CHOST-BYOS-EC2 openssl Not affected
SLES15-SP6-CHOST-BYOS-EC2 openssl-3 Already fixed
SLES15-SP6-CHOST-BYOS-GCE openssl Not affected
SLES15-SP6-CHOST-BYOS-GCE openssl-3 Already fixed
Container Status
suse/sles12sp4
suse/sles12sp5
openssl-1_0_0Not affected
ses/6/cephcsi/cephcsi
ses/6/rook/ceph
suse/sle15:15.0
suse/sle15:15.1
openssl-1_1Not affected
bci/bci-sle15-kernel-module-devel:15.5
bci/golang
bci/golang:1.20-openssl
bci/openjdk-devel:11
bci/openjdk-devel:17
bci/openjdk:11
bci/openjdk:17
bci/python
bci/python:3
rancher/elemental-operator
rancher/seedimage-builder
suse/389-ds
suse/helm
suse/ltss/sle15.3/sle15:15.3
suse/ltss/sle15.4/sle15:15.4
suse/manager/4.3/proxy-salt-broker
suse/manager/4.3/proxy-tftpd
suse/registry
suse/sle-micro-rancher/5.2
suse/sle-micro-rancher/5.3
suse/sle-micro-rancher/5.4
suse/sle-micro/5.1/toolbox
suse/sle-micro/5.2/toolbox
suse/sle-micro/5.3/toolbox
suse/sle-micro/5.4/toolbox
suse/sle-micro/5.5
suse/sle-micro/5.5/toolbox
suse/sle-micro/base-5.5
suse/sle15:15.2
suse/sle15:15.5
openssl-1_1Released
bci/bci-init:15.3
bci/golang:1.16
bci/golang:1.17
bci/node:12
bci/node:14
bci/nodejs
bci/openjdk
bci/openjdk-devel
bci/ruby
rancher/seedimage-builder/5.3
ses/7.1/ceph/grafana
ses/7.1/ceph/haproxy
ses/7.1/ceph/keepalived
ses/7.1/ceph/prometheus-alertmanager
ses/7.1/ceph/prometheus-node-exporter
ses/7.1/ceph/prometheus-server
ses/7.1/ceph/prometheus-snmp_notifier
ses/7.1/cephcsi/cephcsi
ses/7.1/cephcsi/csi-attacher:v4.1.0
ses/7.1/cephcsi/csi-node-driver-registrar:v2.7.0
ses/7.1/cephcsi/csi-provisioner:v3.4.0
ses/7.1/cephcsi/csi-resizer:v1.7.0
ses/7.1/cephcsi/csi-snapshotter:v6.2.1
ses/7.1/rook/ceph
ses/7/ceph/ceph
ses/7/ceph/grafana
ses/7/ceph/prometheus-alertmanager
ses/7/ceph/prometheus-node-exporter
ses/7/ceph/prometheus-server
ses/7/cephcsi/cephcsi
ses/7/cephcsi/csi-attacher:v2.1.0
ses/7/cephcsi/csi-attacher:v3.3.0
ses/7/cephcsi/csi-livenessprobe:v1.1.0
ses/7/cephcsi/csi-node-driver-registrar:v1.2.0
ses/7/cephcsi/csi-node-driver-registrar:v2.3.0
ses/7/cephcsi/csi-provisioner:v1.6.0
ses/7/cephcsi/csi-provisioner:v3.0.0
ses/7/cephcsi/csi-resizer:v0.4.0
ses/7/cephcsi/csi-resizer:v1.3.0
ses/7/cephcsi/csi-snapshotter:v2.1.1
ses/7/cephcsi/csi-snapshotter:v4.2.0
ses/7/prometheus-webhook-snmp
ses/7/rook/ceph
suse/hpc/warewulf4-x86_64/sle-hpc-node
suse/sle-micro/5.0/toolbox
suse/sle15:15.3
suse/sle15:15.4
trento/trento-runner
openssl-1_1In progress
bci/bci-sle15-kernel-module-devel
bci/golang
bci/golang:1.20-openssl
bci/openjdk
bci/openjdk-devel
bci/python
bci/python:3
bci/spack
suse/389-ds
suse/helm
suse/hpc/warewulf4-x86_64/sle-hpc-node
suse/manager/5.0/x86_64/proxy-salt-broker
suse/manager/5.0/x86_64/proxy-tftpd
suse/manager/5.0/x86_64/server
suse/manager/5.0/x86_64/server-attestation
suse/registry
suse/sle15:15.6
openssl-3Already fixed
bci/bci-sle15-kernel-module-devel
bci/bci-sle15-kernel-module-devel:15.5
bci/golang
bci/golang:1.20-openssl
bci/openjdk
bci/openjdk-devel
bci/python
bci/python:3
bci/spack
ses/6/cephcsi/cephcsi
ses/6/rook/ceph
ses/7/ceph/ceph
ses/7/ceph/grafana
ses/7/ceph/prometheus-alertmanager
ses/7/ceph/prometheus-node-exporter
ses/7/ceph/prometheus-server
ses/7/cephcsi/cephcsi
ses/7/cephcsi/csi-attacher:v2.1.0
ses/7/cephcsi/csi-attacher:v3.3.0
ses/7/cephcsi/csi-livenessprobe:v1.1.0
ses/7/cephcsi/csi-node-driver-registrar:v1.2.0
ses/7/cephcsi/csi-node-driver-registrar:v2.3.0
ses/7/cephcsi/csi-provisioner:v1.6.0
ses/7/cephcsi/csi-provisioner:v3.0.0
ses/7/cephcsi/csi-resizer:v0.4.0
ses/7/cephcsi/csi-resizer:v1.3.0
ses/7/cephcsi/csi-snapshotter:v2.1.1
ses/7/cephcsi/csi-snapshotter:v4.2.0
ses/7/prometheus-webhook-snmp
ses/7/rook/ceph
suse/389-ds
suse/helm
suse/hpc/warewulf4-x86_64/sle-hpc-node
suse/manager/5.0/x86_64/proxy-salt-broker
suse/manager/5.0/x86_64/proxy-tftpd
suse/manager/5.0/x86_64/server
suse/manager/5.0/x86_64/server-attestation
suse/registry
suse/sle-micro-rancher/5.2
suse/sle-micro-rancher/5.3
suse/sle-micro-rancher/5.4
suse/sle-micro/5.0/toolbox
suse/sle-micro/5.5
suse/sle15:15.0
suse/sle15:15.1
suse/sle15:15.2
suse/sle15:15.6
suse/sles12sp3
suse/sles12sp4
suse/sles12sp5
opensslNot affected


SUSE Timeline for this CVE

CVE page created: Mon Apr 8 17:00:01 2024
CVE page last modified: Tue Jul 23 11:56:12 2024