Upstream information

CVE-2024-0444 at MITRE

Description

GStreamer AV1 Video Parsing Stack-based Buffer Overflow Remote Code Execution Vulnerability. This vulnerability allows remote attackers to execute arbitrary code on affected installations of GStreamer. Interaction with this library is required to exploit this vulnerability but attack vectors may vary depending on the implementation. The specific flaw exists within the parsing of tile list data within AV1-encoded video files. The issue results from the lack of proper validation of the length of user-supplied data prior to copying it to a fixed-length stack-based buffer. An attacker can leverage this vulnerability to execute code in the context of the current process. Was ZDI-CAN-22873.

Upstream Security Advisories:

SUSE information

Overall state of this security issue: Pending

This issue is currently rated as having important severity.

CVSS v3 Scores
  SUSE
Base Score 8
Vector CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H
Attack Vector Network
Attack Complexity Low
Privileges Required Low
User Interaction Required
Scope Unchanged
Confidentiality Impact High
Integrity Impact High
Availability Impact High
CVSSv3 Version 3.1
SUSE Bugzilla entry: 1219453 [NEW]

No SUSE Security Announcements cross referenced.

List of released packages

Product(s) Fixed package version(s) References
openSUSE Tumbleweed
  • gstreamer-plugins-bad >= 1.22.9-1.1
  • gstreamer-plugins-bad-32bit >= 1.22.9-1.1
  • gstreamer-plugins-bad-chromaprint >= 1.22.9-1.1
  • gstreamer-plugins-bad-chromaprint-32bit >= 1.22.9-1.1
  • gstreamer-plugins-bad-devel >= 1.22.9-1.1
  • gstreamer-plugins-bad-fluidsynth >= 1.22.9-1.1
  • gstreamer-plugins-bad-fluidsynth-32bit >= 1.22.9-1.1
  • gstreamer-plugins-bad-lang >= 1.22.9-1.1
  • gstreamer-transcoder >= 1.22.9-1.1
  • gstreamer-transcoder-devel >= 1.22.9-1.1
  • libgstadaptivedemux-1_0-0 >= 1.22.9-1.1
  • libgstadaptivedemux-1_0-0-32bit >= 1.22.9-1.1
  • libgstbadaudio-1_0-0 >= 1.22.9-1.1
  • libgstbadaudio-1_0-0-32bit >= 1.22.9-1.1
  • libgstbasecamerabinsrc-1_0-0 >= 1.22.9-1.1
  • libgstbasecamerabinsrc-1_0-0-32bit >= 1.22.9-1.1
  • libgstcodecparsers-1_0-0 >= 1.22.9-1.1
  • libgstcodecparsers-1_0-0-32bit >= 1.22.9-1.1
  • libgstcodecs-1_0-0 >= 1.22.9-1.1
  • libgstcodecs-1_0-0-32bit >= 1.22.9-1.1
  • libgstcuda-1_0-0 >= 1.22.9-1.1
  • libgstcuda-1_0-0-32bit >= 1.22.9-1.1
  • libgstinsertbin-1_0-0 >= 1.22.9-1.1
  • libgstinsertbin-1_0-0-32bit >= 1.22.9-1.1
  • libgstisoff-1_0-0 >= 1.22.9-1.1
  • libgstisoff-1_0-0-32bit >= 1.22.9-1.1
  • libgstmpegts-1_0-0 >= 1.22.9-1.1
  • libgstmpegts-1_0-0-32bit >= 1.22.9-1.1
  • libgstphotography-1_0-0 >= 1.22.9-1.1
  • libgstphotography-1_0-0-32bit >= 1.22.9-1.1
  • libgstplay-1_0-0 >= 1.22.9-1.1
  • libgstplay-1_0-0-32bit >= 1.22.9-1.1
  • libgstplayer-1_0-0 >= 1.22.9-1.1
  • libgstplayer-1_0-0-32bit >= 1.22.9-1.1
  • libgstsctp-1_0-0 >= 1.22.9-1.1
  • libgstsctp-1_0-0-32bit >= 1.22.9-1.1
  • libgsttranscoder-1_0-0 >= 1.22.9-1.1
  • libgsttranscoder-1_0-0-32bit >= 1.22.9-1.1
  • libgsturidownloader-1_0-0 >= 1.22.9-1.1
  • libgsturidownloader-1_0-0-32bit >= 1.22.9-1.1
  • libgstva-1_0-0 >= 1.22.9-1.1
  • libgstva-1_0-0-32bit >= 1.22.9-1.1
  • libgstvulkan-1_0-0 >= 1.22.9-1.1
  • libgstvulkan-1_0-0-32bit >= 1.22.9-1.1
  • libgstwayland-1_0-0 >= 1.22.9-1.1
  • libgstwayland-1_0-0-32bit >= 1.22.9-1.1
  • libgstwebrtc-1_0-0 >= 1.22.9-1.1
  • libgstwebrtc-1_0-0-32bit >= 1.22.9-1.1
  • libgstwebrtcnice-1_0-0 >= 1.22.9-1.1
  • libgstwebrtcnice-1_0-0-32bit >= 1.22.9-1.1
  • typelib-1_0-CudaGst-1_0 >= 1.22.9-1.1
  • typelib-1_0-GstBadAudio-1_0 >= 1.22.9-1.1
  • typelib-1_0-GstCodecs-1_0 >= 1.22.9-1.1
  • typelib-1_0-GstCuda-1_0 >= 1.22.9-1.1
  • typelib-1_0-GstInsertBin-1_0 >= 1.22.9-1.1
  • typelib-1_0-GstMpegts-1_0 >= 1.22.9-1.1
  • typelib-1_0-GstPlay-1_0 >= 1.22.9-1.1
  • typelib-1_0-GstPlayer-1_0 >= 1.22.9-1.1
  • typelib-1_0-GstTranscoder-1_0 >= 1.22.9-1.1
  • typelib-1_0-GstVa-1_0 >= 1.22.9-1.1
  • typelib-1_0-GstVulkan-1_0 >= 1.22.9-1.1
  • typelib-1_0-GstVulkanWayland-1_0 >= 1.22.9-1.1
  • typelib-1_0-GstVulkanXCB-1_0 >= 1.22.9-1.1
  • typelib-1_0-GstWebRTC-1_0 >= 1.22.9-1.1
Patchnames:
openSUSE-Tumbleweed-2024-13649


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification. The updates are grouped by state of their lifecycle. SUSE product lifecycles are documented on the lifecycle page.

Product(s) Source package State
Products under general support and receiving all security fixes.
SUSE Enterprise Storage 7.1 gstreamer-plugins-bad Not affected
SUSE Linux Enterprise Desktop 15 SP5 gstreamer-plugins-bad Affected
SUSE Linux Enterprise Desktop 15 SP6 gstreamer-plugins-bad Already fixed
SUSE Linux Enterprise High Performance Computing 12 SP5 gstreamer-plugins-bad Not affected
SUSE Linux Enterprise High Performance Computing 15 SP5 gstreamer-plugins-bad Affected
SUSE Linux Enterprise High Performance Computing 15 SP6 gstreamer-plugins-bad Already fixed
SUSE Linux Enterprise Module for Basesystem 15 SP5 gstreamer-plugins-bad Affected
SUSE Linux Enterprise Module for Basesystem 15 SP6 gstreamer-plugins-bad Already fixed
SUSE Linux Enterprise Module for Desktop Applications 15 SP5 gstreamer-plugins-bad Affected
SUSE Linux Enterprise Module for Desktop Applications 15 SP6 gstreamer-plugins-bad Already fixed
SUSE Linux Enterprise Module for Package Hub 15 SP5 gstreamer-plugins-bad Affected
SUSE Linux Enterprise Module for Package Hub 15 SP6 gstreamer-plugins-bad Already fixed
SUSE Linux Enterprise Server 12 SP5 gstreamer-plugins-bad Not affected
SUSE Linux Enterprise Server 15 SP5 gstreamer-plugins-bad Affected
SUSE Linux Enterprise Server 15 SP6 gstreamer-plugins-bad Already fixed
SUSE Linux Enterprise Server for SAP Applications 12 SP5 gstreamer-plugins-bad Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP5 gstreamer-plugins-bad Affected
SUSE Linux Enterprise Server for SAP Applications 15 SP6 gstreamer-plugins-bad Already fixed
SUSE Linux Enterprise Software Development Kit 12 SP5 gstreamer-plugins-bad Not affected
SUSE Manager Proxy 4.3 gstreamer-plugins-bad Affected
SUSE Manager Retail Branch Server 4.3 gstreamer-plugins-bad Affected
SUSE Manager Server 4.3 gstreamer-plugins-bad Affected
Products under Long Term Service Pack support and receiving important and critical security fixes.
SUSE Linux Enterprise Desktop 15 SP4 gstreamer-plugins-bad Affected
SUSE Linux Enterprise High Performance Computing 15 SP2 gstreamer-plugins-bad Not affected
SUSE Linux Enterprise High Performance Computing 15 SP2-ESPOS gstreamer-plugins-bad Not affected
SUSE Linux Enterprise High Performance Computing 15 SP2-LTSS gstreamer-plugins-bad Not affected
SUSE Linux Enterprise High Performance Computing 15 SP3 gstreamer-plugins-bad Not affected
SUSE Linux Enterprise High Performance Computing 15 SP3-ESPOS gstreamer-plugins-bad Not affected
SUSE Linux Enterprise High Performance Computing 15 SP3-LTSS gstreamer-plugins-bad Not affected
SUSE Linux Enterprise High Performance Computing 15 SP4 gstreamer-plugins-bad Affected
SUSE Linux Enterprise High Performance Computing 15 SP4-ESPOS gstreamer-plugins-bad Affected
SUSE Linux Enterprise High Performance Computing 15 SP4-LTSS gstreamer-plugins-bad Affected
SUSE Linux Enterprise Module for Basesystem 15 SP2 gstreamer-plugins-bad Not affected
SUSE Linux Enterprise Module for Basesystem 15 SP3 gstreamer-plugins-bad Not affected
SUSE Linux Enterprise Module for Basesystem 15 SP4 gstreamer-plugins-bad Affected
SUSE Linux Enterprise Module for Desktop Applications 15 SP2 gstreamer-plugins-bad Not affected
SUSE Linux Enterprise Module for Desktop Applications 15 SP3 gstreamer-plugins-bad Not affected
SUSE Linux Enterprise Module for Desktop Applications 15 SP4 gstreamer-plugins-bad Affected
SUSE Linux Enterprise Server 15 SP2 gstreamer-plugins-bad Not affected
SUSE Linux Enterprise Server 15 SP2-LTSS gstreamer-plugins-bad Not affected
SUSE Linux Enterprise Server 15 SP3 gstreamer-plugins-bad Not affected
SUSE Linux Enterprise Server 15 SP3-LTSS gstreamer-plugins-bad Not affected
SUSE Linux Enterprise Server 15 SP4 gstreamer-plugins-bad Affected
SUSE Linux Enterprise Server 15 SP4-LTSS gstreamer-plugins-bad Affected
SUSE Linux Enterprise Server for SAP Applications 15 SP2 gstreamer-plugins-bad Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP3 gstreamer-plugins-bad Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP4 gstreamer-plugins-bad Affected
Products past their end of life and not receiving proactive updates anymore.
HPE Helion OpenStack 8 gstreamer-plugins-bad Not affected
SUSE CaaS Platform 4.0 gstreamer-plugins-bad Not affected
SUSE Enterprise Storage 6 gstreamer-plugins-bad Not affected
SUSE Enterprise Storage 7 gstreamer-plugins-bad Not affected
SUSE Linux Enterprise Desktop 12 gstreamer-plugins-bad Not affected
SUSE Linux Enterprise Desktop 12 SP1 gstreamer-plugins-bad Not affected
SUSE Linux Enterprise Desktop 12 SP2 gstreamer-plugins-bad Not affected
SUSE Linux Enterprise Desktop 12 SP3 gstreamer-plugins-bad Not affected
SUSE Linux Enterprise Desktop 12 SP4 gstreamer-plugins-bad Not affected
SUSE Linux Enterprise Desktop 15 gstreamer-plugins-bad Not affected
SUSE Linux Enterprise Desktop 15 SP1 gstreamer-plugins-bad Not affected
SUSE Linux Enterprise Desktop 15 SP2 gstreamer-plugins-bad Not affected
SUSE Linux Enterprise Desktop 15 SP3 gstreamer-plugins-bad Not affected
SUSE Linux Enterprise High Performance Computing 15 gstreamer-plugins-bad Not affected
SUSE Linux Enterprise High Performance Computing 15 SP1 gstreamer-plugins-bad Not affected
SUSE Linux Enterprise High Performance Computing 15 SP1-ESPOS gstreamer-plugins-bad Not affected
SUSE Linux Enterprise High Performance Computing 15 SP1-LTSS gstreamer-plugins-bad Not affected
SUSE Linux Enterprise High Performance Computing 15-ESPOS gstreamer-plugins-bad Not affected
SUSE Linux Enterprise High Performance Computing 15-LTSS gstreamer-plugins-bad Not affected
SUSE Linux Enterprise Module for Basesystem 15 gstreamer-plugins-bad Not affected
SUSE Linux Enterprise Module for Basesystem 15 SP1 gstreamer-plugins-bad Not affected
SUSE Linux Enterprise Module for Desktop Applications 15 gstreamer-plugins-bad Not affected
SUSE Linux Enterprise Module for Desktop Applications 15 SP1 gstreamer-plugins-bad Not affected
SUSE Linux Enterprise Module for Package Hub 15 SP4 gstreamer-plugins-bad Affected
SUSE Linux Enterprise Real Time 15 SP2 gstreamer-plugins-bad Not affected
SUSE Linux Enterprise Real Time 15 SP3 gstreamer-plugins-bad Not affected
SUSE Linux Enterprise Real Time 15 SP4 gstreamer-plugins-bad Affected
SUSE Linux Enterprise Server 12 gstreamer-plugins-bad Not affected
SUSE Linux Enterprise Server 12 SP1 gstreamer-plugins-bad Not affected
SUSE Linux Enterprise Server 12 SP1-LTSS gstreamer-plugins-bad Not affected
SUSE Linux Enterprise Server 12 SP2 gstreamer-plugins-bad Not affected
SUSE Linux Enterprise Server 12 SP2-BCL gstreamer-plugins-bad Not affected
SUSE Linux Enterprise Server 12 SP2-ESPOS gstreamer-plugins-bad Not affected
SUSE Linux Enterprise Server 12 SP2-LTSS gstreamer-plugins-bad Not affected
SUSE Linux Enterprise Server 12 SP3 gstreamer-plugins-bad Not affected
SUSE Linux Enterprise Server 12 SP3-BCL gstreamer-plugins-bad Not affected
SUSE Linux Enterprise Server 12 SP3-ESPOS gstreamer-plugins-bad Not affected
SUSE Linux Enterprise Server 12 SP3-LTSS gstreamer-plugins-bad Not affected
SUSE Linux Enterprise Server 12 SP4 gstreamer-plugins-bad Not affected
SUSE Linux Enterprise Server 12 SP4-ESPOS gstreamer-plugins-bad Not affected
SUSE Linux Enterprise Server 12 SP4-LTSS gstreamer-plugins-bad Not affected
SUSE Linux Enterprise Server 12-LTSS gstreamer-plugins-bad Not affected
SUSE Linux Enterprise Server 15 gstreamer-plugins-bad Not affected
SUSE Linux Enterprise Server 15 SP1 gstreamer-plugins-bad Not affected
SUSE Linux Enterprise Server 15 SP1-BCL gstreamer-plugins-bad Not affected
SUSE Linux Enterprise Server 15 SP1-LTSS gstreamer-plugins-bad Not affected
SUSE Linux Enterprise Server 15 SP2-BCL gstreamer-plugins-bad Not affected
SUSE Linux Enterprise Server 15 SP3-BCL gstreamer-plugins-bad Not affected
SUSE Linux Enterprise Server 15-LTSS gstreamer-plugins-bad Not affected
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2 gstreamer-plugins-bad Not affected
SUSE Linux Enterprise Server for SAP Applications 12 gstreamer-plugins-bad Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP1 gstreamer-plugins-bad Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP2 gstreamer-plugins-bad Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP3 gstreamer-plugins-bad Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP4 gstreamer-plugins-bad Not affected
SUSE Linux Enterprise Server for SAP Applications 15 gstreamer-plugins-bad Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP1 gstreamer-plugins-bad Not affected
SUSE Linux Enterprise Software Development Kit 12 gstreamer-plugins-bad Not affected
SUSE Linux Enterprise Software Development Kit 12 SP1 gstreamer-plugins-bad Not affected
SUSE Linux Enterprise Software Development Kit 12 SP2 gstreamer-plugins-bad Not affected
SUSE Linux Enterprise Software Development Kit 12 SP3 gstreamer-plugins-bad Not affected
SUSE Linux Enterprise Software Development Kit 12 SP4 gstreamer-plugins-bad Not affected
SUSE Manager Proxy 4.0 gstreamer-plugins-bad Not affected
SUSE Manager Proxy 4.1 gstreamer-plugins-bad Not affected
SUSE Manager Proxy 4.2 gstreamer-plugins-bad Not affected
SUSE Manager Retail Branch Server 4.0 gstreamer-plugins-bad Not affected
SUSE Manager Retail Branch Server 4.1 gstreamer-plugins-bad Not affected
SUSE Manager Retail Branch Server 4.2 gstreamer-plugins-bad Not affected
SUSE Manager Server 4.0 gstreamer-plugins-bad Not affected
SUSE Manager Server 4.1 gstreamer-plugins-bad Not affected
SUSE Manager Server 4.2 gstreamer-plugins-bad Not affected
SUSE OpenStack Cloud 7 gstreamer-plugins-bad Not affected
SUSE OpenStack Cloud 8 gstreamer-plugins-bad Not affected
SUSE OpenStack Cloud 9 gstreamer-plugins-bad Not affected
SUSE OpenStack Cloud Crowbar 8 gstreamer-plugins-bad Not affected
SUSE OpenStack Cloud Crowbar 9 gstreamer-plugins-bad Not affected


SUSE Timeline for this CVE

CVE page created: Thu Feb 1 16:00:05 2024
CVE page last modified: Sun Jun 16 03:01:13 2024