Upstream information

CVE-2023-5841 at MITRE

Description

Due to a failure in validating the number of scanline samples of a OpenEXR file containing deep scanline data, Academy Software Foundation OpenEX image parsing library version 3.2.1 and prior is susceptible to a heap-based buffer overflow vulnerability. This issue was resolved as of versions v3.2.2 and v3.1.12 of the affected library.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 9.1 5.9
Vector CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
Attack Vector Network Local
Attack Complexity Low Low
Privileges Required None None
User Interaction None None
Scope Unchanged Unchanged
Confidentiality Impact High Low
Integrity Impact High Low
Availability Impact None Low
CVSSv3 Version 3.1 3.1
SUSE Bugzilla entry: 1219498 [NEW]

No SUSE Security Announcements cross referenced.

List of released packages

Product(s) Fixed package version(s) References
openSUSE Tumbleweed
  • libIex-3_1-30-32bit >= 3.1.11-1.3
  • libIex-3_2-31 >= 3.2.2-1.1
  • libIlmThread-3_1-30-32bit >= 3.1.11-1.3
  • libIlmThread-3_2-31 >= 3.2.2-1.1
  • libOpenEXR-3_1-30-32bit >= 3.1.11-1.3
  • libOpenEXR-3_2-31 >= 3.2.2-1.1
  • libOpenEXRCore-3_1-30-32bit >= 3.1.11-1.3
  • libOpenEXRCore-3_2-31 >= 3.2.2-1.1
  • libOpenEXRUtil-3_1-30-32bit >= 3.1.11-1.3
  • libOpenEXRUtil-3_2-31 >= 3.2.2-1.1
  • openexr >= 3.2.2-1.1
  • openexr-devel >= 3.2.2-1.1
  • openexr-doc >= 3.2.2-1.1
Patchnames:
openSUSE Tumbleweed GA libIex-3_1-30-32bit-3.1.11-1.3


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification. The updates are grouped by state of their lifecycle. SUSE product lifecycles are documented on the lifecycle page.

Product(s) Source package State
Products under general support and receiving all security fixes.
SUSE Enterprise Storage 7.1 openexr Not affected
SUSE Linux Enterprise Desktop 15 SP5 openexr Not affected
SUSE Linux Enterprise High Performance Computing 12 SP5 openexr Not affected
SUSE Linux Enterprise High Performance Computing 15 SP5 openexr Not affected
SUSE Linux Enterprise Module for Desktop Applications 15 SP5 openexr Not affected
SUSE Linux Enterprise Module for Package Hub 15 SP5 openexr Not affected
SUSE Linux Enterprise Real Time 15 SP3 openexr Not affected
SUSE Linux Enterprise Server 12 SP5 openexr Not affected
SUSE Linux Enterprise Server 12-LTSS openexr Not affected
SUSE Linux Enterprise Server 15 SP5 openexr Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP5 openexr Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP4 openexr Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP5 openexr Not affected
SUSE Linux Enterprise Software Development Kit 12 SP5 openexr Not affected
SUSE Linux Enterprise Workstation Extension 12 SP5 openexr Not affected
SUSE Manager Proxy 4.3 openexr Not affected
SUSE Manager Retail Branch Server 4.3 openexr Not affected
SUSE Manager Server 4.3 openexr Not affected
Products under Long Term Service Pack support and receiving important and critical security fixes.
SUSE Linux Enterprise Desktop 15 SP4 openexr Not affected
SUSE Linux Enterprise High Performance Computing 15 openexr Not affected
SUSE Linux Enterprise High Performance Computing 15 SP1 openexr Not affected
SUSE Linux Enterprise High Performance Computing 15 SP1-ESPOS openexr Not affected
SUSE Linux Enterprise High Performance Computing 15 SP1-LTSS openexr Not affected
SUSE Linux Enterprise High Performance Computing 15 SP2 openexr Not affected
SUSE Linux Enterprise High Performance Computing 15 SP2-ESPOS openexr Not affected
SUSE Linux Enterprise High Performance Computing 15 SP2-LTSS openexr Not affected
SUSE Linux Enterprise High Performance Computing 15 SP3 openexr Not affected
SUSE Linux Enterprise High Performance Computing 15 SP3-ESPOS openexr Not affected
SUSE Linux Enterprise High Performance Computing 15 SP3-LTSS openexr Not affected
SUSE Linux Enterprise High Performance Computing 15 SP4 openexr Not affected
SUSE Linux Enterprise High Performance Computing 15 SP4-ESPOS openexr Not affected
SUSE Linux Enterprise High Performance Computing 15 SP4-LTSS openexr Not affected
SUSE Linux Enterprise High Performance Computing 15-ESPOS openexr Not affected
SUSE Linux Enterprise High Performance Computing 15-LTSS openexr Not affected
SUSE Linux Enterprise Module for Desktop Applications 15 SP2 openexr Not affected
SUSE Linux Enterprise Module for Desktop Applications 15 SP3 openexr Not affected
SUSE Linux Enterprise Module for Desktop Applications 15 SP4 openexr Not affected
SUSE Linux Enterprise Server 15 SP2 openexr Not affected
SUSE Linux Enterprise Server 15 SP2-LTSS openexr Not affected
SUSE Linux Enterprise Server 15 SP3 openexr Not affected
SUSE Linux Enterprise Server 15 SP3-LTSS openexr Not affected
SUSE Linux Enterprise Server 15 SP4 openexr Not affected
SUSE Linux Enterprise Server 15 SP4-LTSS openexr Not affected
SUSE Linux Enterprise Server for SAP Applications 15 openexr Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP1 openexr Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP2 openexr Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP3 openexr Not affected
Products past their end of life and not receiving proactive updates anymore.
HPE Helion OpenStack 8 openexr Not affected
SUSE CaaS Platform 4.0 openexr Not affected
SUSE Enterprise Storage 6 openexr Not affected
SUSE Enterprise Storage 7 openexr Not affected
SUSE Linux Enterprise Desktop 11 SP4 OpenEXR Not affected
SUSE Linux Enterprise Desktop 12 openexr Not affected
SUSE Linux Enterprise Desktop 12 SP1 openexr Not affected
SUSE Linux Enterprise Desktop 12 SP2 openexr Not affected
SUSE Linux Enterprise Desktop 12 SP3 openexr Not affected
SUSE Linux Enterprise Desktop 12 SP4 openexr Not affected
SUSE Linux Enterprise Desktop 15 openexr Not affected
SUSE Linux Enterprise Desktop 15 SP1 openexr Not affected
SUSE Linux Enterprise Desktop 15 SP2 openexr Not affected
SUSE Linux Enterprise Desktop 15 SP3 openexr Not affected
SUSE Linux Enterprise Module for Desktop Applications 15 openexr Not affected
SUSE Linux Enterprise Module for Desktop Applications 15 SP1 openexr Not affected
SUSE Linux Enterprise Module for Package Hub 15 SP4 openexr Not affected
SUSE Linux Enterprise Real Time 15 SP2 openexr Not affected
SUSE Linux Enterprise Real Time 15 SP4 openexr Not affected
SUSE Linux Enterprise Server 11 SP3 OpenEXR Not affected
SUSE Linux Enterprise Server 11 SP3-LTSS OpenEXR Not affected
SUSE Linux Enterprise Server 11 SP4 OpenEXR Not affected
SUSE Linux Enterprise Server 11 SP4 LTSS OpenEXR Not affected
SUSE Linux Enterprise Server 11 SP4-LTSS OpenEXR Not affected
SUSE Linux Enterprise Server 12 openexr Not affected
SUSE Linux Enterprise Server 12 SP1 openexr Not affected
SUSE Linux Enterprise Server 12 SP1-LTSS openexr Not affected
SUSE Linux Enterprise Server 12 SP2 openexr Not affected
SUSE Linux Enterprise Server 12 SP2-BCL openexr Not affected
SUSE Linux Enterprise Server 12 SP2-ESPOS openexr Not affected
SUSE Linux Enterprise Server 12 SP2-LTSS openexr Not affected
SUSE Linux Enterprise Server 12 SP3 openexr Not affected
SUSE Linux Enterprise Server 12 SP3-BCL openexr Not affected
SUSE Linux Enterprise Server 12 SP3-ESPOS openexr Not affected
SUSE Linux Enterprise Server 12 SP3-LTSS openexr Not affected
SUSE Linux Enterprise Server 12 SP4 openexr Not affected
SUSE Linux Enterprise Server 12 SP4-ESPOS openexr Not affected
SUSE Linux Enterprise Server 12 SP4-LTSS openexr Not affected
SUSE Linux Enterprise Server 15 openexr Not affected
SUSE Linux Enterprise Server 15 SP1 openexr Not affected
SUSE Linux Enterprise Server 15 SP1-BCL openexr Not affected
SUSE Linux Enterprise Server 15 SP1-LTSS openexr Not affected
SUSE Linux Enterprise Server 15 SP2-BCL openexr Not affected
SUSE Linux Enterprise Server 15 SP3-BCL openexr Not affected
SUSE Linux Enterprise Server 15-LTSS openexr Not affected
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2 openexr Not affected
SUSE Linux Enterprise Server for SAP Applications 11 SP4 OpenEXR Not affected
SUSE Linux Enterprise Server for SAP Applications 12 openexr Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP1 openexr Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP2 openexr Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP3 openexr Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP4 openexr Not affected
SUSE Linux Enterprise Software Development Kit 11 SP4 OpenEXR Not affected
SUSE Linux Enterprise Software Development Kit 12 openexr Not affected
SUSE Linux Enterprise Software Development Kit 12 SP1 openexr Not affected
SUSE Linux Enterprise Software Development Kit 12 SP2 openexr Not affected
SUSE Linux Enterprise Software Development Kit 12 SP3 openexr Not affected
SUSE Linux Enterprise Software Development Kit 12 SP4 openexr Not affected
SUSE Linux Enterprise Workstation Extension 12 openexr Not affected
SUSE Linux Enterprise Workstation Extension 12 SP1 openexr Not affected
SUSE Linux Enterprise Workstation Extension 12 SP2 openexr Not affected
SUSE Linux Enterprise Workstation Extension 12 SP3 openexr Not affected
SUSE Linux Enterprise Workstation Extension 12 SP4 openexr Not affected
SUSE Manager Proxy 4.0 openexr Not affected
SUSE Manager Proxy 4.1 openexr Not affected
SUSE Manager Proxy 4.2 openexr Not affected
SUSE Manager Retail Branch Server 4.0 openexr Not affected
SUSE Manager Retail Branch Server 4.1 openexr Not affected
SUSE Manager Retail Branch Server 4.2 openexr Not affected
SUSE Manager Server 4.0 openexr Not affected
SUSE Manager Server 4.1 openexr Not affected
SUSE Manager Server 4.2 openexr Not affected
SUSE OpenStack Cloud 7 openexr Not affected
SUSE OpenStack Cloud 8 openexr Not affected
SUSE OpenStack Cloud 9 openexr Not affected
SUSE OpenStack Cloud Crowbar 8 openexr Not affected
SUSE OpenStack Cloud Crowbar 9 openexr Not affected


SUSE Timeline for this CVE

CVE page created: Thu Feb 1 21:00:20 2024
CVE page last modified: Fri Apr 12 12:08:06 2024